X86 router vlan 2 nic

Hello,

I have the following connections:

ISP <-> x86 <-> ap1

ap1 is dsa compatible, so vlan is straight forward

lan1 10:u*
lan2 10:u*
lan3 t
wifi1 90u*

x86 doesnt seem to be dsa compatible.

has

eht0 lan
eth1 wan

How can i apply vlan on the eth0?

Thanks in advance

Use dotted notation. For example:

VLAN 10 tagged on eth0 --> eth0.10
eth0 on its own will be an untagged network.

ap side:

network


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd6a:2d70:f42f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'kids2.13'
	list ports 'kids5.13'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.10.1'
	option device 'br-lan.10'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'kids'
	option proto 'static'
	option ipaddr '192.168.13.1'
	option netmask '255.255.255.0'
	option device 'br-lan.13'

config device
	option type '8021q'
	option ifname 'kids2'
	option vid '13'
	option name 'kids2.13'

config device
	option type '8021q'
	option ifname 'kids5'
	option vid '13'
	option name 'kids5.13'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan2:u*'
	list ports 'lan3:t'
	list ports 'm2.10:u*'
	list ports 'm5.10:u*'

x86 side

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd6a:2d70:f42f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.10:u*'
	list ports 'eth0.13:u*'
	list ports 'eth0' <.... ?????

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.10.1'
	option device 'eth.10'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'kids'
	option proto 'static'
	option ipaddr '192.168.13.1'
	option netmask '255.255.255.0'
	option device 'eth.13'

ap connects x86 on lan3 (t is correct, or should be u??)

eth0 should be eth0:u? that's my confusion

Thanks for helping

There are quite a lot of issues here. Instead of recommending changes based on guesses/assumptions about the intent, let's get the intent first.

What is your goal? It looks like you want a main lan and a kids network, is that correct?

Is the x86 the main router?

And is the AP just a 'dumb AP'?

1 Like

Yes main lan and kids network

X86 is main router and the other will be a dumb ap

Ok... let's start by resetting both devices to defaults. Post the network config files for each device after they are in their default state.

here they are

x86:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2b:bba6:7c3a::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

dumb ap

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd15:20c3:fbc8::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

Add this to the x86 machine:

config interface 'kids'
	option proto 'static'
	option ipaddr '192.168.13.1'
	option netmask '255.255.255.0'
	option device 'eth0.13'

Don't forget to add a DHCP server to this new network, and for simplicity for now, just add this network to the lan firewall zone (if you want different rules, that can come later).

On the AP, I'll assume that you're connecting via port lan1:

Create bridge VLANs:

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '13'
        list ports 'lan1:t'
        list ports 'lan3:u*'

Edit your AP's lan interface as follows:

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'

And then add an unmanged interface for the kids network:

config interface 'kids'
        option device 'br-lan.13'
        option proto 'none'

Add a wireless SSID with and associate it with the kids network.

That should do it. I've also setup port lan2 on your AP to be the regular lan, and port lan3 is the kids network... so you can verify that the kids network is working properly by plugging a computer directly into port lan3.

Thanks for your help!

All working.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.