X86 router can ping www.google.com but on my computer is 'Destination Port Unreachable'

I user a x86 openwork router ,using open clash as a proxy tool(Fake ip tun mode)
I can success full ping www.goolgle.com, but on my computer can not

my firewall config

root@OpenWrt:/etc/config# uci show firewall.@zone[1]
firewall.cfg03dc81=zone
firewall.cfg03dc81.name='wan'
firewall.cfg03dc81.input='REJECT'
firewall.cfg03dc81.output='ACCEPT'
firewall.cfg03dc81.forward='REJECT'
firewall.cfg03dc81.masq='1'
firewall.cfg03dc81.mtu_fix='1'
firewall.cfg03dc81.network='wan' 'wan6' 'tun0'

my network config

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.5.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth1'
	option proto 'pppoe'
	option username '19382095824'
	option password '095824'
	option ipv6 'auto'

config interface 'vpn0'
	option proto 'none'
	option device 'tun0'

config interface 'docker'
	option device 'docker0'
	option proto 'none'
	option auto '0'

config device
	option type 'bridge'
	option name 'docker0'

config device
	option name 'eth2'

on my computer

wuxin@WUXIN-MBP ~ % ping www.google.com
PING www.google.com (198.18.0.5): 56 data bytes
92 bytes from openwrt.lan (192.168.5.1): Destination Port Unreachable
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 5400 feb1   0 0000  3f  01 f0ce 192.168.5.105  198.18.0.5 

Request timeout for icmp_seq 0
92 bytes from openwrt.lan (192.168.5.1): Destination Port Unreachable
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 5400 0c81   0 0000  3f  01 e2ff 192.168.5.105  198.18.0.5 

on my x86 router

root@OpenWrt:/etc/config# ping www.google.com
PING www.google.com (198.18.0.5): 56 data bytes
64 bytes from 198.18.0.5: seq=0 ttl=64 time=0.187 ms
64 bytes from 198.18.0.5: seq=1 ttl=64 time=0.288 ms
64 bytes from 198.18.0.5: seq=2 ttl=64 time=0.288 ms

Are you trying to route through the tunnel?

Traffic from the router to the internet is unlikely to go through the tunnel, if your pc is being routed through that interface I’d suggest the tunnel is not working

no, not route through the tunnel
on my computer I can use the network perfectly exclude in Terminal
when I ping the google in terminal it will show


but in the router ping google is success

Port unreachable means firewall issue.

This is the behaviour you would expect if you have a firewall rule in the FORWARD table that has a "-j REJECT" option for ICMP.

However, I'm uncertain that this is the reason for the behaviour you're seeing. Your DNS looks broken.

The IP network 198.18.0.0/15 is categorically NOT a Google server, since this is an IANA reserved network, basically a special-use private IP range like the 192.168.5.0/24 network you're using for your local network.

3 Likes

And furthermore the time response is clearly extremely low, indicating a router self response, not a WAN server response.

3 Likes

the wan and lan ports haven't by any chance gotten reversed ?
it can happen during boot...

1 Like

it might be firewall issue, how can i check firewall config or how can i solve it.sorry i Ask a very stupid question

yeah it might be firewall issue,the goods the ip is not correct beacuse i use a proxy as geatway mode。how can i check the firewallconfig,sorry i ask this stupid question

i think my problem is same with this question Destination Port Unreachable - #6 by username1
i did every method that posting was given, but the issue is still exist

  1. Show the whole config (i.e. LAN, etc.).
  2. Did you change any firewall configs - other than adding the tun interface to WAN?

The issue has been solved, I didn't do anything , the network is back to normal, I can ping every url on my computer and my router through CLI. I don't know why .thank you bro.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.