X86 only NICs in Failsafe

I have tried to install OpenWrt on X86 on usb and ssd (physdiskwrite.exe). Both with same result no network. NICs working in windows, dd wrt and ubuntu on that x86 pc. But when I have installed openwrt - the network is not responding only in failsafe but cant get inside GUI.

What could be the problem? Stick to dd-wrt :slight_smile:

Do you have any idea what the hardware chipset is on the NICs? perhaps you need to grab some packages and install drivers for an unusual NIC? Or just buy a cheap new well supported dual port NIC? Maybe $20-30


Only a few Ethernet drivers are included in the x86 release build. As @dlakelan said you'll need to identify your hardware and install the driver package. Easiest way is to check the kernel log of one of the other OS to see which driver is in use. Use another system to download the package and store it in the media filesystem then boot up OpenWrt and install with the CLI terminal.

1 Like



Thanks for your help

How to install?
I'm not sure
https://openwrt.org/packages/index/start what to choose?
.....like that?