X86 machine with qca9882 mini pci card (not embedded)

Guyz I just purchased a mini pci-e card which as qca9882 chip. I am using a x86 system with openwrt and have compiled the ath10k drivers. when I boot the device the mini pci-e card wont show in devices at all. while if I change the card with old intel mini pci-e card it works right away. but when I plug this qca9882 card it wont show at all.... guyz please need help
The card is as follows:

any help would be appreciated.

dmesg and `lspci' should provide some clues.

nothing on dmesg. and lspci is showing only the pcie buses nothing particular to this module.
however when I switched to intel pcie module the wireless file showed me this:
option path 'pci0000:00/0000:00:1c.3/0000:0a:00.0'
so it means that at 0000:00:1c.3 the device should appear right? because when I go to /sys/bus/pci/devices/0000:00:1c.3 I see this 0000:0a:00.0
but this is not the case with qca9882 pcie module. when I go to the above location I dont see anything...

check the card design to see if you need to mask out any of the pins. it is also possible your x86? system does not enable it properly.

i have qca9862 in my laptop and if i load disk image cloning distro (or some similar distro that screws hw configuration) i can't get wifi or bluetooth to show up in my linux os no matter if used rfkill to unblock devices or disable/enable them through bios. what helps in this case is to boot ubuntu 16.04 live usb which re-enables the hardware and is recognized properly afterwards

ok turns out that there was some problem with my board. my board was not supporting this card in the pcie slot so I tried to used it with ubuntu in my laptop. it works. changes a few things in the board and now it works. but the problem is even worse now....

I can see the driver is loaded but the wlan0 interface is not up. here are the logs

[    9.294889] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   10.074465] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
[   10.087893] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043222ff sub 0000:0000
[   10.100129] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   10.111946] ath10k_pci 0000:02:00.0: firmware ver 10.2.4-1.0-00041 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 f43fa422
[   10.241454] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[   10.253546] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 c04add5c
[   10.367020] ath10k_pci 0000:02:00.0: failed to get board id: -95
[   11.530369] ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[   11.654155] ath: EEPROM regdomain: 0x0
[   11.654163] ath: EEPROM indicates default country code should be used
[   11.654167] ath: doing EEPROM country->regdmn map search
[   11.654174] ath: country maps to regdmn code: 0x3a
[   11.654179] ath: Country alpha2 being used: US
[   11.654183] ath: Regpair used: 0x3a

I know it has got something to do with art partition but the problem is that in x86 there is no art partition. and there is no mtd in x86 systems...
need help urgently guyz!!!!

PCIe cards have their ART data stored in an EEPROM chip on the card itself. The driver should find it. Here it appears that the default country of US was read from the EEPROM.

Does iw list show anything?

Thank you guyz. you are right. I was worried about the ART partition but the problem was hostapd not compiled.... it was such a silly mistake. The ART partition must be residing in the EEPROM and the driver found it.
Thanks for your help all!

1 Like