X86/64 -- missing eth2/eth3 on Sophos SG-105

I picked up an Atom E3826-based Sophos SG-105 appliance earlier today and installed 19.07.7 on it (and resized second partition).

The back of the router has the following ports/markings:
eth0 - LAN
eth1 - WAN
eth2 - DMZ
eth3 - HA

The eth0 and eth1 are detected by OpenWrt:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd89:94c7:53cd::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

But ports eth2/eth3 do not seem to work at all. My understanding was it only has Intel network hardware inside, but obviosuly something doesn't get detected. As I have zero experience with this kind of stuff I would appreciate some tips as to how to try to take this further.

dmesg: https://pastebin.com/HHQQ5rXe

PS. Bonus question -- is remapping eth0 to WAN and eth1 to LAN as easy as just modifying values in the /etc/config/network or is it more involved than that?

The easiest approach for x86_64 systems would probably be to boot a recent generic[0] linux (live medium) and to check "lspci -knn" what it detects.

--
[0] arch, debian, fedora, gentoo, mageia, mandriva, opensuse, whatever you're most comfortable with - as long as it's semi-recent.

Thanks, the monitor/keyboard are not easily accessible to me, do these lines from dmesg shed any light:

[    7.573116] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[    7.581054] e1000: Copyright (c) 1999-2006 Intel Corporation.
[    7.589566] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.4.0-k
[    7.597505] igb: Copyright (c) 2007-2014 Intel Corporation.
[    7.837252] pps pps0: new PPS source ptp0
[    7.841835] igb 0000:01:00.0: added PHC on eth0
[    7.846901] igb 0000:01:00.0: Intel(R) Gigabit Ethernet Network Connection
[    7.854601] igb 0000:01:00.0: eth0: (PCIe:2.5Gb/s:Width x1) 00:1a:8c:40:93:dc
[    7.862588] igb 0000:01:00.0: eth0: PBA No: FFFFFF-0FF
[    7.868333] igb 0000:01:00.0: Using MSI-X interrupts. 2 rx queue(s), 2 tx queue(s)
[    8.110344] pps pps1: new PPS source ptp1
[    8.114900] igb 0000:02:00.0: added PHC on eth1
[    8.119966] igb 0000:02:00.0: Intel(R) Gigabit Ethernet Network Connection
[    8.127674] igb 0000:02:00.0: eth1: (PCIe:2.5Gb/s:Width x1) 00:1a:8c:40:93:dd
[    8.135661] igb 0000:02:00.0: eth1: PBA No: FFFFFF-0FF
[    8.141414] igb 0000:02:00.0: Using MSI-X interrupts. 2 rx queue(s), 2 tx queue(s)
[    8.384680] pps pps2: new PPS source ptp2
[    8.389243] igb 0000:03:00.0: added PHC on eth2
[    8.394336] igb 0000:03:00.0: Intel(R) Gigabit Ethernet Network Connection
[    8.402034] igb 0000:03:00.0: eth2: (PCIe:2.5Gb/s:Width x1) 00:1a:8c:40:93:de
[    8.410017] igb 0000:03:00.0: eth2: PBA No: FFFFFF-0FF
[    8.415762] igb 0000:03:00.0: Using MSI-X interrupts. 2 rx queue(s), 2 tx queue(s)
[    8.657312] pps pps3: new PPS source ptp3
[    8.661896] igb 0000:06:00.0: added PHC on eth3
[    8.666963] igb 0000:06:00.0: Intel(R) Gigabit Ethernet Network Connection
[    8.674662] igb 0000:06:00.0: eth3: (PCIe:2.5Gb/s:Width x1) 00:1a:8c:40:93:df
[    8.682650] igb 0000:06:00.0: eth3: PBA No: FFFFFF-0FF
[    8.688396] igb 0000:06:00.0: Using MSI-X interrupts. 2 rx queue(s), 2 tx queue(s)

Not really, but assuming it's indeed all intel, you could try:

  • kmod-e1000 (installed by default)
  • kmod-e1000e (only installed by default for x86_64)
  • kmod-igb (only installed by default for x86_64)
  • kmod-igbvf
  • kmod-ixgbe
  • kmod-ixgbevf
  • kmod-i40e
  • kmod-iavf

Edit: installing and running "lspci -nn" (OpenWrt or any other linux) should give some better idea about the hardware as well.

That's what I normally do. You can even do it in luci, network-interfaces. Just unassign and reassign as you wish. Just make sure to do all the changes at once or be prepared to walk back and forth to your unit a few times, swapping around lan and wan cables :rofl:

Hi

All four ethernet ports are visible in the dmesg.
Have you tried to add eth2 and eth3 manually?

Yeah, thanks @slh @cybrnook and @mrhaav all it took was:

uci set network.wan.ifname='eth0'
uci set network.lan.ifname='eth1 eth2 eth3'
uci commit network
1 Like