X5000r 5Ghz only 1 SSID permitted

The X5000R will only allow 1 SSID on the 5GHz radio. If you have configured more than 1 SSID it simply enables the first one listed. All other SSIDs are ignored. Running release 22.03.5.

The 2GHz radio is fine and allows up to 4 SSID.

FYI I hastily created 2 SSID 5GHz radios for testing; with no problem.


Hostname	OpenWrt
Model	TOTOLINK X5000R
Architecture	MediaTek MT7621 ver:1 eco:3
Target Platform	ramips/mt7621
Firmware Version	OpenWrt 23.05.0-rc2 r23228-cd17d8df2a / LuCI openwrt-23.05 branch git-23.118.79121-6fb185f

Kernel Log reports invalid argument in /var/run/hostapd-phy1.conf

Wed Jul  5 08:05:06 2023 kern.notice kernel: [    0.000000] Linux version 5.10.176 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 11.2.0 r20134-5f15225c1e) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 SMP Thu Apr 27 20:28:15 2023
....
....
Wed Jul  5 08:05:13 2023 kern.info kernel: [   25.333341] br-lan: port 1(lan1) entered blocking state
Wed Jul  5 08:05:13 2023 kern.info kernel: [   25.338932] br-lan: port 1(lan1) entered listening state
Wed Jul  5 08:05:13 2023 daemon.notice netifd: Network device 'lan1' link is up
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1-1) --> new PHY
Wed Jul  5 08:05:14 2023 kern.info kernel: [   26.609173] br-lan: port 9(wlan1-1) entered blocking state
Wed Jul  5 08:05:14 2023 kern.info kernel: [   26.614801] br-lan: port 9(wlan1-1) entered disabled state
Wed Jul  5 08:05:14 2023 kern.info kernel: [   26.620985] device wlan1-1 entered promiscuous mode
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: wlan1-1: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Jul  5 08:05:14 2023 daemon.err hostapd: Interface initialization failed
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: wlan1-1: interface state COUNTRY_UPDATE->DISABLED
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: wlan1-1: AP-DISABLED
Wed Jul  5 08:05:14 2023 daemon.err hostapd: wlan1-1: Unable to setup interface.
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan1-1 disabled_11b_rates=0
Wed Jul  5 08:05:14 2023 kern.info kernel: [   26.677814] device wlan1-1 left promiscuous mode
Wed Jul  5 08:05:14 2023 kern.info kernel: [   26.682809] br-lan: port 9(wlan1-1) entered disabled state
Wed Jul  5 08:05:14 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Wed Jul  5 08:05:14 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1-1 wasn't started
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841): Command failed: ubus call hostapd config_add {"iface":"wlan1-1", "config":"/var/run/hostapd-phy1.conf"} (Invalid argument)
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841): Usage: ubus [<options>] <command> [arguments...]
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841): Options:
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  -s <socket>:		Set the unix domain socket to connect to
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  -t <timeout>:		Set the timeout (in seconds) for a command to complete
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  -S:			Use simplified output (for scripts)
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  -v:			More verbose output
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  -m <type>:		(for monitor): include a specific message type
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841): 			(can be used more than once)
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  -M <r|t>		(for monitor): only capture received or transmitted traffic
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841): Commands:
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - list [<path>]			List objects
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - call <path> <method> [<message>]	Call an object method
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - subscribe <path> [<path>...]	Subscribe to object(s) notifications
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - listen [<path>...]			Listen for events
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - send <type> [<message>]		Send an event
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - wait_for <object> [<object>...]	Wait for multiple objects to appear on ubus
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):  - monitor				Monitor ubus traffic
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841):
Wed Jul  5 08:05:14 2023 daemon.notice netifd: radio1 (1841): Device setup failed: HOSTAPD_START_FAILED
Wed Jul  5 08:05:14 2023 daemon.notice netifd: Wireless device 'radio1' set retry=0
Wed Jul  5 08:05:14 2023 daemon.crit netifd: Wireless device 'radio1' setup failed, retry=0
Wed Jul  5 08:05:14 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Wed Jul  5 08:05:15 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Wed Jul  5 08:05:15 2023 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Jul  5 08:05:15 2023 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Wireless device 'radio0' is now up
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Interface 'nwi_mesh0' is enabled
Wed Jul  5 08:05:16 2023 daemon.notice hostapd: 20/40 MHz operation not permitted on channel pri=1 sec=5 based on overlapping BSSes
Wed Jul  5 08:05:16 2023 daemon.notice hostapd: Fallback to 20 MHz
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Network device 'wlan0' link is up
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Interface 'nwi_mesh0' has link connectivity
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Interface 'nwi_mesh0' is setting up now
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.679906] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.761068] batman_adv: bat0: Adding interface: wlan0
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.766239] batman_adv: bat0: Interface activated: wlan0
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Interface 'nwi_mesh0' is now up
Wed Jul  5 08:05:16 2023 kern.warn kernel: [   28.871394] batman_adv: The newly added mac address (5c:92:5e:9d:94:00) already exists on: wlan0
Wed Jul  5 08:05:16 2023 kern.warn kernel: [   28.880398] batman_adv: It is strongly recommended to keep mac addresses unique to avoid problems!
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.890715] br-lan: port 9(wlan0-1) entered blocking state
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.896349] br-lan: port 9(wlan0-1) entered disabled state
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.902478] device wlan0-1 entered promiscuous mode
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.911393] br-lan: port 9(wlan0-1) entered blocking state
Wed Jul  5 08:05:16 2023 kern.info kernel: [   28.916983] br-lan: port 9(wlan0-1) entered listening state
Wed Jul  5 08:05:16 2023 daemon.notice netifd: Network device 'wlan0-1' link is up
Wed Jul  5 08:05:16 2023 kern.info kernel: [   29.035679] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
Wed Jul  5 08:05:17 2023 kern.warn kernel: [   29.128524] batman_adv: The newly added mac address (5c:92:5e:9d:94:00) already exists on: wlan0
Wed Jul  5 08:05:17 2023 kern.warn kernel: [   29.137388] batman_adv: It is strongly recommended to keep mac addresses unique to avoid problems!
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.148219] br-lan: port 10(wlan0-2) entered blocking state
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.153868] br-lan: port 10(wlan0-2) entered disabled state
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.160246] device wlan0-2 entered promiscuous mode
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.167735] br-lan: port 10(wlan0-2) entered blocking state
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.173358] br-lan: port 10(wlan0-2) entered listening state
Wed Jul  5 08:05:17 2023 daemon.notice netifd: Network device 'wlan0-2' link is up
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.268517] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-2: link becomes ready
Wed Jul  5 08:05:17 2023 kern.warn kernel: [   29.348627] batman_adv: The newly added mac address (5c:92:5e:9d:94:00) already exists on: wlan0
Wed Jul  5 08:05:17 2023 kern.warn kernel: [   29.357480] batman_adv: It is strongly recommended to keep mac addresses unique to avoid problems!
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.367123] br-lan: port 11(wlan0-3) entered blocking state
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.372742] br-lan: port 11(wlan0-3) entered disabled state
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.379262] device wlan0-3 entered promiscuous mode
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.387915] br-lan: port 11(wlan0-3) entered blocking state
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.393562] br-lan: port 11(wlan0-3) entered listening state
Wed Jul  5 08:05:17 2023 daemon.notice netifd: Network device 'wlan0-3' link is up
Wed Jul  5 08:05:17 2023 kern.info kernel: [   29.477761] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-3: link becomes ready
Wed Jul  5 08:05:17 2023 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Wed Jul  5 08:05:17 2023 daemon.notice hostapd: wlan0: AP-ENABLED
Wed Jul  5 08:05:19 2023 kern.info kernel: [   31.893968] br-lan: port 8(bat0.4) entered learning state
Wed Jul  5 08:05:19 2023 kern.info kernel: [   31.899471] br-lan: port 7(bat0.3) entered learning state
Wed Jul  5 08:05:19 2023 kern.info kernel: [   31.905177] br-lan: port 6(bat0.1) entered learning state
Wed Jul  5 08:05:21 2023 kern.info kernel: [   33.813971] br-lan: port 1(lan1) entered learning state
Wed Jul  5 08:05:21 2023 kern.warn kernel: [   33.814292] br-lan: received packet on bat0.1 with own address as source address (addr:5c:92:5e:9d:94:00, vlan:1)
Wed Jul  5 08:05:24 2023 kern.info kernel: [   37.013967] br-lan: port 9(wlan0-1) entered learning state
Wed Jul  5 08:05:25 2023 kern.info kernel: [   37.653973] br-lan: port 10(wlan0-2) entered learning state
Wed Jul  5 08:05:25 2023 kern.info kernel: [   37.659675] br-lan: port 11(wlan0-3) entered learning state
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.213964] br-lan: port 6(bat0.1) entered forwarding state
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.219617] br-lan: topology change detected, propagating
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.225330] br-lan: port 7(bat0.3) entered forwarding state
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.231129] br-lan: topology change detected, propagating
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.236799] br-lan: port 8(bat0.4) entered forwarding state
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.242580] br-lan: topology change detected, propagating
Wed Jul  5 08:05:28 2023 daemon.notice netifd: bridge 'br-lan' link is up
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.249125] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.1: link becomes ready
Wed Jul  5 08:05:28 2023 daemon.notice netifd: VLAN 'br-lan.1' link is up
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'lan' has link connectivity
Wed Jul  5 08:05:28 2023 daemon.notice netifd: VLAN 'br-lan.3' link is up
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'vlan3' has link connectivity
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'vlan3' is setting up now
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'vlan3' is now up
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.256526] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.3: link becomes ready
Wed Jul  5 08:05:28 2023 kern.info kernel: [   40.263556] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.4: link becomes ready
Wed Jul  5 08:05:28 2023 daemon.notice netifd: VLAN 'br-lan.4' link is up
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'vlan4' has link connectivity
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'vlan4' is setting up now
Wed Jul  5 08:05:28 2023 daemon.notice netifd: Interface 'vlan4' is now up
Wed Jul  5 08:05:30 2023 kern.info kernel: [   42.133976] br-lan: port 1(lan1) entered forwarding state
Wed Jul  5 08:05:30 2023 kern.info kernel: [   42.139397] br-lan: topology change detected, propagating
Wed Jul  5 08:05:32 2023 kern.warn kernel: [   44.054131] br-lan: received packet on bat0.1 with own address as source address (addr:5c:92:5e:9d:94:00, vlan:1)
Wed Jul  5 08:05:33 2023 kern.info kernel: [   45.333989] br-lan: port 9(wlan0-1) entered forwarding state
Wed Jul  5 08:05:33 2023 kern.info kernel: [   45.339664] br-lan: topology change detected, propagating
Wed Jul  5 08:05:33 2023 kern.info kernel: [   45.974016] br-lan: port 11(wlan0-3) entered forwarding state
Wed Jul  5 08:05:33 2023 kern.info kernel: [   45.979792] br-lan: topology change detected, propagating
Wed Jul  5 08:05:33 2023 kern.info kernel: [   45.985378] br-lan: port 10(wlan0-2) entered forwarding state
Wed Jul  5 08:05:33 2023 kern.info kernel: [   45.991181] br-lan: topology change detected, propagating
Wed Jul  5 08:05:34 2023 authpriv.info dropbear[3722]: Child connection from 192.168.1.137:61620
Wed Jul  5 08:05:35 2023 authpriv.notice dropbear[3722]: Password auth succeeded for 'root' from 192.168.1.137:61620
Wed Jul  5 08:05:36 2023 daemon.info procd: - init complete -
Wed Jul  5 08:05:36 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1-1) --> new PHY
Wed Jul  5 08:05:36 2023 kern.info kernel: [   49.002592] br-lan: port 12(wlan1-1) entered blocking state
Wed Jul  5 08:05:36 2023 kern.info kernel: [   49.008282] br-lan: port 12(wlan1-1) entered disabled state
Wed Jul  5 08:05:36 2023 kern.info kernel: [   49.014702] device wlan1-1 entered promiscuous mode
Wed Jul  5 08:05:36 2023 daemon.notice hostapd: wlan1-1: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Jul  5 08:05:36 2023 daemon.err hostapd: Interface initialization failed
Wed Jul  5 08:05:36 2023 daemon.notice hostapd: wlan1-1: interface state COUNTRY_UPDATE->DISABLED
Wed Jul  5 08:05:36 2023 daemon.notice hostapd: wlan1-1: AP-DISABLED
Wed Jul  5 08:05:36 2023 daemon.err hostapd: wlan1-1: Unable to setup interface.
Wed Jul  5 08:05:36 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan1-1 disabled_11b_rates=0
Wed Jul  5 08:05:36 2023 kern.info kernel: [   49.024819] device wlan1-1 left promiscuous mode
Wed Jul  5 08:05:36 2023 kern.info kernel: [   49.029740] br-lan: port 12(wlan1-1) entered disabled state
Wed Jul  5 08:05:37 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Wed Jul  5 08:05:37 2023 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Wed Jul  5 08:05:37 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1-1 wasn't started
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743): Command failed: ubus call hostapd config_add {"iface":"wlan1-1", "config":"/var/run/hostapd-phy1.conf"} (Invalid argument)
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743): Usage: ubus [<options>] <command> [arguments...]
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743): Options:
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  -s <socket>:		Set the unix domain socket to connect to
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  -t <timeout>:		Set the timeout (in seconds) for a command to complete
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  -S:			Use simplified output (for scripts)
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  -v:			More verbose output
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  -m <type>:		(for monitor): include a specific message type
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743): 			(can be used more than once)
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  -M <r|t>		(for monitor): only capture received or transmitted traffic
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743): Commands:
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - list [<path>]			List objects
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - call <path> <method> [<message>]	Call an object method
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - subscribe <path> [<path>...]	Subscribe to object(s) notifications
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - listen [<path>...]			Listen for events
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - send <type> [<message>]		Send an event
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - wait_for <object> [<object>...]	Wait for multiple objects to appear on ubus
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):  - monitor				Monitor ubus traffic
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743):
Wed Jul  5 08:05:37 2023 daemon.notice netifd: radio1 (3743): Device setup failed: HOSTAPD_START_FAILED
Wed Jul  5 08:05:37 2023 daemon.notice netifd: Wireless device 'radio1' set retry=0
Wed Jul  5 08:05:37 2023 daemon.crit netifd: Wireless device 'radio1' setup failed, retry=0
Wed Jul  5 08:05:37 2023 user.info : luci: accepted login on / for root from 192.168.1.137
Wed Jul  5 08:05:37 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Wed Jul  5 08:06:23 2023 kern.warn kernel: [   54.294275] br-lan: received packet on bat0.1 with own address as source address (addr:5c:92:5e:9d:94:00, vlan:1)
Wed Jul  5 08:06:24 2023 kern.warn kernel: [   55.094201] br-lan: received packet on bat0.3 with own address as source address (addr:5c:92:5e:9d:94:00, vlan:3)

/var/run/hostapd-phy1.conf"

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=TH
ieee80211d=1
ieee80211h=1
hw_mode=a
supported_rates=120 180 240 360 480 540
basic_rates=120 240
beacon_int=100
channel=149
chanlist=149
noscan=1
tx_queue_data2_burst=2.0
ieee80211n=1
ht_coex=0
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935]
ieee80211ac=1
vht_oper_chwidth=2
vht_oper_centr_freq_seg0_idx=149
vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-2][BF-ANTENNA-4][MAX-MPDU-7991][MAX-A-MPDU-LEN-EXP7]
ieee80211ax=1
he_oper_chwidth=2
he_oper_centr_freq_seg0_idx=149
he_su_beamformer=1
he_mu_beamformer=1
he_default_pe_duration=4
he_rts_threshold=1023
he_mu_edca_qos_info_param_count=0
he_mu_edca_qos_info_q_ack=0
he_mu_edca_qos_info_queue_request=0
he_mu_edca_qos_info_txop_request=0
he_mu_edca_ac_be_aifsn=8
he_mu_edca_ac_be_aci=0
he_mu_edca_ac_be_ecwmin=9
he_mu_edca_ac_be_ecwmax=10
he_mu_edca_ac_be_timer=255
he_mu_edca_ac_bk_aifsn=15
he_mu_edca_ac_bk_aci=1
he_mu_edca_ac_bk_ecwmin=9
he_mu_edca_ac_bk_ecwmax=10
he_mu_edca_ac_bk_timer=255
he_mu_edca_ac_vi_ecwmin=5
he_mu_edca_ac_vi_ecwmax=7
he_mu_edca_ac_vi_aifsn=5
he_mu_edca_ac_vi_aci=2
he_mu_edca_ac_vi_timer=255
he_mu_edca_ac_vo_aifsn=5
he_mu_edca_ac_vo_aci=3
he_mu_edca_ac_vo_ecwmin=5
he_mu_edca_ac_vo_ecwmax=7
he_mu_edca_ac_vo_timer=255

radio_config_id=a15f2b62e2e8649e91fc32db2c4d6a36
interface=wlan1-1
ctrl_interface=/var/run/hostapd
ap_isolate=1
bss_load_update_period=60
chan_util_avg_period=600
disassoc_low_ack=1
skip_inactivity_poll=0
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
utf8_ssid=1
multi_ap=0
wpa_passphrase=lad112
wpa_psk_file=/var/run/hostapd-wlan1-1.psk
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=mgmt
bridge=br-lan
wds_bridge=
snoop_iface=br-lan.1
wpa_disable_eapol_key_retries=1
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
dynamic_vlan=0
vlan_naming=1
vlan_no_bridge=1
vlan_file=/var/run/hostapd-wlan1-1.vlan
qos_map_set=0,0,2,16,1,1,255,255,18,22,24,38,40,40,44,46,48,56
config_id=99b0ecfad68be74aa50aeda7d9d50590
bssid=5e:92:5e:9d:94:04

/etc/config/wireless (only 5Ghz section)

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option country 'TH'
	option cell_density '2'
	option htmode 'HE160'
	option band '5g'
	option channel '149'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'mesh'
	option encryption 'sae'
	option mesh_id 'mesh'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'
	option key 'lad112'
	option network 'nwi_mesh0'
	option disabled '0'

config wifi-iface 'wifinet11'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'mgmt'
	option encryption 'psk2'
	option key 'lad112'
	option wpa_disable_eapol_key_retries '1'
	option disabled '1'

config wifi-iface 'wifinet12'
	option device 'radio1'
	option mode 'ap'
	option ssid 'guest'
	option encryption 'psk2+ccmp'
	option key 'silver400'
	option wpa_disable_eapol_key_retries '1'
	option network 'vlan4'
	option disabled '1'


I see you have 5GHz radio1 htmode set to HE160, try setting to HE80.
AFAIK, my X5000R with MT7915E device isn't capable of running at 160MHz channel.

already tried HE80 HE160 VHT80 etc..... with no effect on result.

there must be a copy/paste error in the code somewhere and/or it doesn't like a character or something in the hostapd-phy1.conf

sorry I take that back. HE80 does allow more than 1 SSID. I must have been going through so many permutations and reboots I missed it.

strangely it accepts HE80+80 without any issue although LUCI doesn't show it correctly. Anyway I'll leave it at HE80.

Good for you. It's been sorted.

@papdee Just out of curiosity, what is the output when you do iwinfo on 5GHz radio,

             root@OpenWrt:~#iwinfo radio1 htmode
root@OpenWrt:~# iwinfo radio0 htmode
HT20 HT40 HE20 HE40
root@OpenWrt:~# iwinfo radio1 htmode
HT20 HT40 VHT20 VHT40 VHT80 HE20 HE40 HE80
root@OpenWrt:~# cat /etc/banner
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 23.05.0-rc2, r23228-cd17d8df2a
 -----------------------------------------------------
root@OpenWrt:~#

/etc/config$ iwinfo radio1 htmode
HT20 HT40 VHT20 VHT40 VHT80 HE20 HE40 HE80 HE80+80 HE160

just a note on the X5000R. I need to edit the wireless config directly as changing settings via LUCI corrupts the file which is the reason for the frustration sometimes. This bug is well known and still exists in 23.05.

Running OpenWrt 23.05.0-rc2 currently here, LUCI doesn’t have 160MHz width frequency as an option, thus no way to test the file corruption like you’ve mentioned above.

However, via wireless config file, setting htmode HE80+80 runs (even though cmd “iwinfo radio1 htmode” doesn’t list it), but with horrible performance that I don’t even bother to iperf.

Thank you for sharing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.