WrtNode1 basic question

I got my board + standard shield but I do not 100% sure how I should use it. :wink:

I have already installed LEDE 17.1.4 version

1.after firmware flash and put on the shield, put RJ45 cable and other end to the router login ssh/telnet should it has internet access by default or not?
2. same question regarding 1 difference, connect with the prepared blue cable 4 wire RJ45 cable directly to the router
3. via Luci I have configured my Router, it has strong signal, but if I connec via ssh I still don't have internet
What should I do more?

I can post my /etc/config setting if helps

ps: I have tried with default openwrt firmware I have the same problem, no internet

  1. With one cable probably not, With 2 or more, depends on whether you put the provider cable in correct Ethernet port.
  2. Number of wires in Ethernet cable might affect your speed, if connected properly, but not presence or absences of internet.
  3. Definitely puting /etc/config/network here will help alot.

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option channel '6'
	option country '00'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'LEDEx'
	option encryption 'psk2'
	option key '12345678'

config wifi-iface
	option network 'wwan'
	option ssid 'ROUTERXX'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid 'C4:6E:1F:4D:0F:56'
	option key 'password'

network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd18:d6eb:01be::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '90:uu:91:kk:hh:nn'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '90:dd:yy:zztt:jj'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

config interface 'wwan'
	option proto 'dhcp'

firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan wwan'

config zone
	option name 'wan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'
root@LEDE:/etc/config# ifconfig
br-lan    Link encap:Ethernet  HWaddr 90:xx:kk:yy:zz:jj
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdgg:pppp:jjjj::1/60 Scope:Global
          inet6 addr: fggg::oooo:iiiii:jjjj:uuuu/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1441 errors:0 dropped:0 overruns:0 frame:0
          TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:122401 (119.5 KiB)  TX bytes:334638 (326.7 KiB)

eth0      Link encap:Ethernet  HWaddr 90:xx:kk:yy:zz:jj
          inet6 addr: fggg::oooo:iiiii:jjjj:uuuu/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:605 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:114556 (111.8 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr 90:xx:kk:yy:zz:jj
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:420 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:55000 (53.7 KiB)

eth0.2    Link encap:Ethernet  HWaddr 90:zz:nn:hh:oo:ii
          inet6 addr: fe80::zzzz:ffff:yyyy:uuuu/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:172 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:54279 (53.0 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:780 errors:0 dropped:0 overruns:0 frame:0
          TX packets:780 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:67489 (65.9 KiB)  TX bytes:67489 (65.9 KiB)

wlan0     Link encap:Ethernet  HWaddr 90:xx:kk:yy:zz:jj
          inet addr:192.168.0.160  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fggg::oooo:iiiii:jjjj:uuuu/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:356 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1510 (1.4 KiB)  TX bytes:23272 (22.7 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 90:zz:nn:hh:oo:ii
          inet6 addr: fe80::zzzz:ffff:yyyy:uuuu/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1440 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1117 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:142555 (139.2 KiB)  TX bytes:411528 (401.8 KiB)

Finally I have found out what caused it.

I have made access point from my Android phone and it does not has any problem. I got internet on wrtnode :slight_smile:
If I use my TL-MR3220 wireless router then I do not have internet, but it got IP!

Any idea why??

Channel: Auto (Current channel 6)
Mode: 11bgn mixed
Channel Width: Automatic

I got few devices, but all of them working well..

Not shure but might be some problem with authentication to to the wwan.

Are you the problem is with the wireless config file?

But how does it get IP if the authentication failed?