Wrt902ac asigning modem ip instead router ip so cant access to admin panel

wr902ac asigning modem ip instead router ip so cant access to admin panel

wr902 ac only have 1 lan port and in panel lan adapter.is br-lan wlan and vlan switch too

does not behave like usual openwrt router

where wan is eth.0 and gets dhcp ip from modem and lan is eth.0.1 and nats modem isp ip to lan i0 (192.168.0.1)

what i need is to:

make my 1 lan port to behave as wan and lan and not bridge the isp ip 5.19.223.200 as my lan ip, so i can access to admin panel and not my modem admin panel...

since if i do a ipconfig renew

i get my modem ip and as it is only 1 port (wr902ac) i connect to router via wifi but cannot access to wifi panel since it throws modem ip and not lan ip, how can i fix it?

isolate client computer and 902, set up wifi, and reconnect via wifi.
once done, reconfigure ethernet port to be a wan port, by moving it from
lan to wan firewall zone.

after it's done, the device will only be accessible via wifi.

how can i isolate it? i cannot pass lan to wan i will send images of config there is only 1 interface which is br lan!
wan zone is emty dont exist

what can i do?

i need to transform that only lan port

to a wan port and get router ip via wifi( if i connect cable to modem it shows modem.ip and not router ip like other routers do


also sorry lost access to the other account it says wrong password username which is weird so i created this so i can with help solve this error

If you want the single ethernet port to operate as both a lan and a wan, that is physically possible, but you must have a managed switch to manage the VLAN assignments to 'break out' the ports.

The typical use case for that and other single-ethernet-port travel routers is to do the following:

  1. Ethernet = wan, wifi AP = lan
    or
  2. wifi sta (client) = wan, wifi AP = lan
    or, sometimes:
  3. wifi (sta) = wan, wifi AP and/or ethernet = lan.

What is it that you want to achieve?

i need to achieve ( ethernet = wan, ap = lan) , how can i do it?

From a default configuration:
in wireless:

  • set up an AP with your desired SSID + password
  • attach it to the lan network. (this part will already be done)
  • enable wifi and make sure you are able to connect via wifi (you'll have done the previous steps using ethernet)

Once connected to wifi, in the network configuration:

  • remove eth0 from lan.
  • assign eth0 to wan.

That's it.

is that done in network interfaces?

Yes... but reset your router to defaults, first.

Wireless is found in the network > wireless tab (if you're using the web interfaces), and network in in the network > interfaces section.

1 Like

oh... it occurs to me that there isn't a wan by default in the network interfaces.

This is simple, though...
create a new one wan (make sure it's lower case), with proto dhcp, and then attach eth0 to it.

1 Like

ok in interfaces i got obly 1 interface which is br lan

there are icons telling

lan : bridge : device: br-lan ,
lan: type software vlan : device eth0.1,
lan: type wireless adapter: device: wlan0
lan: wireles adapter device wlan1

if i go to edit button it says

status:

br lan

protocol: static address

device: br-lan

i have a list that says

a list of devices to select;

bridge: "br-lan" (lan)
ethernet switch: "eth0"
switch vlan: "eth0.1"
wireless network: master wifi1(lan)
wirelless network: master * wifi2
(lan)
alias interface "@lan"
--custom--

what should i do? create a new interface called wan assign it * ethernet switch "eth0" ?

already done added

new interface

called wan

proto

dhcp

, disconnected lan cable from pc and connected to modem

when i connect via wifi

and request ipconfig renew

the ip coming is the modem ip

5.19.223.20

not the usual private iana ip

(192.168.1.2)

also if i hit refresh

when i go to admin panel it shows me

no internet (cannot access router wifi ip i got in lan cable)

i have other wifi router running openwrt, i saw it have a wan interface proto dhcp

when it is connected to my modem the wan interface gets the router ip and the lan interface br lan gets nated to 192.168.1.1

this is not happening in my wr902ac

maybe it is a bug? i do not know, or does openwrt change.the behavior of the switch button located on the rear router saying:

mode switch

-share eth
-share hotspot
-ap rng ext client

or does openwrt disables those buttons?

what am i doing wrong?

My device (I have the v1) works perfectly. As does every v1 and v3 I’ve seen discussed on these forums. The issue is related to your configuration.

What is the upstream connection? If you plug your computer directly into the upstream, what ip address do you get?

if i plug my pc directly to the modem i get ---- again (isp ip)

tried rebooting to zero and still not getting dhcped

however if i try to change to 5.19.223.20 in br lan (gateway is 5.19.223.20)

and plug it to the modem, i get access to the router panel(wr902ac) BUT i cannot run opkg update i get operation not permitted and also get error 6 and error wget 4 also ping to 1.1.1.1 gets error and if i ping google gets not response;

if i change dns from isp to custom (1.1.1.1) still getting those problems

but i got internet but i cannot run opkg nor install nor download packages which i need it to install tor and also openvpn and ipban because i am trying to make a okug and play road warrior homemade

so

i reset to default

what i have touched is:

change wlan ap name and pass(of course, and enabling it)

added new interface called wan ( adapter eth0)

changed lan ip to 192.168.10.10

and still not working

at this moment i do not know what i am doing wrong

it feels like it is just bridging and not dhcping wan ,
which is weird.i have other openwrt router and in interfaces i have wan and protocol dhcp and he gots ip

in wan interface

this v3 does not gets dhcped in wan and it feels like it is just bridging and not dhcping not natting :no_mouth:

i did clean install and clean reset and still cannot makenit work im sorry im rookie

You are making many changes that should not be touched.

Reset to defaults and repeat the process I described earlier.

Make sure you can connect to the router via WiFi. Then plug in your isp connection and see what you get. You should theoretically get a different ip address than your computer does. That is fine.
What kind of internet connection do you have (cable, dsl, fiber, etc)?

did hard reset

changed wifi name

added wan as eth0

... still getting isp ip and not getting usual 192.168.1.1

any idea? firmware is latest (installed testerday)

im almost sure is layer 8 error (me user) i did everything exactly as written but still getting that weird behaviour

also isp is coaxial, i have this setup

modem > router ,

if i use the other open wrt router ...

modem > openwrt(not 902ac) i get 192.168.1.1

if i use 902 ac with exact factory openwrt config

i get modem address... i swear is weird and it got me pulling my hairs

What do you mean by this:

The lan address of your router (accessible via WiFi) will remain 192.168.1.1

Your wan should get an ip addesss from your isp. Your computer should get an address that is 192.168.1.x

and that is the error,

in my other openwrt i got 192.168.1.2. (192.168.1.1 as gateway)

in my 902ac v2 i get my isp adress ¿is it because of the switch button located thing that you can change from position in order to enable other modes?

i dont know what i am wrong i got me crazy this weird error cause theorically should not be happening and

it is happening

And what are you getting now (I assume you’re talking about you computer?)

im talking of the belkin router i have openwrt... it works dhcp there

in my wr902ac v3 does not

i still getting

x.19.223.21 now.. is like it is bridging and not dhcping... it got me mad