WRT32X setting multiple networks concern

Hello
need some help in properly setting my network
I want to have two separated networks. One private the other public (looks simple)
For that purpose I define two bridges one with port 1 and 2 private, the other with port 3 and 4 prublic
using v21.02 on WRT32X
here after the network config

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1a:c0e0:b89e::/48'

config device
        option name 'wan'
        option macaddr '62:38:e0:c3:5c:88'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option name 'br-priv'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config device
        option name 'br-pub'
        option type 'bridge'
        list ports 'lan3'
        list ports 'lan4'

config interface 'priv'
        option device 'br-priv'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'pub'
        option device 'br-pub'
        option proto 'static'
        option ipaddr '192.168.99.1'
        option netmask '255.255.255.0'

Problem is that Luci always reports an error regarding br-pub "Network device is not present" while br-priv is OK
Can you tell me what is wrong in this config and why
THX