WRT32X Open Source Firmware Installation?

Here's my question:

I apologize for asking a question related to DD-WRT here, but as of now that is my only option to replace the Linksys 'Venom' Firmware.

The sysupgrade command does not successfully flash the 'factory to dd-wrt.bin' file.
So would mtd work?

I haven't tried this yet, but it looks promising. However, I have almost zero experience with LEDE / OpenWRT.

Use SCP to upload dd-wrt to /tmp
SSH into WRT32X
Change directory to temp: cd /tmp
Use wget command: wget https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2017/11-04-2017-r33679/linksys-wrt32x/factory-to-dd-wrt.bin


mtd -r write factory-to-dd-wrt.bin linux


Try forcing the upgrade by using the following command but REPLACE the "(FIRMWARE-NAME).bin" file with the one your trying to flash: sysupgrade -F -i -n (FIRMWARE-NAME).bin

Thank you for the quick reply! I apologize, I should have included that someone else (on DD-WRT Forum) has attempted that.
His reply was that afterwards it says Success, but then the router is inaccessible.
It had to be manually switched to opposite partition.

May be some info to glen from the those doing a xflash

inaccessible by what means? both wireless and wired? have you tried turning the network card off and on? have you waited few mintues after forced flash? have you tried power cycling the unit once after few minutes as it may get stuck after the flash and before the reebot. if it works with the WRT3200ACM converted to WRT32X then I see no reason for the WRT32X not to flash DD-WRT. I am running DD-WRT on WRT3200X with WRT32X partition layout and u-boot myself.

Please discuss questions regarding installation of dd-wrt in the appropriate forum, i.e. the dd-wrt forum.

I tried a sysupgrade with forced flash for myself. I posted my findings here:

Thank you all for your help! Hopefully this can get solved soon.

Since the discussion has moved to the correct forum, I'm closing this topic now.