WRT32X - Moving from 19.07.8 to 21.02.1

Hi All,

Hoping someone can help - I've been trying to update my Linksys WRT32X (currently on 19.07.8) to 21.02.1.

I have understood so far that there's a change from swconfig to DSA and therefore not imported by previous config extract.

I'm trying to recreate my network config file and been successful with the WAN parameters (simple copy and paste) but can't get my head around the rest. This enables me to get a WAN IP address but no internal clients are able to connect to the internet.

If its not too much to ask, is someone able to 'rewrite' the below to match what's required for using DSA:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option ipv6 'off'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'
	option macaddr '82:72:15:EE:E3:67'
	option clientid '82:72:15:EE:E3:67'
	option ipv6 'off'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option peerdns '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option ifname 'eth1.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

Thanks in advance!

I don't see you doing anything 'special' in your old swconfig configuration, not special VLAN definitions, just cloning a MAC address on WAN and overriding the DNS servers - you can do the same with DSA, without really touching any DSA specifics.

1 Like

Resetting to defaults and configuring the whole system from scratch is highly recommended when going from 19 to 21. In particular there are major changes in network, dhcp, and wireless. You can keep your old /etc/config/firewall if it has been customized.

Start with the default DSA network config, and as noted add your DNS servers to the config interface wan section. If you really need to override the MAC address you'll need to add a config device section though on many models one will be generated for you with the "sticker" factory MAC and you can just change the MAC.

Important differences with DSA are that layer 2 settings like MAC address and bridge membership now go in a separate config device, and config interface holds layer 3 settings like protocol and references the device block with option device. Also each Ethernet port has its own name and is generally referenced directly. There is no common "CPU" port like eth0 any more.