WRT32X - Failed after firmware Sysupgrade

Hello Hello !!

Yes first post, so first thank you for all of this. When I first start up my WRT32X, I was so suprise with the lack of options available; not even MAC filtering ... And this is where (by talking with a friend) I found OpenWRT. I confgured everything like I wanted (not always easily) but with time everything looked good.

Why did I do upgrade when it looks fine?

Recently I found our a weird behavior. Long story short, I have 4 radio on my router but all devices were connected to the same 2.4ghz and with not great performance. So I investigated and found that my 5ghz were not able to be associated ... Long story short, I found in the forum a guy that had the same similar issue that he resolved by upgrading his firmware. mine was old (18.x.x) i decided to do it but in sequent.

Process follows

So I did the 18 --> 19 with success except i lost my config.
then i wanted to do the 19 --> 20 but i had a warning saying the venon was not supported and it will not keep the config. i didn't care as i already lost it in the previous step so I forced it.

Result and investigation

Since, the router doesn't response.
in the order:
1- No Web interface
2- No ping to the default
3- No DHCP service
4- Try with fix IP address but same result.
5- Try to use the reset button for 10 sec then redo the test but still same result.
6- Decide to ask for help.

Why it happened?

I know in french we say "Touche pas à cça p'tit con" (translate by "Don't touch this little ...") but I still did thiniking knowing what I was doing :-P.
I'm not really sure but the only reason that I see why it happened would be that I mixed the version.
I think that when I wanted to select the 20 version, i may be choose the wrong version and select the 22 version. This is because I download all the version at the same time in the same folder and it was late when I did this.

What to do ?

Obviously the first step would be to have access to any interface.
I don't see the "Console" entry as we have on Cisco (No Console port nor USB-C port)
But there are 2 USB port (One USB 2 and One USB3).
I suppose there is a "Boot from USB" solution but I didn't find it yet.
Any idea or suggestion to reset the router?
Or maybe there is another Default IP that I can use to get back the access?

Thank you for you help

The wiki page for your device has information about recovering from your bricked state

1 Like

you have a device with dual boot partitions. The other partition likely is still ok.

first try https://openwrt.org/toh/linksys/wrt32x#power_switch, to manually trigger booting via the other firmware partition.

1 Like

Ok thank you it work, I was able to switch the boot. Now I'll check to sysupgrade the version 19-->21 (there is no version 20). I'll keep you inform.

Perfect it work. I had to reset to factory that is not really a big deal as you already know.


(And happy new year)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.