WRT32x bricked, stuck on boot with power led blink

Hello need help with linksys WRT32x.

I tried to restore to linksys factory from DDWRT, and in process seems got it bricked.
Not able to get to marvel prompt to restore firmware or fix issue.

1) I did over ssh:
erase nvram
mtd -e linux -r write /tmp/FW_WRT32X_1.0.180404.58.img linux
mtd -e linux2 -r write /tmp/FW_WRT32X_1.0.180404.58.img linux2

at this router stuck with power LED blinking.

2) Tried to use serial into router, it try to boot and dont go further following

BootROM - 1.73

Booting from NAND flash

General initialization - Version: 1.0.0

AVS selection from EFUSE disabled (Skip reading EFUSE values)

mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed

Detected Device ID 6820

High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3

Serdes Lane 4 is SGMII

board SerDes lanes topology details:

 | Lane # | Speed|    Type     |


 |   0    |  6   |  SATA0      |

 |   1    |  5   |  PCIe0      |

 |   2    |  6   |  SATA1      |

 |   3    |  5   |  USB3 HOST1 |

 |   4    |  5   |  PCIe1      |

 |   5    |  0   |  SGMII2     |


:** Link is Gen1, check the EP capability 

PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities 

:** Link is Gen1, check the EP capability 

PCIe, Idx 1: remains Gen1

High speed PHY - Ended Successfully

DDR3 Training Sequence - Ver TIP-1.46.0

mvSysEnvGetTopologyUpdateInfo: TWSI Read failed

   DDR3 Training Sequence - Switching XBAR Window to FastPath Window 

DDR3 Training Sequence - Ended Successfully

Not detected suspend to RAM indication

 BootROM: Image checksum verification PASSED

U-Boot 2013.01 (May 18 2017 - 16:37:44) Marvell version: 2015_T1.QA.0p16

Boot version : v2.0.9

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0

no marwel prompt or anything..

3) tried to recover bootloader following https://openwrt.org/toh/linksys/wrt_ac_series#corrupt_bootloader_recovery

after 100% complete it boot and but same result, after boot it stuck at same point, power LED blink an same message on serial.

Not sure what else I can do.. any help would be greatly appreciated.

Given that you were coming from ddwrt, Iā€™d recommend asking on those forums to get instructions for unbricking and restoring the factory firmware.

no much info on that.. as looking way to restore rotuer to factory assuming this is common bricked state. If can figure out how to proceed from current situation to restore it.

Kindly help

Where did these instructions come from?

How To Unbrick and Restore A Linksys WRT 1200 1900 and 3200 Using Serial and FTP - YouTube

Bricked WRT32X - Installing and Using OpenWrt - OpenWrt Forum

followed this youtube video too, but issue is over serial it not give me prompt to input commands, it get stuck before it get to that , please see dump in post initial. I'll try to attach screen video for same to explain.

followed: I know it from ddwrt, but here just trying to recover.

I able to get this far, after this there no prompt or anything..

on boot, it output this straight without any pause to escape or do anything thing.. and after this cant do anything and power led keep blinking .. not sure if there anything can be done at this point...

Since you followed directions from the DD-WRT forums, you'll be more likely to find people who would be familiar with that specific method of writing the stock firmware back to the device, what might go wrong, and how to recover from that. In many cases, OpenWrt does not use mtd write commands, so the community here is less likely to know what went wrong in your situation and how to recover... DD-WRT forums are much more likely to be able to solve this particular issue.

possible assist

1 Like

understand that to ask ddwrt, but if anyone here know anything on how to recover router irrespective of firmware where it stuck not able to get uboot prompt, please help.

At this point, it is less about the firmware itself and more about the process you used. That process is rather uncommon for OpenWrt, but quite common for DD-WRT. That is why you'll have better luck on the DD-WRT forums than you will here. Obviously if anyone on this forum is able to help, I'm sure they well... I just wouldn't expect many users here to have much experience with the specific process that has caused your router to become bricked.

While the use of mtd CLI is not something recommended for the neophyte it is hardly unfamiliar to the community.

I'm not saying that the community doesn't know about (or ever use) mtd write... just simply that it is not the daily driver method for OpenWrt in terms of writing firmware or reverting to the vendor's stock firmware. Therefore, the specific situation that has occurred to the OP's unit would likely be a much less common occurrence here than it would be on DD-WRT's site where the method is used very frequently.

So you've said, by my count in 4 posts so far, just not sure how that offers any assistance to the OP involved in the fire fight; pretty sure the obvious occurred to the OP.

If can simply can get to marvell prompt on uboot.
That would be big help, irrespective of what firmware that would be great help.

As read many post saying it in silent boot mode, I tried to press space bar as soon as I see following message on serial terminal:

Marvell version: 2015_T1.QA.0p16
Boot version : v2.0.9

Then tried to run following just to see if in silent prompt, but no output:

printenv silent

no output

able to get this prompt.. but when type anything in putty it not show masked character. as I tried to run printenv it show this masked line and no response to enter...

Able to finally get prompt

  • seems there something may be to do with usb-ttl cable.
    I had to disconnect groun pin to make router boot, and keep TX/RX pin connect.
    once get output, connect ground pin as that make keyboard input to work.
  • as soon boot+connect ground pin, with in fest 3 second press a key to interrupt boot process.
  • first thing
    setenv silent

once reboot (same thing with ground pin)

  • now have venom prompt

and follow rest of the process to flash firmware,
Note: needed flat firmware file as one directly from linksys not worked as it is..

1 Like

ok, here something off:

  1. Can connect to router over wifi, but router fail to connect to internet.

  2. tried to even reinstall factory firmware downloaded from linksys, it refuse it firmware failed to check and not install.

  3. Router not able to reset even with reset button 10 sec press.

Issue: At this point not able to use router to connect to internet.

Able to ssh into router, any pointer now what to do? kindly help as seems not this running openwrt

root@'s password:

BusyBox v1.24.2 () built-in shell (ash)
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 DESIGNATED DRIVER (Bleeding Edge, 50140)
  * 2 oz. Orange Juice         Combine all juices in a
  * 2 oz. Pineapple Juice      tall glass filled with
  * 2 oz. Grapefruit Juice     ice, stir well.
  * 2 oz. Cranberry Juice
root@netgateway:~# ls
root@netgateway:~# pwd