Wrt32x 5Ghz (radio0) stops working - 19.07.4

I've recently updated my wrt32x from 19.07.3 to 19.07.4
Since the update the 5Ghz radio (radio0) stops working in less than 24 hours.
I can see clients try to associate but fails, eventually all clients disconnect from the router.
When this happens it does not help to restart the radio, only to reboot the router.
I have also tried to scan for other APs using radio0 just to check if the radio works, it will not find anything. There are no errors in syslog or kernel log.
If I reboot the router it will work for about a day until the problem returns.
I had 70 days uptime with 19.07.3 without any problems.

This is my config for radio0:

config wifi-device 'radio0'
	option type 'mac80211'
	option noscan '1'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'FR'
	option legacy_rates '0'
	option htmode 'VHT80'
	option channel '36'
	option short_gi_160 '0'
	option vht160 '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxx'
	option key 'xxxx'
	option macaddr 'xxxx'
	option encryption 'psk2+ccmp'
	option wpa_group_rekey '86400'
	option ieee80211r '1'
	option nasid 'xxxx'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option ieee80211d '1'

Note: I'm using the full version of wpad instead of wpad-basic

Any idea what may be the problem?

Anyone with WRT3200ACM or WRT32X? 10x

11 days uptime wds sta+ap on 5ghz on 19.07.4
try the thagabe patch, or try that version of eduperez ipks

Thanks, already tried the "thagabe patch" (from eduperez ipks), same result, this is what I can't understand, I did not find any changes which should make this, before I updated the device it was at 70 days (and this was only due to a long power interruption).
I'm using the same wireless config file, I tried creating a new one to see if there are default changes there, did not see anything important.
Can't reach 24hours with the 5Ghz working