WRT32X 22.03 - wifi stops working until I restart radio

I have a strange issue with my WRT32X where after a number of days, my WiFi seems to stop working.
I've created a second network with a different SSID and that works for a while, but eventually falls over too. The only way to recover seems to be to restart the radio, but I'm not sure if that radio restart itself fixes it, or whether it's just that some other service gets restarted as a dependency.

The issue seems to be that DHCP stops working rather than the network being completely dead because I can see requests.
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 10.0.0.144 aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 10.0.0.144 aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 10.0.0.144 aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 10.0.0.144 aa:d5:0e:13:bf:23
Dec 3 20:39:39 OpenWrt dnsmasq-dhcp[1]: DHCPACK(br-lan) 10.0.0.144 aa:d5:0e:13:bf:23 Galaxy-Tab-A8

Any idea where I can start to troubleshoot here?
Here is my wireless config:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option country 'AU'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '60:38:e0:cc:d7:12'
        option ssid 'FBI_5'
        option encryption 'psk2'
        option key 'xxxxxxx'
        option disassoc_low_ack '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option band '2g'
        option cell_density '0'
        option legacy_rates '1'
        option country 'AU'
        option htmode 'HT20'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '60:38:e0:cc:d7:11'
        option ssid 'FBI_2'
        option encryption 'psk2'
        option key 'xxxxxxxxx'
        option wmm '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option band '2g'
        option channel 'auto'
        option cell_density '0'
        option legacy_rates '1'
        option txpower '36'
        option country 'AU'
        option disabled '1'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'FBI_VAN'
        option encryption 'psk2'
        option key 'xxxxxxxx'
        option network 'lan'
        option macaddr '60:38:E0:CC:D7:13'

For now I was thinking of scheduling a radio restart overnight to avoid the issue.

3200/32X radio is a not gracefully aged diva.

  • Get used to suboptimal wifi on 32x, the proprietary wifi firmware blob is abandoned and not of high driver code quality

  • WPA3 does not work, but you are not using that, so not the issue here

  • there are issues, if you activate the third radio and are not acting wise on country code settings. It is often recommend to not activate the third radio and keep country code „driver default“ for the first 2 radios (the first 2 have the country code hard coded in proprietary driver blob and gets negative affected by any custom country settings). If you do insist on activating the third radio, its different for the third: you need a command line tool to set country code for third, alligned to the country code for which the device was hard coded (likely in your case AU). not doing so reduces range. Details might be in older threads, not in wiki.
    Not sure, if this further affects your crash issue as well, but it is a finding in your config.

  • activate the fewest possible wifi settings or check forum threads, what is really supported. There are several wifi options available in UCI/LuCi, but not supported by the 32x wifi.
    Outcome of some combinations, when used on 32x, unknown.

what you can try:

  • Are you on the latest 22.03 release?
  • Any other customizations used? Have you tried resetting settings and starting with minimal default settings, 2 radios only, no fancy wifi tunings, disabled WPA3, to see if any custom settings cause issues?
1 Like

I have kind of a similar problem with this router. I have installed OpenWrt 22.03.0 r19685-512e76967f / LuCI openwrt-22.03 branch git-22.245.77528-487e58a on it and tried to create a guest network. It didn't work on the Marvell 88W8964 802.11nac or the Marvell 88W8964 802.11bgn radios but it worked in a way on the Marvell 88W8887 802.11bgnac radio. The way it did not work was that when I added a new SSID on the first 2 it killed both the principal and the secondary (guest) network. It kind of works on the third radio, but up to a point. It dies in a couple of days, and it works again if rebooted. I am not sure why it does not work on the first 2 radios, and it works on the third radio. Also, this dying activity looks like a memory leak. Where to look for clues?

Someone mentioned that this router did not age well. So which router is recommended?

Thank you.

because you need set a different bssid on every interface every essid

see issue

1 Like

now that does ring some foggy bell. Gave mine away a year ago including the braincells with the usage knowledge.

But wasn‘t it in the former cases that 2nd WiFi would not startup at all? Summary at that time was somehow: when I remember correctly, LuCi incorrectly reused the same Mac/BSSID over, when creating additional WiFis in LuCi. To fix, you had to manually edit the wireless file afterwards, to remove the duplicate value on one of the WiFis.

there a several old threads, this is just some of them

Me :grimacing:. Router is good, wifi did not age well. search for 32X or 3200 + Wifi in the forum grounds about the Wifi limitations, there were lots of threads about this.

If you stick to boring standard no thrill WiFi config and WPA2, you maybe still good.

Other than that for WiFi: market is currently a bit frozen due to chip shortage. Maybe consider RT3200, if available in your country. also check the AX device thread in the hardware section. AX devices support and device availability might also get further improved within the next 6-9 months, I would not rush it (depending on how bad your situation is)

I for myself have moved from 32X to 2 APs (dir 1960/2660) + x86 router.

Third radio is disabled.
Shame about the lack of driver support - it's a decent router generally speaking.
I had a perfectly working Archer C7, but it struggled a bit with CPU when transferring data to an attached USB drive.
Maybe I'll just stick to the 3am radio restarts for now.

I was trying to use this WRT 32X as a secondary router to replace an older Asus 68U. I was able to set it up with stock OpenWRT and it looks pretty solid. The problem started when I tried to set up the guest network. Now I'm following the advice in the forum, and I have tried to modify the BSSID manually and that did not work. I mean it worked for a while and then overnight it stopped working. Now I have deleted the option BSSID from the config wireless file and I'll check again if it will not bomb again overnight.

Also, what I am seeing with Linksys routers with OpenWRT is that the WPA3 is not working properly. Sometimes it loses the connection and the only way to restore it is to switch to WPA2 only option.

Anyhow, I appreciate the help in the forum. Wasn't expecting such a fast response. BTW, is there a way to contribute to the OpenWRT development, like money or something? How are the developers getting supported?
Thanks

thats because WPA3 is not implemented at all in the binary driver of the 1200(?)/1900/3200/32x Linksys WRT family. Luci does not know about these driver restrictions. Dont enable it

I've deleted the second SSID from my 2ghz radio, but I don't think that is going to fix my issue because I created that SSID as a test when the main one kept breaking.

Quick update - the radio restarts worked for a while, but now the 2Ghz network is pretty much failing completely. Clients just can't get an ip address.
I've tried using sysupgrade to revert to the factory firmware, but the router doesn't seem to boot afterwards and I have to do the 3 x power on trick to force it to boot back into OpenWRT.

When I used a WRT32X I added

  • a cron entry to restart network at 4AM every morning
  • the following was also added to rc.local
echo "0" > /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" > /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu
echo "1" > /sys/module/mwifiex/parameters/disable_tx_amsdu

That was pre version 22.x, maybe even pre 21.x, it's been a while - so I don't know if any of the above is still relevant - well, the network restart I guess is, pre-emptive restart every day doesn't hurt

It was never relevent for wrt3200acm/ wrt32x. Disabling amsdu is a workaround for a bug in the 88W8864 (WRT1200/1900): [https://openwrt.org/toh/linksys/wrt_ac_series#latency_with_88w8864]

Best thing @hybiepoo could do if they want modern WiFi is to plug in a WiFi 6 access point. Either the U6-Lite (what I use with my wrt32x) or WAX214 are $100.

There are no high end wifi6 routers supported by OpenWrt, maybe not until ath11k matures. E8450/RT3200 is a lower end supported option until then.

2 Likes

For the record, I'm not after "modern" WiFi. I just want reliable WiFi. If I could go back to stock firmware now I would so I could have the proprietary driver, but none of the methods I can find will work.
Neither does flashing dd-wrt, though I guess it will have the same issues if it's using the same open source driver.

I bought this router for its improved CPU over my Archer C7 so that my SFTP transfers were not consuming the entire CPU.

Use the Archer as an AP and turn radios off. Not sure as to the no go back, maybe the partition size change, possibly try backing up to a release predating that change and try from there.

1 Like

Good point, I think that was a hangover from when I had one of those 1200 or 1900 (can't recall which) - I just blindly copied stuff when I "upgraded" :smiley:

Lol wouldn't done much harm anyway, you would have just lost a bit peak throughput.

Hopefully I've fixed the problem by buying a R7800. Will find out when it arrives.

not that the wrt32x wifi was any good to begin with!

They have decent throughput for routing gigabit internet though - thinking of switching back to one just for routing duties, no wifi though