WRT3200acm will not flash to second partition

Hi I flashed my WRT3200acm with a build I built my self. OpenWrt SNAPSHOT r10263-bc47285cb3 / LuCI Master (f138fc93)
Kernel Version 4.19.52
Now I am stuck on this build. I have tried to flash OpenWrt 18.x and even tried flashing back to stock. :disappointed:
So when I flash a new build it just reboots back in to the old build.
When I look in Advanced Reboot it shows that k4.19.53 Is on the other partition. When I click the button to switch to the other partition it says.

Failed to execute call dispatcher target for entry '/admin/system/advanced_reboot/alternative_reboot'.
The called action terminated with an exception:
/usr/lib/lua/luci/controller/advanced_reboot.lua:119: attempt to concatenate global 'errorMessage' (a nil value)
stack traceback:
	/usr/lib/lua/luci/controller/advanced_reboot.lua:119: in function </usr/lib/lua/luci/controller/advanced_reboot.lua:98>
	(tail call): ?

I think there is something raung with my uboot.

root@Tappers-router:~# fw_printen                                               

 Warning: Bad CRC, using default environment                                     

 bootcmd=bootp; setenv bootargs root=/dev/nfs nfsroot=${serverip}:${rootpath} ip=

 ${ipaddr}:${serverip}:${gatewayip}:${netmask}:${hostname}::off; bootm           



 root@Tappers-router:~# cat /proc/cmdline                                        

 console=ttyS0,115200 root=/dev/mtdblock6 ro rootdelay=1 rootfstype=jffs2 earlypr

 intk mtdparts=armada-nand:2048K(uboot)ro,128K(u_env),256K(s_env),256K@8064K(devi



cat /proc/mtd
 dev:    size   erasesize  name                                                  

 mtd0: 00200000 00020000 "u-boot"                                                

 mtd1: 00020000 00020000 "u_env"                                                 

 mtd2: 00040000 00020000 "s_env"                                                 

 mtd3: 00040000 00020000 "devinfo"                                               

 mtd4: 001e0000 00020000 "sysdiag"                                               

 mtd5: 05000000 00020000 "kernel1"                                               

 mtd6: 04a00000 00020000 "ubi"                                                   

 mtd7: 05000000 00020000 "kernel2"                                               

 mtd8: 04a00000 00020000 "rootfs2"                                               

 mtd9: 05600000 00020000 "syscfg"                                                

 mtd10: 005c0000 00020000 "unused_area"                                          


UBI version: 1

Count of UBI devices: 2

UBI control device major/minor: 10:59

Present UBI devices: ubi0, ubi1

That's all the info I can find for now. Thanks.

I don't think this is solved.

Then you may like to check with the OP in the other post.

Dun. :blush: Thanks for the advice. I was on my first coffie of the day when I made this thred. lol

When I do:
/usr/sbin/fw_printenv -n boot_part
I get;
Warning: Bad CRC, using default environment

Error: "boot_part" not defined

What happens if you try to look at the "raw" U-Boot data with

hexdump -C -n 1024 /dev/mtd1

(u_env partition from https://openwrt.org/toh/linksys/linksys_wrt3200acm)

How about checking


If you have a serial connection you might try resetting and saving the uboot environment.

I broke it even more. lol Now it will not boot. I do have a USB to ttl cable so I need to dig it out. Can I fix it from windows? My screenreader cant work in linux. Unless it can be dun from WSL but I don't think that would work.

Should be able to with cmder or putty. whatever you use on windows. The driver for your usb tty cable may be an issue depending on type.

Damb! lol How do I find out the driver. Will it show up in device manager?