WRT3200ACM Upgrade is Partial and Incomplete

Hello All
Yesterday I got impatient and compulsive and without thinking upgraded my
Linksys WRT3200ACM (lovely router) from 19.07 to 21.02.1.
Admin and wireless (OMG the bandwidth!) functions look good but I have lost control
of some physical ports.
My UCI-fu is weak since I am mostly reliant on LUCI.
Assistance is appreciated in diagnosing and resolving why the LAN/VLAN ports
are not operating...thanks in advance.

The image I am using is ...
|Firmware Version|OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.314.39479-e1ccb66|

Did you keep the settings when you upgraded from 19 to 21? As this is an upgrade to a major release with significant changes in the configuration files, it is highly advised to upgrade without keeping settings and configure the device from scratch. If you did keep the settings, do a reset to defaults and configure the router from scratch.

1 Like

It is a DSA device from 21.02 so you need a completely new network config setup.


Thank you
If I am to do this properly, I am assuming I can hit the Big Red Button "Reset to Defaults", in
BTW I have a backup of my previous config, the only complex part is that I am port
mirroring all of my traffic to a analyzer.

That's right.

That's good, the main differences are in DSA.

Port mirroring isn’t easy available in 21.02, at least not as easy as in 19.07 where you had this in switch menu in LuCi.

1 Like

I made some diving into this port mirror question earlier this year. But I didn’t really try this method, I instead used 19.07 for the port mirror work I had to do then.

Thanks, I will try this out. Unfortunately it will have to wait until tomorrow, you know
work-from-home and all that :roll_eyes:.

1 Like

I have restored the basics; internet, Wifi, wired access.
While trying to do more I saw instabilities in LUCI. Uhttpd appeared to lock up
or go into a funny state that eventually seized up the entire router.
I am going to be watching it for now.

Any further advice on WRT3200 + 21.02.1 is appreciated.

I will be looking for LUCI updates that might be relevant...

Luci isn’t updated by its own, that is included in the whole OpenWRT package.

I haven’t really heard any else problem for this device other than the hopeless wifi problem.

If you ask me you should probably make a new forum post for the uhhtpd error. I haven’t heard much problem with that earlier in this forum and use it my self.
I don’t think that uhhtpd fault you describing is device specific but a luci fault and no one will see that single problem embedded in this forum tread. But it is important to investigate further and maybe file a bug report.
And then mark this forum tread as solved if you have solved the original problem.

1 Like

Sounds like what happens when sae mixed is attempted.

Thank you for the suggestion. I will close this case and continue to observe my
device. I still have to implement my port mirroring sometime as well.

Take care.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.