WRT3200ACM & Tunnelbroker - workaround, it's working so far

Hello all,

First post. I don't usually have things to offer on a first post, but this time I do!

OpenWrt 18.06.4 r7808-ef686b7292 / LuCI openwrt-18.06 branch (git-19.170.32094-4d6d8bc)

I configured HE Tunnelbroker and it worked once then after a reboot it doesn't work. No devices can send out of the network to the default gateway.

The problem is that the tunnel DOES come back up after a reboot (on WAN6) but it appears the gateway is wrong, as others have already stated.

I have tried a lot of different options after reading lots and lots of posts on forums.
I believe I've found a work around to make it work. How do I add a delay in one of the config files? I think that might fix the problem as it seems the WAN6 and default gw come up before the system is fully ready.

I have changed the WAN6 advanced settings "bring up on boot" is now deselected. If you then reboot the box and manually connect the tunnel the routing works ok. Every time so far.

The problem is that if you deselect "bring up on boot" and save & apply, it does save that option but after a period of time it the "bring up on boot" goes back to having the box selected again! How is this happening?

cheers,
Mukiwa

I've been using HE's tunnel on this device since version LEDE 17, and have never had any issue similar to what you explain here... I can't even say I fixed it, I just never experienced it.

I remember I added and "option ifname '@wan'" line, but everything else is exactly as explained in any guide.

I am not trying to deny the issue or reject your solution, but perhaps there is something wrong somewhere else.

1 Like

Please, post your network configuration:

uci show network

I've never had a problem on Shibby tomato or advanced tomato I set it up and it worked instantly.

I upgraded to this WRT and it is a huge improvement apart from the Tunnelbroker issue.
I've tried to have my Opnsense be my Tunnelbroker but OpenWRT WAN6 will not take any DHCPv6 addresses. If I attach my pc via cable to the Opnsense it works first time. Something is not right that is for sure.
Right now my Openwrt is still pinging ipv6.google.com for 3 hours, no issues. My lan pc can ping for a few minutes then the route drops.

Here is my uci show network output

type or paste code hnetwork.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.lan=interface
network.lan.type='bridge'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ipaddr='172.16.1.1'
network.lan.gateway='172.16.1.1'
network.lan.broadcast='255.255.255.255'
network.lan.dns='172.16.1.251'
network.lan.ip6assign='64'
network.lan.ifname='eth0.1'
network.wan=interface
network.wan.ifname='eth1.2'
network.wan.proto='pppoe'
network.wan.username='username'
network.wan.password='password'
network.wan.delegate='0'
network.wan.ipv6='0'
network.wan.peerdns='0'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 3 5t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='4 6t'
network.root=interface
network.root.proto='static'
network.@wireguard_WireGuard[0]=wireguard_WireGuard
network.@wireguard_WireGuard[0].route_allowed_ips='0'
network.keznet=interface
network.keznet.proto='static'
network.keznet.ipaddr='10.10.10.1'
network.keznet.netmask='255.255.255.0'
network.keznet.gateway='172.16.1.1'
network.keznet.broadcast='255.255.255.255'
network.keznet.dns='208.67.220.220 1.1.1.1 9.9.9.9'
network.keznet.ip6assign='64'
network.wan6=interface
network.wan6.proto='6in4'
network.wan6.peeraddr='216.66.80.26'
network.wan6.ip6addr='2001:xxxxxx::2/64'
network.wan6.username='username'
network.wan6.ip6prefix='2001:xxxx::/48'
network.wan6.tunnelid='123456'
network.wan6.password='password'
network.OpenVPN=interface
network.OpenVPN.proto='none'
network.OpenVPN.ifname='tun0'
network.OpenVPN.auto='1'ere

Hi,

I've put that into /etc/config/network now.

I'll let you know,

Thanks for your help :slight_smile:

1 Like

Hi,
Thanks for your help, it worked!

The only problem now is I need to manually restart my wan6 interface daily as I have a timer on the modem to reboot it every 24 hours to get a fresh IP address. This has cured the Plusnet connection speed to stay consistent rather than slowly dropping off over a period of days.
Cheers

I wrote a script that configures a HEnet 6in4 tunnel. (I used it when I was flashing new firmware frequently...)

But the script has a note at the end that describes a URL that you can invoke to re-establish the tunnel using your new external IP address. I don't know if URL still works, but if so, you could put something like wget https://... in your Scheduled Tasks.... The script is at:

PS Just so future readers know, there's also a wiki page for Setting up an IPv6 Tunnel with LuCI if you don't want to use the command line.

1 Like

Hi Rich,

Thanks mate, I'll try it out!

Hi Rich,

Update from my end. I never had to use your script in the end. I have no idea why things suddenly started working but I did change a couple of things.

  1. I installed a mechanical timer on/off switch on the power line (night time off / on)
  2. Changed DDNS from ipv4 first then ipv6 to ipv6 (HE net) first, ipv4 second.

All been well since.
Thanks for your advice.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.