WRT3200ACM Slowing down and Dropping

Hello all,
I bought a Linkys WRT3200ACM a month ago, and put OpenWrt on it. It worked perfectly for the first 2-3 weeks; then it started giving me problems.

  1. My 5GHz radio used to give me 220 Mbps consistently the first week. Now I get 100 Mbps, if I am lucky. I connected my computer to the ethernet directly and get 220 Mbps, so I know my modem and ISP are not the problem. I did no updates not did I change the configuration. It just slowed down on its own.
  2. My 2.4 Ghz radio for my older devices is consistently dropping, especially on my Roku stream players.

My guess is that it is a faulty driver. I also bought a fan since the router gets hot. I tried rebooting and resetting the router, but I still only get 100 Mbps. I could get 220 Mbps without trying a month ago.
I am running OpenWrt 19.07


any device that runs hot to the extent a fan is needed is not a good sign and could be a sign of some other problem, not a faulty driver

i have had a wrt3200acm for many years, always updating when a new version of openwrt, currently running v19.07. the router never ran hot and it is in a closet without much air flow.

see what processes are running, perhaps there is a process using a lot of cpu cycles.
install htop and sort by percent_cpu

one test might be to use the linksys firmware and see what happens.

Hot to the touch is usually 40-50C and above is considered unbearably hot, while the SoC silicon depending on process size might be able to do 90-100C for it's entire projected lifespan. Usually most of the electronic components on the board are rated for at least 80C continuous operation as well.

I'd first check what the actual temperature is with something like collectd or via checking /sys for temp values if the device supports that. If you're not pushing 75C+, I wouldn't even bat an eye.

For example I've got a Raspberry Pi4 with a aluminum heatsink attached, passive. The heatsink is currently at 54C, SoC around 56C. I can't hold my finger on the heatsink for longer than a few seconds because it's painful. But the RPi foundation engineers tell me that the RPi4 should last 35 years when operating below throttle temp (85C).

my wrt3200acm runs at 25C

as per the linksys manual
Operating Temperature 32 to 104°F (0 to 40°C)
Storage Temperature -4 to 140°F (-20 to 60°C)

the router might cutting power to the cpu and/or wifi chip, to reduce heat.

if you have a power meter, you might see what the router is consuming.
my router runs average 20VA

What the heck? 25'C ???

As measured by the built-in temperature sensors (shown in LuCI statistics), the CPU temp is around 80'C and the circuit board temp about 55'C in wrt3200acm with light load.

Find 25C a little bit doubtful, my rango runs at ~57C.

the OP never mentioned chipset, just the router and so did i.

if the router is hot enough to need a fan, that is a sign of problem.
the point is this is a new router, could have a manufacturing problem.
my wrt3200acm is many years old, never a problem.

the router could be cutting power to the wifi.
checking the real-time and average power sent to the wifi, that would be of use.

i will double check the temp, as i use F, not C.
i just setup two thermometers on the router, i will soon post the results.

it could be good to check the cpu temp as well and power usage of the entire router.

Paths from mamba fan control script, @hnyman do you know if the paths differ on the rango

cpu=`cat /sys/class/hwmon/hwmon2/temp1_input`
ddr=`cat /sys/class/hwmon/hwmon1/temp1_input`
wifi=`cat /sys/class/hwmon/hwmon1/temp2_input`
root@OpenWrt:~# cat /sys/class/hwmon/hwmon2/temp1_input
cat: can't open '/sys/class/hwmon/hwmon2/temp1_input': No such file or directory
root@OpenWrt:~# cat /sys/class/hwmon/hwmon1/temp1_input
root@OpenWrt:~# cat /sys/class/hwmon/hwmon1/temp2_input
cat: can't open '/sys/class/hwmon/hwmon1/temp2_input': No such file or directory

Yes, 78927 millicelcius = 78.927 'C

good to know thanks
so that is for ddr, but what exactly is that?

Not quite sure, as I have just monitored it via LuCI statistics, without trying to identify exactly which value comes from which component.
In WRT3200ACM (rango) there are actually more sensors, both on hwmon path, and elsewhere (which collectd's sensors modules finds).

I just booted up my WRT3200ACM, so the values are low:

root@router3:~# cat /sys/class/hwmon/hwmon*/temp*_input

Two other sensors also shown in LucI stats:

That would actually be the CPU temp on the rango:

root@bsaedgy:/sys/class/hwmon# cat /sys/class/hwmon/hwmon1/temp1_input

how would i see that same info, as i cannot find it in the web interface?
do i need to install a package?

Install LuCI statistics (which install collectd itself), as well as thermal and sensors support in collectd (and lm-sensors to make the config possible via LuCI).

opkg update
opkg install luci-app-statistics
opkg install collectd-mod-thermal
opkg install collectd-mod-sensors
opkg install lm-sensors

ps. right now there seems to be download trouble at the OpenWrt package repo

1 Like

i checked with two kitchen thermometers, not the most accurate but a good baseline.
both are at approx. 26'C.
in a closet with little air flow

of course, the minute i try to install packages....

Hello all,
Thank you for all the great responses. I quickly checked right now since I am taking an exam today, and I am surprised how many responses I got. I will upload my temperature statistics tomorrow or Wednesday, and maybe flash the Linkys firmware as well. It could possibly be a hardware problem since it worked perfectly at first and gradually slowed down within a month. I did not update anything or reconfigure OpenWrt.

thanks, i installed all the packages

the problem is that i see only one chart, how can i see what you screenshot showed?

i tihnk that thermal_zone0 = cpu temp

and this my setup

The other graphs are possible to see on the sensors page, not thermal.

( Look at my example above)