WRT3200ACM single core getting maxed

I am aware the other core is used for wifi, but I am just using it as a router. So I was wondering if I could improve performance by enabling the other core.

there's an irqbalance package

I have been trying to get this to work, I finally think I got it to work but am unable to tell if it is on the proper setting.

The wiki for irqbalance is outdated for ssh now I guess. So I am unaware on how to get it into setting 3 so it fully uses both cores.

you should only need to enable it in /etc/config/irqbalance, and start the service

cat /proc/interrupts | grep eth

I get permission denied within ssh

  • But I'm pretty sure I already enabled it within Luci web UI.

What does this do?
"37: 29274302 0 MPIC 8 Level eth0" Is the response the console gave me.

cat /proc/interrupts to see the whole list.

Prior to DSA on this platform, you would see both CPUs like this:

36:   15572107          0      MPIC   8 Level     eth1
37:    2380424          0      MPIC  12 Level     eth0

cat /proc/irq/default_smp_affinity to see your current affinity. It's probably already set at 3.

It boils down to `irqbalance' won't work on your platform under DSA - ATM.

DSA does not support multiple cores. (yet)

As far as I remember, ethernet IRQ cannot be moved in this router. Enable packet steering in the firewall page instead.

1 Like