WRT3200ACM running 22.03.2. WAN DHCP drops out, no internet until I restart or reboot

I have a few of these, but I've heard similar problems with the WAN DHCP not routing to its uplink gateway.

I can't ping, but if I restart the wan interface, it will come back, as well as a restart of the device. It also appears that sometimes it will come back on its own.

I have Spectrum Internet with a new 2.5G Motorola modem, I believe, and it appears to work fine directly through the ethernet port.

OpenWrt 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branch git-22.304.65171-ec905e6

I removed WAN6 and all IPv6 because I am not using it and did not know if that was part of the problem, but it did not improve.

Suggestions? Thank you.

root@Wireless:~# uci show network; \

network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdbf:a5f4:5e2a::/48'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='lan1' 'lan2' 'lan3' 'lan4'
network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.200.1'
network.lan.dns_search='spectrum.net'
network.lan.dns='1.1.1.1' '8.8.4.4' '8.8.8.8'
network.@device[1]=device
network.@device[1].name='wan'
network.@device[1].macaddr='62:38:e0:be:46:48'
network.wan=interface
network.wan.device='wan'
network.wan.proto='dhcp'
network.wan.force_link='1'
network.wan.peerdns='0'
network.wan.dns_search='spectrum.net'
network.wan.dns='1.1.1.1' '8.8.8.8' '8.8.4.4'

root@Wireless:~# ip -4 addr ; ip -4 ro li tab all ; ip -4 ru;
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
inet 66.91.33.174/22 brd 66.91.35.255 scope global wan
valid_lft forever preferred_lft forever
22: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
inet 192.168.200.1/24 brd 192.168.200.255 scope global br-lan
valid_lft forever preferred_lft forever
default via 66.91.32.1 dev wan src 66.91.33.174
66.91.32.0/22 dev wan scope link src 66.91.33.174
192.168.200.0/24 dev br-lan scope link src 192.168.200.1
broadcast 66.91.32.0 dev wan table local scope link src 66.91.33.174
local 66.91.33.174 dev wan table local scope host src 66.91.33.174
broadcast 66.91.35.255 dev wan table local scope link src 66.91.33.174
broadcast 127.0.0.0 dev lo table local scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local scope host src 127.0.0.1
local 127.0.0.1 dev lo table local scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link src 127.0.0.1
broadcast 192.168.200.0 dev br-lan table local scope link src 192.168.200.1
local 192.168.200.1 dev br-lan table local scope host src 192.168.200.1
broadcast 192.168.200.255 dev br-lan table local scope link src 192.168.200.1
0: from all lookup local
32766: from all lookup main
32767: from all lookup default

root@Wireless:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdbf:a5f4:5e2a::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.200.1'
list dns_search 'spectrum.net'
list dns '1.1.1.1'
list dns '8.8.4.4'
list dns '8.8.8.8'

config device
option name 'wan'
option macaddr '62:38:e0:be:46:48'

config interface 'wan'
option device 'wan'
option proto 'dhcp'
option force_link '1'
option peerdns '0'
list dns_search 'spectrum.net'
list dns '1.1.1.1'
list dns '8.8.8.8'
list dns '8.8.4.4'

root@Wireless:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'

config dhcp 'lan'
option interface 'lan'
option leasetime '12h'
option start '200'
option limit '255'
option force '1'

config dhcp 'wan'
option interface 'wan'

You do not need this in either LAN or WAN:

list dns_search 'spectrum.net'

And you should not use this in LAN:

list dns '1.1.1.1'
list dns '8.8.4.4'
list dns '8.8.8.8'

But I do not think this is the cause of the issue.

Are there any relevant messages in the logs?
Can you do a traceroute, and show us the results?

I'll remove those.

I did run a traceroute. It will never go passed the uplink gateway, nor does the uplink ping or respond.

If I restart the interface, it'll come back within 30 seconds or so.

Not seeing any errors, however, I did switch it back to Linksys firmware and it has been running fine, for whatever that is worth.

My R7800 Netgear Nighthawks running the same OpenWrt are not experiencing this problem and run the same 22.03.2 version.

What could I do to turn on more verbose logging and diagnostics to try and see if there are software or hardware problems?