WRT3200ACM on 23.05-RC3 can't use 5GHz WiFi

Just updated mine from RC1 and then figured out that there is no usable 5GHz radio.

The problem is: radio0 which supposed to be 1st 5GHz becomes "Generic Unknown" and not possible to enable. radio1 is 2.4GHz so everything alright; While radio2 is another 5GHz showing "Marvell 88W8887 802.11ac/b/g/n" can only be set with channel "Auto" (anything else will disable it) and system defaults it at CH 149. Even with 149 my clients can not use it at all.

Below is the config, any clue how to fix it?

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option cell_density '0'
        option country 'JP'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '60:38:e0:aa:bb:cc'
        option encryption 'psk2+ccmp'
        option key 'xxxxxxxxxx'
        option wpa_disable_eapol_key_retries '1'
        option ssid 'Testing'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option band '2g'
        option htmode 'HT20'
        option country 'FR'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '60:38:e0:aa:bb:cc'
        option ssid 'Testing'
        option encryption 'psk2+ccmp'
        option key 'xxxxxxxxxxxx'
        option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option channel 'auto'
        option country 'JP'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'Testing'
        option encryption 'psk2+ccmp'
        option key 'xxxxxxxxxxx'
        option wpa_disable_eapol_key_retries '1'

I see 'option country' is different - JP on radio0 and FR on radio1. What happens if you align these correctly to the country you're living in?

Also, you have no values for

   option band '5g'
   option htmode 'VHT80'

in config wifi-device 'radio0'

mine looks like this for example

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option country 'FR'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWRT3'
        option encryption 'psk2'
        option macaddr '24:f5:a2:c0:43:2a'
        option key 'xxxxx'

PS - FR seems to be the OpenWRT default. I have it even though im in the UK and it works fine

1 Like

One major difference though, UK and FR are both collated under ETSI regulatory rules (yes, the UK has been diverging recently, but the old Marvell firmware doesn't know that - and none of those differences matter much to the 2.4/ 5 GHz radios in those Marvell routers anyways). Japan/ MKK is considerably different though, with quite different allowed channel maps.

The regulatory settings for all radios must match and be correct for your region (achieving that might require removing the mwifiex kernel modules, as that radio is hardcoded to FCC).

2 Likes

Already aligned all to JP, still doesn't work, I will try to reset the whole router to see if there is any change.

Yes, let us know the result

Reset the router to default, still observing weird thing.

Radio0 is 2.4GHz, nothing special and fully functional.
Radio1 is 5GHz, Auto channel selection always 149 DFS (why?), but even I tried to connect it, the speed is only about 20-30Mbps.
The second 5GHz radio disappears (I suspect the above one is the one we shouldn't use but there is no more 5GHz radio now)

Hmm.
My understanding is that radio2 cant be used. But you now say that radio0 and radio1 are now transposed! Do they all show as country = JP?

Can you edit any of these values, either through LuCi or through CLI?

I already changed both to JP when I reset the router.

So that now works then. I cant explain low 5g performance though. Having radio0 and radio1 transposed makes me wonder whether you had a bad flash? You had no such issues before?

If not i would be tempted to reflash, don't keep settings and rebuild the config manually.

Does anyone else have any ideas?

1 Like

No it doesn't work since I put it on 23.05-RC3, it was OK when I use 22.03.2 (because I only use WiFi so the switch issue wasn't a problem for me)

Ok. So if the previous version of the software works works ok for you, it could just be a bad flash.
I would therefore

  1. download a fresh copy of rc3
  2. tell the router to boot from the other partition. (The one with the good software on it)
  3. copy the config
  4. flash rc3 again from there. That way you keep the existing partition and OpenWRT will the overwrite the broken rc3
  5. do not keep settings but configure it manually, if necessary using the working config you copied
1 Like

See the README, you cannot override the CC of the eeprom locale with mwlwifi, so do not set a Country Code, and turn off radio2

config wifi-device 'radio2'
...
	option disabled '1'

How to do this?

SSH into your router.

Run:/usr/sbin/fw_printenv -n boot_part
It will give you a 1 or 2. This is the partition you are currently using with rc3

Then run the following - /usr/sbin/fw_setenv boot_part 2 changing the number to that of the other partition. Reboot the router and it will boot into this partition

By design, when you flash the firmware it installs it on the partition that you are using, and this will now be the one with rc3

Love yourself a little and throw that junk in the trash and buy a router with support for mt76 wifi drivers.

bootTaOther.sh
#!/bin/sh
#hacked from /lib/upgrade/linksys.sh

cur_boot_part=`/usr/sbin/fw_printenv -n boot_part`
target_firmware=""
if [ "$cur_boot_part" = "1" ]
then
    target_firmware="kernel2"
    fw_setenv boot_part 2
    fw_setenv bootcmd "run altnandboot"
elif [ "$cur_boot_part" = "2" ]
then
    target_firmware="kernel1"
    fw_setenv boot_part 1
    fw_setenv bootcmd "run nandboot"
fi
# re-enable recovery so we get back if the new firmware is broken
fw_setenv auto_recovery yes
echo "$target_firmware"
reboot

@anon79208902 - Hardly a piece of junk, just mwlwifi is a borked piece of s***

3 Likes

No I won't, even the WiFi might be a bit bad to use, I would still want to use it as a wired router due to it's speed, as well as expansion option, I can connect a 4-bay eSATA tower to it to act as an entry level NAS.

for wrt3200acm radio2 can be forced to FR:

root@OpenWrt:~# nano /etc/modules.d/mwifiex-sdio
mwifiex_sdio
mwifiex reg_alpha2=FR

after reboot I could use 5GHz on rc4

before:

root@OpenWrt:~# iw reg get 
global
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#2
country US: DFS-FCC
	(2400 - 2472 @ 40), (N/A, 30), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5730 - 5850 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#1
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

after:

root@OpenWrt:~# iw reg get 
global
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (N/A)
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#2
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (N/A)
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (N/A)
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country FR: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
	(5250 - 5350 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
	(5470 - 5725 @ 160), (N/A, 26), (N/A)
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)
1 Like