Wrt3200acm no wan ip

After installing the latest release for the Linksys Wrt3200acm it will not pull a wan IP from my modem/comcast using an sb6121. It will get one if i connect to my old router, or when i flash back to stock firmware. Awkwardly my isp gives a new ip depending on what device i plug in, i though we were running out of those?
Im having trouble finding a solution and hoped to find insight here, any thoughts?

I used default setup and everything looked good.

Edit: new modem and everything is fine, old one was old.

Just to be clear, you're on a cable (docsis) connection.

What happens here is that the ISP uses the router's MAC address for authentification and its DHCPd, they lock on this MAC address. In most cases it helps to power off both cable modem and the (new) router for a bit, e.g. 15 minutes, for the ISP to release the previous DHCP lease (they only allow you to use a single device/ MAC at a time) and accept the new one. In other cases you may have to phone them to release the old MAC manually and accept the new one.

Alternatively you could also clone the WAN MAC address of your old router and use that on your wrt3200acm's WAN interface instead, so that the ISP won't even notice the change - while this should always work, I'd only go this route as a last resort.

Thanks for the fast reply. Yes im on cable, and no I didnt wait longer than 10 minutes. I could try being more patient, however, I was able to connect quickly in each scenario outside of having openwrt on it. I did try using the mac from the 1st router but didnt work. I have flashed back to stock firmware and its working. Im wondering if there is another identifier that is used along with MAC to let me on and they dont like openwrt? I called comcast and they didnt know but they do want me to get a 3.1 modem.

That's also possible (by requiring special dhcp options being set for the dhcp request), but not very common. It's also possible, but also not very likely, that you're encountering a interoperability problem between your ISP's DHCPd and the DHCP client used by OpenWrt, respectively a bug in the later; it's not impossible, but not likely.

No dude there are least chances of this . That single session issue ithat you mention above is possible because we ususlly do that with radius attribute called simultaneous-use and Mac binding to that port. Both working together
Other possibly is the port policy which shut it down for sometime on seeing different mac

So I should probably wait longer when I give this another go I suppose? Resetting the modem to default requires the coax disconnected and it says to wait 5-30 minutes.. I can will give this a try. The fact that i got an ip when attached to the other router makes me think the firmware works fine. Lan worked fine with network shares, ssh, and google.

Have you enabled the broadcast checkbox on WAN?


If your ISP instructs you to do this, then you must wait. By any chance, were you required to give them the MAC address of the old router?

1 Like

I gave the broadcast checkbox a try but perhaps needed to wait longer. No to the mac supply, they didnt ask me and as far as i can remember ive never given them a mac for anything except the modem.

You could try this:


Adding the MAC of your old router.

I gave that a try but no work. Router works with stock firmware and mac fine though. Perhaps with other suggestions included this will work

1 Like

Can you show the configuration lan/wan with new firmware

I will do this after work today when i give this another attempt. I used the default config yesterday and everything looked good.

So i found time to play with this again and was super patient in the troubleshooting steps but still could not obtain a wan connection to the modem. Again it works with stock firmware and openwrt works fine if i plug the other router between this one and the modem. The config is just default but i am at a loss. My network knowledge drops off at modems, but as i understand my modem is supposed to bridge itself to the router. Is there a way i can force or promote this interaction in my config file?

Edit: This is done automatically by the modem when it detects a router connected to it.

I got desperate enough to call my isp and that went as well as you might imagine, but now i no longer get different wan ip's based on what device i have plugged into the modem. I tried specifying this ip, subnet, and gateway and that didnt work either.
Per the norm my modem will always require a restart when the device connected to it has been swapped.. I connected the router with owrt and restarted modem but it establishes no connection. I had the stock fw in tmp folder ready to flash, send command to sysupgrade, and as soon as its finished it will connect to modem no problemo.

I had also updated the system, connected the owrt router behind the old router to get online again no problem, and ran
opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade
with success. I am at a loss once again.

Can i blame my isp somehow in this? Is there any sort of preamble that would signify to them that im using an open source firmware?

Are you running it (SB6141) in bridge mode? As far as I can tell using Google it's not possible to do so using that particular model with Comcast.

I was mistaken when i first posted and i have the sb6121.

Low and behold, with a new modem everything works fine. I went with another surfboard and this one isnt 7+ years old like the last one. Was worth getting, my download speed is much faster.