WRT3200ACM no connect to ISP

Thank you for reading this post. I have a similar issue as @panda_madness, no WAN connection. Installed OpenWRT 18.06.4, and cannot get to Internet. The settings have been checked with my ISP support and confirmed that the Mac address is correct and a DHCP client IP address is assigned. From their side everything looks normal with this router hooked to their network. Other routers work fine here.

The overview screen does not show an active WAN connection (no IP address, etc). The WAN interface 1.2 shows a Tx and Rx packet count. Diagnostics: ping, etc time out. WiFi and LAN appears to be working fine.

I suspect that the WAN interface is working correctly, but not communicating with the rest of the router. I reverted back to the default settings to stay to the standard settings as close as possible. Is there a setting that may I have overlooked?
BTW, was the BCP38 setting removed from the latest version?

It's a bit hard to help you with so little information... No screenshots, no configuration files, no logs, no details about your ISP...

1 Like

@ReiniervdL, welcome to the community!

Without having enough information, [just] a guess:

Perhaps you failed to reset the firewall back to defaults; and the DHCP answer from your ISP's server is getting blocked, hence no assigned IP address on WAN.

I would advise just resetting the router to defaults; and testing with a known default config.

@eduperez, @lleachii,
Thank you for your response. I did revert back to defaults and tried to bypass the firewall.

Here is more information:
IP4%20upstream Interfaces

Here is an interesting part of the system log that keeps repeating:

Fri Jul 19 19:08:09 2019 daemon.notice netifd: wan (30615): udhcpc: malformed hex string 'root'
Fri Jul 19 19:08:09 2019 daemon.notice netifd: Interface 'wan' is now down
Fri Jul 19 19:08:09 2019 daemon.notice netifd: Interface 'wan' is setting up now
Fri Jul 19 19:08:09 2019 daemon.notice netifd: wan (30631): udhcpc: malformed hex string 'root'
Fri Jul 19 19:08:09 2019 daemon.notice netifd: Interface 'wan' is now down
Fri Jul 19 19:08:09 2019 daemon.notice netifd: Interface 'wan' is setting up now

I changed the ID in the "advanced" section, but did not help and I cannot leave it blank.

Network config:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd97:2d19:4ee0::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'
        option macaddr 'xx:36:3B:8A:A3:xx'
        option delegate '0'
        option broadcast '1'
        option clientid 'root'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'
        option vid '2'

Firewall config:

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'
type or paste code here

Hope this helps. Thanks for supporting.

The DHCP client seems to be rejecting 'root' as a client id. Are you sure you need it? Is that the correct value? Looks like you need to use a hex value there, not a string of text.

1 Like

Hi Eduardo,
Yes, that was it!! The default installation filled it with "root". It cannot be left empty, so I entered 00. Now it works.

Thank you!!

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.