WRT3200ACM multiple WIFI disconnects

If wifi clients remain connected, it could be unrelated to wifi. Do you have wired devices connected to the router?

This is the current configuration:

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd2:5302:23cd::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '5t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '3t 5t'
	option vid '10'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '3t 5t'
	option vid '20'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '3t 5t'
	option vid '35'

config interface 'Admin'
	option proto 'static'
	option ifname 'eth0.10'
	option delegate '0'
	option netmask '255.255.255.0'
	option gateway '10.10.0.1'
	option broadcast '10.10.0.255'
	option force_link '0'
	option ipaddr '10.10.0.253'
	option dns '10.10.0.1 8.8.8.8'

config interface 'Guest'
	option type 'bridge'
	option proto 'none'
	option ifname 'eth0.35'
	option auto '1'
	option delegate '0'
	option force_link '1'

config route
	option interface 'Admin'
	option target '0.0.0.0'
	option netmask '0.0.0.0'
	option gateway '10.10.0.1'

config interface 'Global'
	option type 'bridge'
	option proto 'static'
	option ifname 'eth0.20'
	option delegate '0'
	option ipaddr '10.30.0.251'
	option netmask '255.255.255.0'
	option gateway '10.30.0.1'
	option broadcast '10.30.0.255'
	option dns '10.30.0.1'

config route
	option interface 'Global'
	option target '10.70.105.20'
	option gateway '10.30.0.1'
	option netmask '255.255.255.255'

root@OpenWrt:~# uci export dhcp
package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# uci export wireless
package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option txpower '20'
	option country 'DE'
	option legacy_rates '0'
	option channel '36'
	option htmode 'VHT40'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT40'
	option txpower '20'
	option country 'FR'
	option legacy_rates '1'
	option channel '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option network 'Guest'
	option encryption 'psk2'
	option key '<Guest Password>'
	option ssid '<SSID Guest>'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option network 'Guest'
	option encryption 'psk2'
	option key '<Guest Password>'
	option ssid '<SSID Guest>'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option network 'Global'
	option encryption 'wpa2'
	option auth_server '10.70.105.20'
	option auth_port '1812'
	option auth_secret '<The secret>'
	option ssid '<SSID Intern>'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option network 'Global'
	option encryption 'wpa2'
	option auth_server '10.70.105.20'
	option auth_port '1812'
	option auth_secret '<The secret>'
	option ssid '<SSID Intern>'

The router is only connected to the switch, via cable.
The port is configured as VLAN.

You mentioned that you have multiple Access Points per floor, so did you perform a proper site survey before mounting the APs to their locations?
In your configuration you have maximum transmit power. Is that necessary? It could be a reason for interference and frequent disconnections or staying connected to a non optimal AP.
Are the other APs using the same or different frequencies? It should be the latter.

it should be said that the wifi drivers on this device are abandoned and unfortunately buggy. perhaps brief disconnects occur without any real long term stoppage that would be obvious to the end users.

I'm looking forward to being able to replace mine in a couple years with some WIFi 6 enabled Enterprise access points (when they are widely available eventually).

the wrt3200 would have been a pretty good device if the wifi drivers were supported.

2 Likes

All AP are using different channels on the frequencies.
The increasing of the TX power was only a test mysite. The result is the same.

But when I use a different SSID only for one accesspoint, then It can be the same.
Last time, when I tested by myself, I was idsconnected from the network (not from the wifi) with a 60 minutes interval.

You meen that the wifi driver is not officiell suported by openwrt?
The company advertises with support for opensorce OS.

It's not just OpenWrt, it's the Linux kernel. And it's not Linksys, but rather the chipset makers Marvell. They never really supported the driver with proper levels of information release and/or development resources. Recently Marvell sold off the entire business unit to some other company, and support ended entirely as I understand it.

So, the device "works" under OpenWrt as well as it works under anything at all, which is sort of a 7 on a scale where 9 or 10 is what you'd want for enterprise use.

I've found the occasional "have you tried turning it off and on again" works wonders in my fairly complex network at home (three APs, two wifi networks across multiple channels etc). You might get some benefit from a nightly reboot... can't promise anything though:

https://openwrt.org/docs/guide-user/base-system/cron#periodic_reboot

The nightly restart is already implemented by my side.

When it is true, what you say about the Marvell driver, then it is maybe the diver overloaded with the count of users?

I is there a process available on the openwrt, which I can very fast restart, and it doesn't kicks out the users?

Do you can recommend a good device for openwrt for company use?

I doubt it's the number of users that's the issue. People experience these sort of random issues even in home environments with just a few devices.

WiFi for VOIP use is extremely demanding. Even 100ms of downtime is very noticeable. There's no way to restart without kicking out users off the device. However if there are multiple APs all on the same ESSID, you should be able to turn a device off and the clients renegotiate with another device. You'll lose about 1s of audio, but you shouldn't drop the call.

As for what's a good device for enterprise use... You'd really want something tested and stable. I couldn't recommend anything in particular. I can say the gl-inet devices are at least supported by the manufacturer and run a slightly modified openwrt out of the box. Perhaps something like the GL-B1300? but I really don't know.

Not exactly OpenWrt, more like under-the-hood, but works like a charm:

uap-ac-lite-gf-BZ.v4.0.80# cat /etc/os-release 
NAME="LEDE"
VERSION="17.01.6, Reboot"
ID="lede"
ID_LIKE="lede openwrt"
PRETTY_NAME="LEDE Reboot 17.01.6"
VERSION_ID="17.01.6"
HOME_URL="http://lede-project.org/"
BUG_URL="http://bugs.lede-project.org/"
SUPPORT_URL="http://forum.lede-project.org/"
BUILD_ID="r3979-2252731af4"
LEDE_BOARD="ar71xx/ubnt"
LEDE_ARCH="mips_24kc"
LEDE_TAINTS="no-all mklibs busybox"
LEDE_DEVICE_MANUFACTURER="LEDE"
LEDE_DEVICE_MANUFACTURER_URL="http://lede-project.org/"
LEDE_DEVICE_PRODUCT="Generic"
LEDE_DEVICE_REVISION="v0"
LEDE_RELEASE="LEDE Reboot 17.01.6 r3979-2252731af4"

Look at the Unifi products from Ubiquity.

I brought now the GL .inet B1300

This is running by default on 15.05.1.

Can it be, that this device doesn't supports VLAN by default?

The switch is also very confusing here.
It shows me 6 ports, but the device has only 3 physical ports.

The wrt3200acm needs option country 'DE' changed to option country 'FR' on all radios. Plus LEDE and OpenWrt 15.xx is verry old. You should change the option country 'FR' and update OpenWrt on the wrt3200acm to:
https://downloads.openwrt.org/releases/18.06.6/targets/mvebu/cortexa9/openwrt-18.06.6-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin
You can flash this upgrade and save your configs. If you still get the wifi drops then you can try updating to the 19.xx branch.

You should always set the country to where you are operating your router, not some other country.

@tmomas The WiFi driver on the wrt3200acm is broken so you can not run
different country codes for that setting.I am in GB, but if I make that
change wifi runs like shit!
I have to keep mine set to FR on all 3 radios.

Hi

All configurations here are not working for me.

Not the changes with the TX and not with the change of the country code.
Also the update to 18.06.6 and 19.07.1 was no solution for me.

That means the hardware is the reason.

I don't want to spend more time in this device.
But we have a lot of this devices here. :slightly_frowning_face:

When somebody has one more idea for me, this can maybe help, but I already ordered one 2 new devices for testing.

I want to solve this problem asap.
so the employees can not more cry about the WiFi.

Thanks for all helps here.

I just have one of these routers, perhaps I was extra lucky and got a good one...

Both my wife and me work from home, so there are two laptops (different brands) connected by wifi to this router, for eight to ten hours straight. We both have a different VPN connection open the whole time, we both make frequent VoIP calls that last one hour or even more with multiple participants. In my case, this is 100% reliable, or I would have bought something else, I just cannot afford to lose the privilege of working from home.

We also have two TVs at home, one is 4K and the other just FullHD. Both are connected to the same router, and both can stream a show at the same time, while someone else is working on the laptops. Again, zero interruptions and zero lagging allowed, or I would sleep on the sofa.

There are five different phones connected to this routes right now, different brands and different generations. No issues so far. I could continue, but it looks like I am bragging about my gadgets.

I am not saying this router is perfect, there are several well known issues. And I am not saying this is all your fault because it works for me. But perhaps you should look a bit deeper before blaming the device.

1 Like

I have a similar selection of gadgets, and two WRT32x devices in use as access points, with two ssids in use. one is wpa2-eap protected and the other is unencrypted guest.

my Android phones generally connect and stay connected. My fire tablets on the other hand when they go to sleep they come back on showing a connection, but don't actually have one, they require turning wifi off and on again... my Linux laptops work well, but my wife's Mac doesn't. she has to turn wifi off and on about 5 times a day.. occasionally the guest ssid allows association but no internet access, turning the AP off and on solves it...

i think there are known issues with multicast on this device? since ipv6 requires good multicast for router adverts, and ipv6 is an integral part of my network, I think this is part of my issue. I will ditch these as soon as the next wifi6 generation of devices comes along. it's too bad but there are too many quirks.

Exactly I have the same scenario.

But how we can solve this?
There must be hopefully a solution, without trow away the devices.

Have you flashed this device to OpenWRT?
Have you multiple SSID configured?

Can you send me your config for the WiFI?

So I can compare with my settings.
Maybe this can help me.