WRT3200ACM - Multiple reboots after upgrade to OpenWrt 22.03.0-rc6


last week I upgraded my Linksys WRT3200ACM to OpenWrt 22.03.0-rc6.

Upgrade worked fine, I added WOL options, and after a while I got complains that internet was not working anymore.

When I checked, everything was working fine though at that moment, but after a while, it happened again.

When I tried to login to the console, it did not respond, but after a while it worked again.

I installed Advanced reboot, so I could switch back to the other version I had installed

I searched the forum, but couldn't find anything about this.

For now I'll stay on the current version, until the stable version of OpenWRT 22.03 is available.

It might be your packages or config. I use the WRT32X (same hardware as you) and have a 23 day uptime since flashing rc6, no stability issues. Running dhcp, firewall, adblock, samba, sqm cake, usb3 storage, etc. Completely stable. I'd say either wipe your config and try and or yea just stick with the stable build until 22.03 releases.

Here are the packages I install from SSH after a clean flash, just in case it helps:

opkg update && opkg install luci luci-ssl irqbalance luci-app-advanced-reboot luci-app-sqm luci-app-adblock luci-app-upnp luci-app-wireguard luci-app-samba4 kmod-usb3 kmod-ata-marvell-sata kmod-usb-storage kmod-usb-storage-uas block-mount usbutils mount-utils luci-app-hd-idle kmod-fs-exfat iperf3 nano

1 Like

I have run my wrt3200acm as a project work router network inside my operational network since before rc1 without problems.

Not specifically installed the rc6 but I have buildt from source around that time.

But not a single one of the 22.03 builds I have done has been so unstable that it reboots on that device. So I doubt the problem is directly connected with the 22.03 installed in wrt3200acm.

I would start by remake the configs from scratch to se if it helps (like you should always do when upgrading major releases).


Well, I tried again today, and performed a clean installation.

After an hour or so, my internet connection was disconnected, I trdid pinging the router, but no reponse.

After a minute or 2, the router started responding.
I looked for a debug log/crash dump in /sys/kernel/debug , but could not find one.

What I did notice that he time it took before my router responded again, was much longer that it would take for a normal reboot.

Very strange, since I do not have a very complex setup, and I do not have these reboot issues with the previous version.

Same problem with ZyXEL NBG6817 and 22.03 final. Did you solve the issue? Snapshot release seems having problems with pppoe restart so I will go back to 21.03.

I created a new topic about this for the Final release.