WRT3200ACM: Intermittent 'No route to host' to wifi hosts

Environment:
New WRT3200ACM router
LEDE Reboot 17.01.4 r3560-79f57e422d
Kernel 4.4.92

I installed this router a few weeks ago and I have had an intermittent issue trying to reach hosts on wifi. I have a few different wifi hosts that are serving different applications on my hone network. Most are web based, but there's a couple of custom apps and a database server. But since I moved from my old router, I have intermittent connectivity issues connecting to applications served from my wifi hosts. My wired hosts are always fine.

Strangely, this isn't the wifi network being dropped, as if I go to those hosts directly I can use them to connect to network. Note, I haven't tested them all since several are headless, but the ones I have tried maintain connectivity and LUCI says they're still connected to wifi.

So this appears to be some kind of routing issue in the router, when trying to locate a host. From linux clients to linux servers, I get 'No route to host' errors (Windows errors are more generic, an error occurred).

It seems that the connection gets established in about 20 minutes if I make a few different requests. In fact, I have been using a dumb shell line just to hit it until it comes back onto the network. But this doesn't work great.

' while (true); do wget my_host; sleep 60; done

I do have a couple of dd-wrt routers set up as repeaters in my network, but in trying to solve this issue I have killed them and am just using the WRT3200ACM router and still trying to work this issue out. I'll add them back when I can get this resolved.

cat /etc/config/network

cat /etc/config/wireless

Make sure to obscure the "option key" value(s) in the wireless config results before posting.

$cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr 'xxxx'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option peerdns '0'
        option dns 'xxxx'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'none'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

config interface 'guest'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr 'xxxx'
        option netmask '255.255.255.0'

.

$cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'US'
        option channel '36'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'xxxx'
        option network 'lan'
        option encryption 'psk2+ccmp'
        option key 'xxxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'US'
        option channel '9'
        option distance '20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'xxxx'
        option network 'lan'
        option encryption 'psk2+ccmp'
        option key 'xxxx'

config wifi-device 'radio2'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option country 'US'
        option channel '149'
        option htmode 'HT40'
        option txpower '19'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option mode 'ap'
        option network 'lan'
        option encryption 'psk2+ccmp'
        option key 'xxxx'
        option ssid 'xxxx'
        option wds '1'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'xxxx'
        option network 'guest'
        option encryption 'psk2+ccmp'
        option key 'xxxx'

My two cents:

What you are reporting is quite similar to what others have been commenting before.

Do you have a reference for where others are commenting on similar behavior? I spent two weeks on and off searching for anything similar, before registering to ask this question. I think part of my issue is I can't think of what this would be so it's hard to search for an unknown.

Wording could be contrued as issue 243, the updated firmware BLOB supposedly addresses, so worth trying the above link.

Yes, of course! There are several issues (some of them closed) reported on the second link I posted above.