WRT3200ACM: Impossible to connect to radio0

Hi!

I have an issue with my Linksys WRT3200ACM (OpenWrt 21.02.1 r16325) : The radio0 never seem to be truly up, none of my device can connect to it. Here is a screenshot of LuCi :

Now, I was looking around a bit and I noticed that there was a lot of issue related to this model "third radio":

Has I understand, radio2 is used has a radar for DFS and should be kept disabled. But In my case, I have no issue with user connecting to radio2, but not on radio0. Radio2 is only capable of a channel width of 80MHz and Radio0 is capable of 160MHz, so I don't know if that matter.

Could it be possible that in my case radio0 is the "dummy" radio and should be kept disabled ?

Here is the result of uci show wireless :

root@OpenWrt:~# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11a'
wireless.radio0.path='soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
wireless.radio0.country='FR'
wireless.radio0.cell_density='0'
wireless.radio0.channel='auto'
wireless.radio0.htmode='VHT160'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.mode='ap'
wireless.default_radio0.macaddr='e8:9f:80:1b:5e:a2'
wireless.default_radio0.encryption='psk2'
wireless.default_radio0.key='************'
wireless.default_radio0.network='lan'
wireless.default_radio0.ssid='************'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.hwmode='11g'
wireless.radio1.path='soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
wireless.radio1.country='FR'
wireless.radio1.cell_density='0'
wireless.radio1.channel='auto'
wireless.radio1.htmode='HT40'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.mode='ap'
wireless.default_radio1.macaddr='e8:9f:80:1b:5e:a1'
wireless.default_radio1.ssid='************'
wireless.default_radio1.encryption='psk2'
wireless.default_radio1.key='************'
wireless.default_radio1.network='lan'
wireless.radio2=wifi-device
wireless.radio2.type='mac80211'
wireless.radio2.hwmode='11a'
wireless.radio2.path='platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
wireless.radio2.cell_density='0'
wireless.radio2.channel='auto'
wireless.radio2.htmode='VHT80'
wireless.default_radio2=wifi-iface
wireless.default_radio2.device='radio2'
wireless.default_radio2.mode='ap'
wireless.default_radio2.ssid='************'
wireless.default_radio2.encryption='psk2'
wireless.default_radio2.key='************'
wireless.default_radio2.network='lan'

No, the main radios are the 88W8964 based ones connection to PCI, and the third weak radio is based on 88W8887 (and should not be used)

You should probably

  • disable the third radio,
  • set radio0 settings to small/vanilla settings: channel 36, HT40 or VHT80, but not the DFS-requiring VHT160.
2 Likes

I did that and know it is working fine. I guess it was because I put the VHT160 for radio0.
OpenWRT doesn't yet support DFS on this chip right ?

Thank you :slight_smile:

5.000 GHz is not a valid channel. Set a definite channel, the "auto" mode may not be supported.

And 160 MHz operation in France always requires part or all of the signal to be in a DFS band, so that's not going to work.

3 Likes