WRT3200ACM Failed migration to 21.2.0 => SOLVED

WT3200ACM user here, tried the latest version today but had to back out as I had no internet connectivity at all.
I flashed the sysupgrade.bin file through Luci, and accepted not to keep settings (although it did seem to keep custom IP address).


the connection attempt failed error was consistent although the PPPoE pass to the modem was correct. Maybe I just don't understand DSA? I tried various options in terms if assigning the WAN interface but with no success.

Is there something fundamental I'm missing here? I would have extracted the network config but got an access denied message when I went through SSH...

Choose "wan" for the wan physical device. In DSA this is the path to the wan port on the back. Anything of the syntax 'ethX' is obsolete. The separation of the switch and the eth CPU port is abstracted from the user in DSA.

It might be best to reset to defaults and configure from scratch. All you should need to do to get the wan connected is change the protocol to pppoe and enter your username and password.

1 Like

thanks for quick reply - i'll give a go in a few days and report back
just one thing, do you mean, from the options presented
switch port wan
ethernet switch eth0 (wan)
alias interface (wan)

I guess the first - is that right?

Yes switch port wan. Which will just be 'wan' in the CLI config files.

this was my mistake. When I flashed the sysupgrade, I failed to notice that the checkbox to keep existing setting was checked and I did not uncheck it. That means that the new FW was all confused.
Reflashing and unchecking meant it flashed perfectly.
Note to devs - can you reproduce the fact that that the keep settings checkbox is checked by default? I think on such a major upgrade it should be unchecked by default

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.