WRT3200acm does not accept any firmwares but factory original

Dear Forum

I just got this equipment last week, immediately I've tried various firmwares like 18.06.2, Davidc502 and DD- WRT latest. But non of them worked, system just won't bootup, not Pingable, no SSH, no Telnet. The official factory firmware works fine on the unit.

I knew there was any issue with Winbond chip W29N02GV before, but I thought the new firmwares should have overcomed the issue. Can anyone please help ?

When you run the official Linksys OEM firmware, what does the kernel and system log say about the memory chip???

1 Like

Thanks for the reply. the OEM firmware generates logs only Incoming log , Outgoing log , Security log , and the DHCP client log .


cannot see any info about the memorychip

SSH and Telnet were not accepted.

The change to the winbond chip was quite a while back so don't think that is the issue, maybe a new one, is this a new unit with recent DoM. Access is by ssh, do you have a tty serial to see what is transpiring on a flash / boot.

Thanks. I just bought this unit from Amazon last week, I opened up the case I can see 1702, 1708, etc. I presssume it was made 17 Feb or August. Now it is runnning on last OEM firware without any issue. Before I get a TTY cable, I jsut want to make sure it is not the hardware malfunctioning issue. May it be something wrong with the memerory chip ?

Yes, I understand your concern re tty. Given your initial description, my assumption would be that you are still running OEM from the partition in play when you received the device; i.e. you used the power switch to get off of the non-functioning flash. If this is the case maybe try flashing an OEM image to see if that takes on the other partition.

Removed Removed

I really don't think that is relevant or good advice.
That turns the wrt32x into a wrt3200acm and would allow it to be flashed with that firmware. While this may have been required early on, the device is now fully supported and this just confuses the entire situation.

1 Like

Thanks,that is a good advice. I will definitely try this.

Thanks Dude, do you happend to know why it cannot be flashed as long as the OEM firmware exists ? Is you unit also new?

Things are just becoming more interesting. Indeed, I can flash it to another partition with OEM previous vesion and vice versa. However, it just cannot flash into any other third party firmwares. Can I be rest assured that at lease there is nothing wrong with the memory chip. Is there a swtitch that only allows you to use OEMs ???

What device you exactly do have?
Are you sure that it is wrt3200acm and not wrt32x ?
Any more of info on the device label?

The OEM firmware had some admin diagnostic logs, if I remember right (not those traffic logs that you listed).
Please look carefully through the menus if you can find info about the device.

The long advice from mooman above is related to forcing a wrt3200acm firmware into a wrt32x, which is practically a new rebranding of the same device. But that should not be needed normally.

1 Like

...and which is a high risk procedure you should avoid if possible.

If ssh/ telnet is available, you can gather logs (dmesg) that way.

I just tested with my own WRT3200ACM by flashing the OEM firmware into it and made some observations in the OEM firmware:

  • You are right, there are no usable logs in the OEM firmware. User is pretty much locked out of the useful info, and ssh and telnet are disabled.
  • Flashing Openwrt works ok, but there seems to be is a hidden requirement about internet connection:
    • If there is no internet WAN connection (or maybe, if there has not been internet WAN connection since the boot) and the router is flashing the orange internet/WAN LED, the flash fails. The GUI accepts the firmware filename, but the "start" button does not do anything.
      (Also possible that the router needs to have "called home to Linksys" via internet at least once, or something like that. Not sure about the exact requirement.)
    • If the internet/WAN led is steady white, the start button opens a dialog and the flashing will go ok.

In any case, I managed to flash my own OpenWrt 19.07 build into it ok. As flashing 19.07 works ok, also 18.06 and master should work ok, although I did not test that.

That's a weird requirement... I'd love to confirm that and add it to the wiki.

They both the same...just housing is difrent!

That methodology was required to get the rango FW onto the venom before lantis1008 got the FW working directly for the venom; or, it is no longer required. To my knowledge all current wrtpac devices should be able to be flashed directly from OEM to OpenWrt by way of the factory image.

Guys,I just spent half hour with Linksys technician online. They finally think this unit is proven defective and has been approved for a product replacement...

I have to say that this is the most frustrated router I've ever had...such a pain

There are subtle differences like flash layout, image format, the way the Wi-Fi power tables are loaded and a few others. Otherwise we would just use the same image.

In code, where it comes to TFTP .img, I wrote: USE .img for your Modell! Anyway. Thanks, my Code worked for me, but dont want argue more about it, removed my post, Thanks!