WRT3200ACM "Bad Request" after first install

Hi all,
I've finally got my new router, a WRT3200ACM and the first thing I've done it's been installing Open WRT following its Wiki https://openwrt.org/toh/linksys/linksys_wrt3200acm:

  • Login to Linksys WebUI (Default IP:; Password: admin)
  • ConnectivityManual Update
  • Select factory image [.img] 1. Once flash completes, router will reboot

The next step should be "Login to WebUI" but even though I can see the LuCI login form, when I try to set a password I always get "Bad Request".

This is the filename of the image I tried to upload:

What I've done wrong?

Now I've restored the previous partition by turning on/off three times and I am again in the OEM frontend.

Do you get any Error Code with "Bad Request"?

Is it the same issue as here: https://github.com/openwrt/luci/issues/4295 ?

No, this time the issue was of the PEBKEC type.
I tried to set a password at the first login (following a "standard" common to most devices) instead of a blank one.

I thought that it could be an issue related to a wrong password but I was expecting a http 401 error, not a "Bad Request".

Anyway, with a blank password, all is working now!
It begins my very first experience with OpenWRT.

thats should be the issue with the login cookie.
It was actually discussed in the forum a few weeks ago, also for the WRT3200
edit: found it: Can't log in after factory install: "No password set!"
found yet another related thread: [WAC104] Unable to login through LuCI w/ OpenWrt 21.02.0-rc4

the previous vendor firmware in this case is a modified OpenWRT image, which uses the same cookie name as a login session as a pure OpenWRT image.
When you flash OpenWRT from the vendor image, there is no formal logout, therefore the now stale session cookie stays in the browser (for a firmware that now no longer exists).
You most likely have not closed and reopened the browser, when you then have experienced the bug. But most likely have closed and reopened the browser, when you were later on able to login flawlessly with blank password into OpenWRT.

I have never verified it: but closing browser, reopen it after flashing factory image from vendor firmware should effectively avoid the issue.

1 Like

Really possible.
To avoid any cache/cookie/serviceWorkers issue I eventually used a dedicated browser tab (using Firefox + Multi-Account Containers extension) so it was like a new browser.
I couldn't close the browser since I had some job opened.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.