WRT3200ACM 21.02 and WiFi hanging LuCI (WPA2/WPA3 mixed)

Hello All,
I am experiencing a strange issue.
Just migrated to 21.02 (fresh installation and setting everything from zero) on WRT3200ACM.
All working well until I turn on the Wifi.

Once the Wifi is turned on, clients connecting, all working, but after a while, I cannot log in to the router over the web. Luci is loading only the login page, then nothing else after that. Sometimes reporting corrupted "main" (?) or reporting XML Time Out.

I can still log in over SSH.
Turning off WiFi Radio doesn't help.

I have been working for a full day without Wifi enable on the router (used separate Wifi device - also OpenWrt 21.02 connected by LAN cable to WRT3200) and no issue was observed. Once I turned on WiFi on the router all starts crashing LuCI.

Logs don't report any issues, hence hard for me to see what's going on.

luci-reload also not helping.

It doesn't seam that there is corrupted memory, as the router is working perfectly with Wifi turned off (and worked on 19.x firmware without issue). The only difference in wifi settings between 19.x and 21.02 is that Wifi using WPA2/WPA3 (strong) instead WPA/WPA2 AES.

Funny is, that on other device, less powerfull I don't have issues.

On post here it is mentioned following:

Update : This seems to be fixed by simply disabling 802.11w support.
Network->Wireless->Edit->Wireless Security->802.11w Management Frame Protection = Disabled
It used to be disabled by default in older versions of OpenWRT.

But I keep set this as disabled, but it still falling back into Optional.

802.11w is required for WPA3. The wifi config scripts force it on when you have WPA3 or WPA2/WPA3 mixed...

...even if you try to disable it in config.


So, it needs to be at least "optional" in WPA2/WPA3 mixed.
And that breaks WRT3200ACM pretty quickly.

There are several bug reports in the driver home page, but as the mwlwifi driver is abandonware, there is no hope to get any fixes into the closed-source "firmware" blob part of the driver.


Thanks, that’s explain lot.
Will stick with WPA2 only.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.