Wrt3200 wireless problem

Hi

I've just bought the wrt3200 and build a custom build from 2203 snapshot and I got radio 0 device is not active - wireless is not associated but everything is well configured, do you have an idea what is the problem?
Thanks

Edit : only radio 1 works : 2.4

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd73:0f40:0845::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '62xx.xxx.xx:e8'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        option metric '5'
        option type 'bridge'
        list dns '1.1.1.1'

config device
        option type 'bridge'
        option name 'br-guest'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config interface 'wg0'
        option proto 'wireguard'
        option force_link '1'
        list addresses 'xxxxxxx/16'
        option metric '10'
        option private_key 'CEl5gnhFs='
        option mtu '1400'

config wireguard_wg
        option public_key 'uLLxxxxxxxxxxxxxxxxxxEQ='
        list allowed_ips '0.0.0.0/0'
        option route_allowed_ips '1'
        option endpoint_host '1xxxxxxxxx'
        option endpoint_port '1443'
        option persistent_keepalive '25'

config wireguard_wg0
        list allowed_ips '0.0.0.0/0'
        option route_allowed_ips '1'
        option endpoint_port '51820'
        option persistent_keepalive '25'
        option description 'montreal'
        option public_key 'pB//7qgQ/TQxxxxxxxxxxxxxxxxxX8='
        option endpoint_host 'xxxxxx155'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option country 'CA'
        option cell_density '0'
        option channel '157'
        option txpower '23'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option macaddr '60:'
        option ssid '5_5'
        option encryption 'psk2'
        option key 'Y#'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option band '2g'
        option country 'CA'
        option txpower '30'
        option disabled '0'
        option htmode 'HT40'
        option channel '9'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option macaddr '60:'
        option encryption 'psk2'
        option key 'Y'
        option ssid 'N'
        option network 'lan'

config wifi-iface 'guest'
        option device 'radio0'
        option mode 'ap'
        option ssid 'xx'
        option encryption 'psk2'
        option key 'N'
        option network 'guest'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option channel '34'
        option band '5g'
        option htmode 'VHT80'


root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'
        option doh_backup_noresolv '-1'
        option noresolv '1'
        list doh_backup_server ''
        list doh_backup_server '127.0.0.1#5053'
        list doh_backup_server '127.0.0.1#5054'
        list server '127.0.0.1#5053'
        list server '127.0.0.1#5054'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '12h'

config host
        option ip '192.168.1.182'
        option mac '14::1F'
        option name 'chromecast'
        option dns '1'

1 Like

The problem seems to be about the guest WiFi, if I remove it, the radio0 works

I can't help with your radio problem, sorry!

But I did want to chime in and make sure that you're aware that there's a serious bug in linux kernel 5.10 (used in openwrt 22.03) which makes your WRT-3200 router's switch behave like a hub, copying any internal LAN traffic onto the WAN port and bypassing openwrt's firewall/routing.

I've switched to using the Divested-WRT build which uses linux kernel 5.15, on my personal WRT-1900AC until this problem gets fixed (sometime later this year) in this openwrt 23.xx.

If you really want to make your own builds, you may be better-off using the current mainline as a starting point rather than 22.03.

1 Like