WRT1900acv2 LEDE (both and davidc502 won't connect WAN PORT)

Have been running chaos calmer fine for years. There is nothing wrong with my cable modem, etc so don't ask ---- and everytime I switch back to chaos calmer I am fine.

On LEDE -- wifi is fine, no access to WAN port whatsover. Have rebooted cable modem and detached, reatteached router WAN port a zillion times. no bytes in, period (this no DHCP response). Yes, this needs to be DHCP on the WAN port

switch back to chaos calmer and I am fine every time. Switch to lede (tried std and davidc502 build) -- no wan port, period. Thoughts? (Here's one of the broke ones -- this is davidc502)

BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 Lede SNAPSHOT, r7210-14cb05909a
  • Are you resting to defaults, or saving your configs when upgrading???
  • What version of LEDE are you flashing to?

Anything interesting shown by

swconfig dev switch0  show

I assume you are not keeping config

1 Like

I was keeping config. Bad idea? I had tried both lede 17.01.4, AND the davidc502 build which is shown in the login logo above.

root@Muttadoodle:~# swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
Port 0:
	mask: 0x0000: (0)
	qmode: 3
	pvid: 1
	link: port:0 link:down
Port 1:
	mask: 0x0000: (1)
	qmode: 3
	pvid: 1
	link: port:1 link:down
Port 2:
	mask: 0x0000: (2)
	qmode: 3
	pvid: 1
	link: port:2 link:down
Port 3:
	mask: 0x0000: (3)
	qmode: 3
	pvid: 1
	link: port:3 link:down
Port 4:
	mask: 0x0000: (4)
	qmode: 0
	pvid: 0
	link: port:4 link:up speed:1000baseT full-duplex
Port 5:
	mask: 0x0000: (5)
	qmode: 3
	pvid: 0
	link: port:5 link:up speed:1000baseT full-duplex
Port 6:
	mask: 0x0000: (6)
	qmode: 0
	pvid: 0
	link: port:6 link:up speed:1000baseT full-duplex
	port_based: 0
	vid: 1
	ports: 0 1 2 3 5t

It doesnt appear that VLAN2 (WAN) is assigned to a port.

Yes, the ports / vlans were reworked from CC, and your switch config appear wrong.


Yeah, I noticed on choas calmer, enable_vlan isn't even enabled, which, given that it
works, is probably the way I want it on LEDE too. (I see no need for the tagging of any sort)

Thanks, I think I will be all set once I either figure out the network setting on LEDE, or just
start fresh on LEDE config (which I didn't feel like doing)

I appreciate the quick help, this seems like a great formum

You should.
15.05 is so ancient that at least system, network and partially also firewall config defaults (or hardware-related settings) have changed, mostly between 15.05 and 17.01 but also later...

Let the firmware to create at least /etc/config/network and /etc/config/system from scratch.

OK thanks --- yes it was really firewall I mostly needed to save, but I can always copy those
out and back in.

Will let you know how it goes when I get back to work on it tonight ----