WRT1900ACSV2 no internet connection

Hello, new here and need some help.

I have a wrt1900acs set up from stock, fully working. I downloaded the right image of openwrt (lede-mvebu-cortexa9-linksys-wrt1900acs-squashfs-factory) and it flashed without problems. But from the start I have no internet connection and have a hard time finding some step by step guides to help me as I'm sort of a router noop...

I have a PPPoe account and i put the details in but no luck. The router just did not connect to the net.

On stock firmware I had to enable vlan and setup the wan but I cant find out hoe to do that properly on openwrt.

Anybody willing to help a noop out... :slight_smile:

Have the same router in Interfaces did you choose the second one down Wan and swap Protocol i use PPPoE for my ADSL

Yes I did, and put in the user and password. Have actually tried this a number of times.

Not sure what to do next...

for us to solve this we need to understand:

  • how should your internet connection look like? we need all relevant details like:

    • VLAN details
    • provider used
    • mac address needs cloning?
    • ipv4 /ipv6
    • etc, etc, etc,
  • how does the current setup look like

    • please provide screenshots of all relevant details like the wan setup pages
    • and the switch vlan page

Only then we can understand the gap and how to fix that :slight_smile:

Thank you for your answer johnnysl.

I think my problem has something to do with Wan and Vlan settings. Here is my setup in my orginal Linksys firmware.


I just cant figure out how to apply these settings in OpenWrt

Questions regarding DD-wrt should be adressed to the DD-wrt forum, not the OpenWrt forum.

Sorry I actually meant OpenWrt, I think it's time for coffie :slight_smile:

1 Like

You would change WAN to VLAN 4; and change the WAN port from UNTAGGED to TAGGED.

I've managed to get DHCP internet connection after I made the changes to the Vlan but still I cant connect with a PPPoe account.

I get an error message auth_failedtopeer (or something similar) but I have checked and all my details are correct so I'm a little lost. Everything works when I use the DHCP protocol.

Any ideas?

I installed mine using this youtube video as a guide (mine was new out of the box) and it worked just fine. I know it's a version old, but is it any help?