WRT1900ACS Partitions - both marked "Alternate" Can't switch

WRT1900ACS is sitting on Partition 02 per Kernel version in Status/Overview (5.10.42). When I attempt Advanced Reboot to go to the other partition LuCI tells me both are Alternate and returns error as below. All Flashing attempt to appear to run through the process, but always returns to current partition.

Still looking and tried:
:~# /usr/sbin/fw_printenv And it Returns:
Cannot parse config file '/etc/fw_env.config': No such file or directory


#hacked from /lib/upgrade/linksys.sh

cur_boot_part=`/usr/sbin/fw_printenv -n boot_part`
if [ "$cur_boot_part" = "1" ]
    fw_setenv boot_part 2
    fw_setenv bootcmd "run altnandboot"
elif [ "$cur_boot_part" = "2" ]
    fw_setenv boot_part 1
    fw_setenv bootcmd "run nandboot"
# re-enable recovery so we get back if the new firmware is broken
fw_setenv auto_recovery yes
echo "$target_firmware"

I have no idea what caused this problem. Pwr ON/OFF X3 brings me back to my older build on Partition 1 which all appears normal in LuCI Advanced Reboot.

Re-flashed the same build from yesterday and ended up with the same issue on reboot. Oddly everything works just fine on the new build other than Advanced Reboot. So, back to Partition 1.

Fired up a new build using same .config - Just clean/pull/update/install/make. Everything says it is already up to date - so no changes. Re-applied the newest build again and find myself back to the original problem on the newer build. Scrolling through history, I noticed a warning at end of the build:

WARNING: Applying padding in /home/openwrt/bin/packages/arm_cortex-a9_vfpv3-d16/luci/Packages to workaround usign SHA-512 bug!.
I scrolled back in history to the original problem build and see the same message on my build from yesterday.

To make a long story short, I waited for something to update on Snapshot and rebuilt again. This time all is well. No WARNING, no .config changes!!!!

Can't say I solved this, but at least all has ended will.

Thanks! I remembered the term nandboot somehow from the back of my mind last night from that thread, but I figured the power switch might be a safer bet figuring I had somehow messed up the partitions.

I haven't changed my .config over 5-6 builds now - just update Snapshot on a regular basis to keep current. The only change yesterday was a feeds update to a forked theme repo I use in my build that still works just fine. At this point, I can only point the finger at "GREMLINS IN THE MACHINE".

I went looking for the cause of the WARNING message that cropped up on a couple of my builds that elicted my post on this topic.

I came up with this OLD Forum topic:

that then led me to this Commit:

Now, based on the commit, it makes no real sense this caused my issue. It's just padding to make it work, but looking a bit more, the warning references the /luci/Packages and concerns only the LuCI feed. Add to that my build begins to work ONLY after I take a LuCI feed update??? I'm really curious. Anyone.