WRT1900ACS No Wan IP - Help needed!

Router : LinkSys WRT1900ACS, Firmware 18.06.4

I cannot get a WAN IP with OpenWRT. It works fine with LinkSys stock firmware. I can also get WAN IP with a different router like USG. Issue is only with OpenWRT firmeare. I have done the basic trouble shooting ( turn off the modem, router, different versions of firmware etc ).

Issue is seen with David's build also. ( I see the same issue in DD-WRT also ). I have used the OpenWRT with the same router a while ( 1 to 2 year ) ago ( Don't remember the version ). It was working fine at that time.

Mac address of the router remains the same between Stock and OpenWRT firmware. Stock firmware always works fine.

Note: I have disabled wifi in the LinkSys ( Issue is seen with Wifi enabled also). Using Unifi AP as access points. Currently using USG instead of LinkSys.

Any help is appreciated.

Have you enabled the broadcast flag for DHCP?


Yeah. I have tried with that also. My internet provider is comcast.

And can you confirm there's no Vendor Class or Client ID accidentally entered (or filled out by auto forms)?

I am pretty sure these fields were empty. I will cross check again.

1 Like

Client ID, Vendor Class ID etc all are empty.. Just checked. Any thing else that I should check?

fwiw, have you seen this other recent post from a new WRT1900ACS v2 owner with SB6183 modem?

I just went through that. I don't see any issues with cable modem. It works with stock firmware of the same LinkSys router and also with a different router like USG. Issue happens only when I install OpenWrt ( or DD-WRT. I tried both ). The default settings ( and suggested settings) fails to get the Wan IP.

If you were to connect your WRT1900ACS (openwrt) to LAN port of another router, I presume it works?

I wonder what would happen if you tried an older release such as 18.06.2?

If you were to connect your WRT1900ACS (openwrt) to LAN port of another router, I presume it works?

I didn't try this. Not sure how this helps. As mentioned earlier stock firmware works fine.

I wonder what would happen if you tried an older release such as 18.06.2?

I will try this.

Connecting WRT1900ACS to LAN port of another router is just to demonstrate the WAN port is working with OpenWrt, but there is clearly some issue when used a cable modem & ISP.

Is there any message on the logs when you plug-in the WAN cable?

1 Like

Will check this over the week end.

I agree that a good test is to ensure that the WAN port (physically and logically) is working properly by connecting another router's LAN > WRT1900ACS WAN. Make sure they have different LAN address spaces (when traversing across NAT or really any routing layer, it is mandatory to have different subnets on each side).

Also, make sure you're running a completely default configuration (aside from possibly the LAN address space) -- you can reset to defaults within LuCI or use the firstboot command when you ssh into the device.

If the WAN works properly in the above configuration, it should be possible to get it to work on the cable modem. Keeping in mind that you may need to power-cycle the modem several times (and sometimes even call the cable ISP to ask them to release any associated MAC address bindings), I also just learned about the fact that sometimes it will work if you just wait a while because of the DHCP request timing. Check out this post over on the UI forums, and importantly it links to this other thread that actually has a dump of the DHCP requests with timestamps.

I have had similar issues getting a WAN IP from my cable modem -- I've always gotten it to work in the end, but next time, I'll just set a timer and wait. If that works, it will save me a lot of time and frustration knowing that I just need to be patient.

1 Like

I had finally spent some more time on this. I tried the following.

  1. I used older versions of openWrt ( 18.06.02 , 18.06). Same issue is seen. Also tried with 19.07 rc1
  2. I tried connecting my laptop directly to the cable modem via ethernet cable. It works fine.
  3. I tried with stock firmware on the same router (which is connected to same cable modem ). It always work.
  4. I checked the logs which is attached
  5. Tried with old cisco router with stock firmware. It works.

I ran out of ideas. Any help is appreciated.

Edit: I see a similar issue reported here with no clear solution. OpenWrt on WRT1900ACS -- can't get WAN-side IP address assigned