WRT1900ACS is Lede the way to go?

#3

I am using WRT1200AC.

  1. Assuming you are using OpenWrt 15.05, you can update to LEDE on luci web interface.

  2. You should not use IP address with HTTPS. Because the server certificate will always be invalid. You can override DNS lookup results with dnsmasq. You can redirect HTTP traffic to a specific host with iptables.

0 Likes

#4

@Borromini thanks for your guidance on the flashing of OpenWRT to LEDE

is this what you mean

cd /tmp
curl -LO https://downloads.lede-project.org/releases/17.01.0-rc1/targets/mvebu/generic/lede-17.01.0-rc1-r3042-ec095b5-mvebu-linksys-wrt1900acs-squashfs-factory.img
sysupgrade -n lede-17.01.0-rc1-r3042-ec095b5-mvebu-linksys-wrt1900acs-squashfs-factory.img

I am not sure if curl is installed on OpenWRT wget cannot download from https due to certificate issues.

0 Likes

#5

@jimzhong thanks for the suggestions. I am green to this, just a weekend with the WRT1900ACS :wink: so how would I redirect the WLAN clients when visiting https://example.com to 192.168.1.202 please - what commands shall I issue.

On OpenWRT I tried these but it did not work

uci add dhcp domain
uci set dhcp.@domain[-1]=domain
uci set dhcp.@domain[-1].name=example.com
uci set dhcp.@domain[-1].ip=192.168.1.202
uci commit dhcp
/etc/init.d/dnsmasq restart

and

uci add_list dhcp.dnsmasq.server=/example.com/192.168.1.202
0 Likes

#6

wget can download without certificates if you use the "--no-check-certificate" option, or you can install the ca-certificates package (using opkg) to get the certificates.

And I think that you should use the "sysupgrade.bin" image, not the "factory.img" image that is only used when you flash from the original OEM firmware.

0 Likes

#7

@hnyman thanks for the suggestions on the wget/curl issue.

As to the factory.img, the firmware is the file suggested by the download page of LEDE project https://lede-project.org/toh/views/toh_fwdownload?dataflt[Model*~]=WRT1900ACS.

Is this ok?

What's boggling me about this firmware is the following LEDE unsupported -> v2 needs newer wifi driver!!

0 Likes

#8

[quote="fab, post:7, topic:1404"]
As to the factory.img, the firmware is the file suggested by the download page of LEDE project https://lede-project.org/toh/views/toh_fwdownload?dataflt[Model*~]=WRT1900ACS.

Is this ok?
[/quote]No. The page gives two links.

  • factory = install from Netgear firmware.
  • sysupgrade = upgrade from existing LEDE / Openwrt

https://lede-project.org/faq/before_installation#what_is_the_difference_between_the_different_image_formats

0 Likes

#9

@hnyman thanks for that, as I had a lot of issues with the OpenWRT install, would you recommend to flash the device clean with the LEDE factory image rather than using the LEDE sysupgrade?

What about the v2 needs newer wifi driver notice,

0 Likes

#10

Just add this line to the config dnsmasq section in /etc/config/dhcp

list address '/example.com/192.168.1.202'

And then type /etc/init.d/dnsmasq reload

1 Like

#11

Managed to flash LEDE with the following in OpenWRT maybe it will be useful to someone new like me:

opkg update
opkg install curl
cd /tmp
curl -LO http://downloads.lede-project.org/releases/17.01.0-rc1/targets/mvebu/generic/lede-17.01.0-rc1-r3042-ec095b5-mvebu-linksys-wrt1900acs-squashfs-factory.img
sysupgrade -n lede-17.01.0-rc1-r3042-ec095b5-mvebu-linksys-wrt1900acs-squashfs-factory.img

NOTE: I have used the http://downloads..... instead of the https://downloads... as OpenWRT had issues with wget --no-check-certificate . I also tried to install ustream-ssl but package was not available.

The flash went smooth without any errors and have the WRT1900ACS v2 boot LEDE in a snap.

Will continue with the set-up and WiFI signal tweaks.

0 Likes

#12

I am also curious about the notice stating "v2 needs newer wifi driver". Is there any more info on the impact using the existing wifi driver, and what may need to be done to update? Thank you!

0 Likes

#13

I beleive that LEDE 17.01 has the newest driver in it, I think that
documentation is old.

David Lang
kk

0 Likes

#14

Thank you!

0 Likes

#15

@trross33 and @dlang to be correct version 17.01.0-rc2 has the latest mwlwifi driver as per thread here WRT1900ACS v2 how to update mwlwifi driver

The radio is totally stable compared to rc1 but there is still an issue with the power table (a Linksys issue and not firmware) and signals are somewhat week. I have tested extensively and reported such to Linksys upon guidance received during this thread https://github.com/kaloz/mwlwifi/issues/139

Linksys reply was dismissive with crap of warranty voidance, when their sales pitch is OpenWRT, LEDE and now DD-WRT. Ironically they do press releases on such synergies too.

I have also used MetaGeek's Wi-Spy + Chanalyzer and can only deduce that the issue is the antennas but somehow the beam forming technology compensates a bit.

So go for the 17.01.0-rc2

I still have some issues though for example the channel on 5g band

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00$
        option htmode 'VHT80'
        option channel '104'
        option country 'MT'

The channel is set to 104 but the router is using channel 36 instead.... have a look at the screenshot hereunder and see the Lumen WiFi 5g channel yourself. I reboot the system many times, but I can not get the channel to 104.

0 Likes

#16

Unfortunately, that has been like that from the get-go - Linksys marketeers touting 'OpenWrt support' while they had not contacted a single OpenWrt developer (go figure).

As for the version you recommend, have there been any regressions between RC2 and stable? If not, I'd recommend to use stable. Devs won't be taking bug reports against 17.01 RC's, they want you to use up to date release (or trunk, if you're running trunk :smiley: ).

0 Likes

#17

@Borromini I have found LEDE 17.01.0-rc2 to be the best option for the WRT1900ACS v2. I have extensively tested all LEDE builds, OpenWRT and DD-WRT. With LEDE stable, I could not connect to the radios.

0 Likes

#18

OK... Did you file a bug? That would help the devs look into it. The Linksys AC devices are pretty popular, so... A far as I can see though, between RC 2 and final, there were no changes to the mwlwifi driver.

0 Likes

#19

@Borromini I recommended rc2 as I was not aware that this got superseded with the latest stable version LEDE Reboot 17.01.0 r3205-59508e3 which is basically rc2 :wink: I have updated to the stable version by flushing the factory image in and now the 5g channel shows channel 104 as it should. WiFi signal is still weak though. Screenshot attached, the problem is not a bug but an issue with the power table.

0 Likes

#20

@Fab I see. I asked because the way you wrote it, people might read the thread and think RC2 might be preferred over the stable release for some reason. Glad we cleared that up :slight_smile:

0 Likes

#22

Hi

I am newbie and have recently got a hold of a WRT1900ACS V2 and was wondering if the current release 17.01.2 contains the latest wifi driver that was included in 17.01.0-rc2.

The link below still says that it needs the newer wifi driver, although it points to the new release.

https://lede-project.org/toh/views/toh_fwdownload?dataflt[Brand*~]=linksys

Any help will be appreciated.

Regards

LL

0 Likes

#23

For latest mwlwifi with stable.

0 Likes