WRT1900ACS - Firmware corrupts itself after a short period

I have a WRT1900ACS, obviously purchased because it had official support for OpenWRT.

I'm trying to install OpenWRT, and I've tried the following two images:


After installing the first image, I was able to set an IP, configure wifi, etc. But after a while, I wandered away to do something else, came back and the device had reverted to the Linksys UI.

Wondering whether this was a flaw or corruption in the image, I tried to install the acv2 image (based on the fact that the FCC ID of the device said "ACv2", and reviews reported them as being identical hardware).

Once again, I was able to configure the device normally, got called away from my desk - and when I got back, the image had corrupted itself.

Unfortunately, I made the assumption that the device would write "whichever partition wasn't being booted from", whereas apparently "whichever one was least-recently written to" is accurate, and I now have a completely bricked WRT.

I own a TTL cable, so I'll take it home and try and get it flashed back to OEM, but I'm completely surprised that both images have exhibited the same "corruption after some time" issue. Has anyone else tried 18.06.2 on a WRT1900ACS or WRT1900ACv2, and what was their experience?

You may want to check out the following custom OpenWRT build for the WRT1900ACS: https://dc502wrt.org/ It is well maintained and updated based on the latest snapshots and WiFi drivers on an at least monthly basis.

The forum dedicated to it is one of the most active in the OpenWRT community: Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

I've been running this trouble free on my WRT3200ACM for 3 years without issue. Enjoy...

Works totally fine on my WRT1900ACSv2, my understanding is the ACSv2 is just an ACS with a locked region code or some other FCC compliance thingy.

I suspect your device has hardware problems. The only reason to walk away and come back to it rebooted into linksys factory firmware is if it rebooted, and it's only going to spontaneously reboot if it has a hardware fault.

shelby (acsv1 | acsv2) != cobra (acv2), the dts does vary some between the two.

I've got a lot of meanings for dts, and none stand out.. https://www.acronymfinder.com/Information-Technology/DTS.html

Can you clarify please? :slight_smile:

Both images installed, both images booted, both images operated normally and both images spontaneously corrupted.

I assume we're talking about device trees?

I was unlucky to get a faulty unit 1900ACS with similar problems you describe. link to thread

Got it replaced yesterday and flashed to openwrt. Haven't had a single problem with it so far.