WRT1900ACS 5Ghz Radio not showing up

tried copying and changing the paths just get a generic bgn

Ok, and.. ?

And I want a 5G wi-fi but since it isn’t detecting the 5G radio I can’t

What else did you hack?
It is likely better to let OpenWrt to generate a new default wireless config, and then edit the needed change by hand (instead of using an old config file or something like that ...)

Delete the file /etc/config/wireless, reboot, and you will have the default wireless config (but wifi disabled until you config them).

If the radio still remains silent, check the system log for wifi error messages.
(post your config here, plus the system log. )

Okay, I've already tried it, the problem is default config isn't coming with 5ghz radio only with the first one.