WRT1900ac v1 wlan <--> wan performance issue

Edit: As per reply, doesnt seem to be a wireless issue as wlan <--> is as fast as stock firmware

Hi there, this is a problem that has been reported a few times here, but as far as i can see, no answer has been reached. Simply put, compared to the latest stock firmware, wifi performance on 5GHz is less than half on all builds of lede ive tried(davids, stable, dev (all on 4.4 kernel)). I have intel 7260 and 7265 clients for testing and DOCSIS gigabit wan connection, that requires vlan tagging.

Both clients achieve a consistent 250 - 300+mbps down on speedtest.net, within 10 meters of the router and a wall in between. Both have a connection speed of around 850mbps. Also defaulting to channel 36

But under lede, both clients seem to top out at 130mbps on speedtest.net, connection speeds alot more variable, between 500 and 850. also channel 36.

higher channels worked better for the 7265, reaching 200mbps down, but the 7260 stayed about 130 while dropping the connection occasionally. Lede is still able to achieve at least 800mbps down on ethernet. The stock firmware is terrible and now its started dropping WAN connection occationally, so switching back to LEDE would be great, need 5ghz performance though.

After setting up a samba server on LAN, i was about to transfer files at 30+MB/s - So not a problem with wireless as I expected. Rather,

lan <--> wan = Same as stock firmware throughput
wlan <--> wan = half stock firmware throughput

I wonder if this could be a problem with my vlan configuration?

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix xxx

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option delegate '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4t 6'
        option vid '10'