WRT1900AC v1 - USB 3 Not Working


#1

Hi

I have recently setup a SWAP partition and SWAP file on a really old USB 2 memory stick with my self-compiled firmware for the Linksys WRT1900ACv1 router. Although I have it working on USB 2, my router has USB 3 and so it would faster to use that over USB 2. Unfortunately, I cannot get it to work despite the necessary packages been installed.

USB%20OpenWRT

This is the results from the 'lsusb -t' command

root@OpenWrt:~# lsusb -t
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=orion-ehci/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M

What am I missing?

Many thanks

Will


#2

If it's a USB 2 memory stick, why do you expect it to connect using USB 3?


#3

I actually plugged in a USB memory stick but the power indicator light on the both the USB memory stick itself and the router never lit us.


#4

Can anyone help please?


#5

This is what a USB2 flash drive plugged into a USB3 port should look like (machine is a WRT32X).

root@OpenWrt:~# lsusb -t
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
    |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=orion-ehci/1p, 480M

Bus 1 is the USB2 port (with nothing plugged in). Buses 2 and 3 are aliases for the USB3 port. Only one will be active at a time, depending on which kind of device is plugged in. Here there is a USB2 device plugged in, so it appears on bus 2 and operates at a speed of 480M.

The flash can be accessed, but there is no performance improvement vs. a USB2 port.


#6

First of all it is a bad idea to have swap on a USB stick, performance wise and wearing the stick wise.
Your router has a lot of memory. If it runs out it means something went awfully wrong there and the swap won't save you.
Other than that, what is the problem here?
Have you mounted the swap partition and it is not working?
Does it appear in dmesg?
Is it defined in fstab?


#7

I have an LED indicator light on my USB 3 memory stick which does work in the USB/eSATA port. However, plugging it into the USB 3 port doesn't light up.

The only reason I'm running a SWAP partition is to be able to run the Speedtest-cli from GitHub that uses Python as it uses a lot of RAM especially on the upload speeds if you don't utilise the '--no-pre-allocate' command.


#8

Perhaps...power?


#9

I'm seeing the same thing here on a mamba, no power on usb 3 port. I have not tried either of the usb ports since we were trying to get the front LEDs working/correct. I know that they were working back at that time (1-2 years back), perhaps the mamba dts has been altered.


#10

Do you have an unpowered USB hub between the router and the memory stick? If so the router may not have enough power on the USB port to support it. Maybe it doesn't even have enough to support a led.


#11

No hub is in place. The USB 3 stick goes straight into the port.

To rule out a hardware issue I will test the stock Linksys firmware and post back the results.


#12

My assumption would be that between this commit and now, a regression has occurred; that being the last time I tried connecting anything to the USB.


#13

By way of another data point. On my way to a new master image today, I flashed through the current 18.x stable release and the USB 3 port has power on that image. So, appears the regression is only on master, have not taken a peek at the patch directory to try and spot a likely culprit.


#14

Opened FS#2091


#15

I'm currently running 18.0.6 that I compiled myself from GitHub but I haven't flashed since November last year.

This is the version I'm running

Screenshot_2019-01-30-14-09-05