WRT1900AC V1 - Flashing correct version but no access

Hi you smart people!
Complete newb here so sorry for idiocy.

I just got a linksys WRT1900AC V1 and want to put openWRT onto it so i can have VPN on all my network (because tracking).
Anyways, i connected to the Linksys interface (192.168.1.1) updated to latest linksys firmware and proceeded to try and flash the openwrt-18.06.1-mvebu-cortexa9-linksys-wrt1900ac-squashfs-factory.img downloaded at http://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/openwrt-18.06.1-mvebu-cortexa9-linksys-wrt1900ac-squashfs-factory.img
when i try and flash it, it proceeds and seems to have worked. However, i loose all internet connection and after this i just cant connect to 192.168.1.1 and setup openWRT. I have tried downloading the image several times and flashing it again and again but i keep getting the same result.
What am i doing wrong?

  • Anders

How can you flash anything if you do not have any access to the device? I think there is something I did not understand in your post.

i have access, until i flash. After the flash i loose all connection until i reset the device again.

Do you get IP and the rest settings from DHCP after the successful flashing of the openwrt image?
Does ping or ssh work on 192.168.1.1 ?

Are you saying that upon reboot/reset - the OEM firmware is still there?

Try a different image such as snapshot (no gui so you will have to ssh). If it still does not take it sounds like HW and you will probably need a ttl-serial connection to get a handle on what is happening.

upon switching to the 2nd firmware yes. Not just a standard "hold reset for 10 sec". But the Linksys WRT1900AC have 2 firmwares that you can switch between.

1 Like

nope, ping does not work at all after flashing. Neither does SSH.

From what I read in the instructions the migration to Openwrt is quite trivial.
Have you verified the integrity of the image you downloaded with sha256sum application?

1 Like

just used sha256sum. The value is identical so that is also not the issue.
Yes, the install should be super simple. Upload image, hit enter, wait for it to reboot and ur off to the races. But unfortunatly, after i let it reboot i just get nothing until i switch back to the "good" firmware that is the stock one

I downloaded an older image now, that flashed fine. Just upgraded to 18.06.1 and that went flawlessly aswell! :slight_smile:

2 Likes

Please make a bug report about not being able to flash from OEM.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.