WRT1900AC - Random reboots

idk what to say, just had a random reboot, so maybe i marked as solved a little early, ill keep monitoring and updating this post
yesterday i needed to downgrade a driver due to timeouts (see this post for more details on why, Problems with wifi connection)

maybe that is the root cause

ya, it happened again in the middle of the night, issue is NOT solved :frowning:

Curious how you know that your router rebooted in the middle of the night? What problem did this cause you? If my router were to reboot at say 2am I'd probably never know it except that I send my logs to a separate log server. In other words, the router comes back up and is functioning normally. Since you have detected that it rebooted I'm guessing there's "something wrong" can you describe what it's doing? it may give a clue about what causes the reboots.

1 Like

i monitor uptime and logs. Its not always in the middle of the night (though it did happen again last night :frowning: ). I work from home and am in meetings often, so random reboots are a show stopper for me. plus this is "suppose" to be stable, but that doesnt seem to be the case for my device.

I wish i had more concrete information in hopes of a resolution but this whole post started on how to get more information on random reboots and was redirected to reloading.

im sure there is a bug somewhere but i guess i need to test more to find the root cause.
I think it has to do with the driver for the wrt1900ac but even that im not sure on. especially since today my rsync backup script caused another reboot (and the one from last night might be from the scheduled running of that same script). saying that however it ran 8 days without problem (backup scrip included) until i downgraded the driver [due to timeouts in wifi connectivity, see link above]

anyways ill try to investigate further when i have time.

Got it. That makes good sense. I have a WRT1900acsv2 and it never reboots randomly. I find that if I power cycle it every few weeks it prevents some weirdness with wifi eventually becoming mildly unstable (android devices start to constantly reassociate). It doesn't seem like it's enough to reboot it, it actually needs to power cycle. So every couple of weeks or so I power cycle it in the morning. It's not my router though, it's just a fancy AP. If I do this power cycle thing it's pretty rock solid.

EDIT: in case it's not obvious I'm not advocating switching hardware, but rather that your hardware should be able to be pretty darn stable for weeks at a time, but you might want to actually power cycle it every so often.

From your post in the thread of the community build, this thread is the one where the idle issue was resolved. That fix is in master and all the 18.x stable releases.

1 Like

but Davidc502 in post (Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds) is saying I need to upgrade to 18.06.02. Which leads me to think its not fixed in 18.06.01.

Well, the 18.06.1 git log would be the definitive resource. This fix, but no reason to stay on .1 release, but I would not expect it to resolve the issue at hand.

1 Like

Seems to me, and I'm only going on memory, the issue wasn't resolved completely until 5 or 6 months ago. Time goes by so fast I could be way off and not know it.

When I search the git log, it appears a patch was created last March which would mean that .01 would have been covered (patched).

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=5faa9556b1c10a4b21208615bddb7480401fa213

However, it seems to me people were still having issues with .01. This was a post from last December.

Bottom line is, and I agree with you, there is no reason to stay on .01.

1 Like

its funny cuz for 18.06 and 18.06.01 i was watching the boards every day religiously waiting for their release but 02 i missed it completely

at the start of this post i reloaded, and it took a few days maybe even a couple weeks to really start happening (though i will say it seemed to progressively get worse, as it started happening alot more frequently)

but ill report back my results

thanks all!

somewhat of a side question here
does .02 include the latest mwlwifi drivers and firmware?

normally i wait to see timeouts before installing the latest mwlwifi drivers and firmware from:(https://github.com/eduperez/mwlwifi_LEDE/releases)

  • kmod-mwlwifi_4.14.63+10.3.8.0-20181112-e5e07002-1_arm_cortex-a9_vfpv3.ipk
  • mwlwifi-firmware-88w8864_10.3.8.0-20181112-e5e07002-1_arm_cortex-a9_vfpv3.ipk

when i look at whats installed i see:
kmod-mwlwifi 4.14.95+2018-11-14-81..9-1
mwlwifi-firmware-88w8864 2018-11-14-81413aa9-1

so it looks like the included driver and firmware is newer 4.14.95 vs 4.14.63 and 2018-11-14 vs 20181112

but these seem to be a generic driver and so idk if maybe the ones from the eduperez are better for my device?

my understanding is that as of today (mid Feb 2019) yes the latest drivers are already in 18.06.02

2 Likes

https://openwrt.org/releases/18.06/changelog-18.06.2#wirelessmt76_10_changes
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=6e16dd1234ea4814af2b46a22b4aea111baef3ab

1 Like

Actually, this commit is the one of interest. If you check the mwlwifi repository there are a few commits after that version, but nothing of interest for this device, which I assume is the reason no-one has bothered to push any of those commits. And there is not really such a thing as generic mwlwifi driver; or, you have the latest and greatest.

1 Like

still having random reboots :frowning:
idk what to do
do you guys think there is any reason in me buying a used wrt1900acs ?
been looking on ebay and they arnt too bad price wise
i just really dont want to spend the money and end up back in the same place

What do you have installed other than base config?

try opkg list-installed

adblock - 3.5.5-3
base-files - 194.2-r7676-cddd7b4c77
block-mount - 2018-12-28-af93f4b8-3
busybox - 1.28.4-2
ca-bundle - 20180409-2
ddns-scripts - 2.7.8-1
dnsmasq - 2.80-1.2
dropbear - 2017.75-7.1
e2fsprogs - 1.44.1-1
f2fs-tools - 1.10.0-1
f2fsck - 1.10.0-1
firewall - 2018-08-13-1c4d5bcd-1
fstools - 2018-12-28-af93f4b8-3
fwtool - 1
hostapd-common - 2018-05-21-62566bc2-5
ip6tables - 1.6.2-1
iptables - 1.6.2-1
iw - 4.14-1
iwinfo - 2018-07-31-65b8333f-1
jshn - 2018-07-25-c83a84af-2
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 4.14.95-1-8d45bc4124b425e568ca3ec03511914e
kmod-cfg80211 - 4.14.95+2017-11-01-9
kmod-crypto-crc32 - 4.14.95-1
kmod-crypto-crc32c - 4.14.95-1
kmod-crypto-hash - 4.14.95-1
kmod-fs-ext4 - 4.14.95-1
kmod-fs-f2fs - 4.14.95-1
kmod-gpio-button-hotplug - 4.14.95-2
kmod-ip6tables - 4.14.95-1
kmod-ipt-conntrack - 4.14.95-1
kmod-ipt-core - 4.14.95-1
kmod-ipt-nat - 4.14.95-1
kmod-ipt-offload - 4.14.95-1
kmod-lib-crc-ccitt - 4.14.95-1
kmod-lib-crc16 - 4.14.95-1
kmod-mac80211 - 4.14.95+2017-11-01-9
kmod-mwlwifi - 4.14.95+2018-11-14-81413aa9-1
kmod-nf-conntrack - 4.14.95-1
kmod-nf-conntrack6 - 4.14.95-1
kmod-nf-flow - 4.14.95-1
kmod-nf-ipt - 4.14.95-1
kmod-nf-ipt6 - 4.14.95-1
kmod-nf-nat - 4.14.95-1
kmod-nf-reject - 4.14.95-1
kmod-nf-reject6 - 4.14.95-1
kmod-nls-base - 4.14.95-1
kmod-ppp - 4.14.95-1
kmod-pppoe - 4.14.95-1
kmod-pppox - 4.14.95-1
kmod-scsi-core - 4.14.95-1
kmod-slhc - 4.14.95-1
kmod-usb-core - 4.14.95-1
kmod-usb-ehci - 4.14.95-1
kmod-usb-storage - 4.14.95-1
kmod-usb-storage-extras - 4.14.95-1
kmod-usb-storage-uas - 4.14.95-1
kmod-usb2 - 4.14.95-1
kmod-usb3 - 4.14.95-1
libblkid - 2.32-2
libblobmsg-json - 2018-07-25-c83a84af-2
libbz2 - 1.0.6-4
libc - 1.1.19-1
libcomerr - 1.44.1-1
libcurl - 7.60.0-3
libevent2 - 2.0.22-1
libexif - 0.6.21-1
libext2fs - 1.44.1-1
libf2fs - 1.10.0-1
libffmpeg-mini - 3.2.12-3
libflac - 1.3.2-1
libgcc - 7.3.0-1
libid3tag - 0.15.1b-4
libip4tc - 1.6.2-1
libip6tc - 1.6.2-1
libiwinfo - 2018-07-31-65b8333f-1
libiwinfo-lua - 2018-07-31-65b8333f-1
libjpeg - 9a-1
libjson-c - 0.12.1-2
libjson-script - 2018-07-25-c83a84af-2
liblua - 5.1.5-1
liblucihttp - 2018-05-18-cb119ded-1
liblucihttp-lua - 2018-05-18-cb119ded-1
libmbedtls - 2.14.1-1
libminiupnpc - 2.0.20170509-1
libnatpmp - 20150609-1
libnl-tiny - 0.1-5
libogg - 1.3.2-2
libopenssl - 1.0.2q-1
libpopt - 1.16-1
libpthread - 1.1.19-1
librt - 1.1.19-1
libsqlite3 - 3260000-2
libss - 1.44.1-1
libubox - 2018-07-25-c83a84af-2
libubus - 2018-10-06-221ce7e7-1
libubus-lua - 2018-10-06-221ce7e7-1
libuci - 2018-08-11-4c8b4d6e-1
libuclient - 2018-11-24-3ba74ebc-1
libusb-1.0 - 1.0.22-1
libuuid - 2.32-2
libvorbis - 1.3.6-1
libxtables - 1.6.2-1
logd - 2018-02-14-128bc35f-2
lua - 5.1.5-1
luci - git-19.020.41695-6f6641d-1
luci-app-commands - git-19.046.40869-30d9bc0-1
luci-app-ddns - 2.4.9-3
luci-app-firewall - git-19.020.41695-6f6641d-1
luci-app-minidlna - git-19.043.27302-23029f5-1
luci-app-samba - git-19.043.27302-23029f5-1
luci-app-transmission - git-19.043.27302-23029f5-1
luci-base - git-19.020.41695-6f6641d-1
luci-lib-ip - git-19.020.41695-6f6641d-1
luci-lib-jsonc - git-19.020.41695-6f6641d-1
luci-lib-nixio - git-19.020.41695-6f6641d-1
luci-mod-admin-full - git-19.020.41695-6f6641d-1
luci-proto-ipv6 - git-19.020.41695-6f6641d-1
luci-proto-ppp - git-19.020.41695-6f6641d-1
luci-theme-bootstrap - git-19.020.41695-6f6641d-1
minidlna - 1.2.1-3
mkf2fs - 1.10.0-1
mtd - 23
mwlwifi-firmware-88w8864 - 2018-11-14-81413aa9-1
netifd - 2018-11-19-4b83102d-2
odhcp6c - 2018-07-14-67ae6a71-15
odhcpd-ipv6only - 1.15-3
openssh-sftp-server - 7.7p1-1
openwrt-keyring - 2018-05-18-103a32e9-1
opkg - 2019-01-18-7708a01a-1
ppp - 2.4.7-12
ppp-mod-pppoe - 2.4.7-12
procd - 2018-03-28-dfb68f85-1
rpcd - 2018-11-28-3aa81d0d-1
rpcd-mod-rrdns - 20170710
rsync - 3.1.3-1
samba36-server - 3.6.25-12
swconfig - 11
transmission-daemon-openssl - 2.93-7
ubi-utils - 2.0.2-1
uboot-envtools - 2018.03-1
ubox - 2018-02-14-128bc35f-2
ubus - 2018-10-06-221ce7e7-1
ubusd - 2018-10-06-221ce7e7-1
uci - 2018-08-11-4c8b4d6e-1
uclient-fetch - 2018-11-24-3ba74ebc-1
uhttpd - 2018-11-28-cdfc902a-2
usbutils - 007-9
usign - 2015-07-04-ef641914-1
wireless-regdb - 2017-10-20-4343d359
wpad-mini - 2018-05-21-62566bc2-5
zlib - 1.2.11-2

Are you using flow offload?

not to my knowledge (maybe a dependency for something else)

Under Luci in the interfaces section see if flow offload is checked.

1 Like