Wrt1900ac - guest wifi causes instability


#1

Hi, I recently purchased a Linksys WRT1900AC router.First thing I did was to install the latest stable version, v18.06.1(prior to v18.06.2) of Openwrt on the device. But I have noticed that router becomes unreachable sometimes through Wi-Fi. Ping times spike to 1 second, 2 seconds, etc, returns to normal after a while and then it happens again. So I did a factory reset and ran a vanilla v18.06.1 with no additions to see what happens. The router ran without any problems for 4 straight days. I then enabled guest Wifi late last evening. Work up this morning and noticed the problem had resurfaced. So I think we can safely say the issues is caused only when guest wifi in enabled. I have about 15 devices connected to my router, many of them IoT devices and occasionally 3-5 guest devices. Any idea what could be the cause of this issue? I have attached my system log below. Mac Addresses replaced with [MAC Address] for security.

Mon Feb 11 11:23:52 2019 kern.debug kernel: [27683.658635] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:23:52 2019 kern.debug kernel: [27683.666204] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:23:52 2019 kern.debug kernel: [27683.675577] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:23:52 2019 kern.debug kernel: [27683.684853] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:23:52 2019 kern.debug kernel: [27683.693598] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0-1: AP-DISABLED
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0-1: CTRL-EVENT-TERMINATING
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Interface wlan0-1.IPv6 no longer relevant for mDNS.
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Leaving mDNS multicast group on interface wlan0-1.IPv6 with address fe80::225:9cff:fe13:1d41.
Mon Feb 11 11:24:11 2019 daemon.notice netifd: Network device 'wlan0-1' link is down
Mon Feb 11 11:24:11 2019 daemon.notice netifd: Interface 'GUEST' has link connectivity loss
Mon Feb 11 11:24:11 2019 daemon.notice netifd: Interface 'GUEST' is now down
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Interface wlan0-1.IPv4 no longer relevant for mDNS.
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Leaving mDNS multicast group on interface wlan0-1.IPv4 with address 192.168.5.1.
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Withdrawing address record for fe80::225:9cff:fe13:1d41 on wlan0-1.
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Withdrawing address record for 192.168.5.1 on wlan0-1.
Mon Feb 11 11:24:11 2019 daemon.notice netifd: Interface 'GUEST' is disabled
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Feb 11 11:24:11 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Feb 11 11:24:11 2019 kern.info kernel: [27702.716718] device wlan0 left promiscuous mode
Mon Feb 11 11:24:11 2019 kern.info kernel: [27702.721340] br-lan: port 2(wlan0) entered disabled state
Mon Feb 11 11:24:11 2019 kern.debug kernel: [27702.736601] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:11 2019 daemon.notice netifd: Network device 'wlan0' link is down
Mon Feb 11 11:24:11 2019 kern.debug kernel: [27703.051494] ieee80211 phy0: change: 0x40
Mon Feb 11 11:24:11 2019 kern.debug kernel: [27703.140486] ieee80211 phy0: change: 0x100
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Interface wlan0.IPv6 no longer relevant for mDNS.
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::9610:3eff:fe01:6143.
Mon Feb 11 11:24:11 2019 daemon.info avahi-daemon[4155]: Withdrawing address record for fe80::9610:3eff:fe01:6143 on wlan0.
Mon Feb 11 11:24:12 2019 user.notice mac80211: Failed command: iw phy phy0 set antenna all all
Mon Feb 11 11:24:12 2019 daemon.notice netifd: radio0 (23962): command failed: Not supported (-95)
Mon Feb 11 11:24:12 2019 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Mon Feb 11 11:24:12 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Mon Feb 11 11:24:12 2019 kern.debug kernel: [27703.744020] ieee80211 phy0: change: 0xffffffff
Mon Feb 11 11:24:12 2019 kern.info kernel: [27703.849648] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mon Feb 11 11:24:12 2019 kern.info kernel: [27703.863049] br-lan: port 2(wlan0) entered blocking state
Mon Feb 11 11:24:12 2019 kern.info kernel: [27703.868440] br-lan: port 2(wlan0) entered disabled state
Mon Feb 11 11:24:12 2019 kern.info kernel: [27703.874191] device wlan0 entered promiscuous mode
Mon Feb 11 11:24:12 2019 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Feb 11 11:24:12 2019 daemon.err hostapd: Using interface wlan0 with hwaddr [MAC ADDRESS] and ssid "EDGAR"
Mon Feb 11 11:24:12 2019 kern.debug kernel: [27704.004470] ieee80211 phy0: change: 0x100
Mon Feb 11 11:24:12 2019 kern.debug kernel: [27704.013508] ieee80211 phy0: change: 0x42
Mon Feb 11 11:24:12 2019 kern.info kernel: [27704.200225] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mon Feb 11 11:24:12 2019 kern.info kernel: [27704.206853] br-lan: port 2(wlan0) entered blocking state
Mon Feb 11 11:24:12 2019 kern.info kernel: [27704.212195] br-lan: port 2(wlan0) entered forwarding state
Mon Feb 11 11:24:13 2019 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
Mon Feb 11 11:24:13 2019 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Feb 11 11:24:13 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:13 2019 daemon.notice netifd: Network device 'wlan0' link is up
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[11073]: exiting on receipt of SIGTERM
Mon Feb 11 11:24:13 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 1)
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: started, version 2.80 cachesize 150
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: DNS service limited to local subnets
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq-dhcp[24248]: DHCP, IP range 192.168.31.100 -- 192.168.31.249, lease time 12h
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain test
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain onion
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain localhost
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain local
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain invalid
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain bind
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain lan
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: reading /tmp/resolv.conf.auto
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain test
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain onion
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain localhost
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain local
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain invalid
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain bind
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using local addresses only for domain lan
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using nameserver 208.94.176.20#53
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: using nameserver 208.94.176.18#53
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: read /etc/hosts - 4 addresses
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: read /tmp/hosts/odhcpd - 3 addresses
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq[24248]: read /tmp/hosts/dhcp.cfg01411c - 8 addresses
Mon Feb 11 11:24:13 2019 daemon.info dnsmasq-dhcp[24248]: read /etc/ethers - 0 addresses
Mon Feb 11 11:24:13 2019 user.info : dnscrypt-proxy - [fvz-anyone] does not support DNS Security Extensions
Mon Feb 11 11:24:13 2019 user.info : dnscrypt-proxy + Provider supposedly doesn't keep logs
Mon Feb 11 11:24:13 2019 daemon.notice dnscrypt-proxy[24269]: dnscrypt-proxy Starting dnscrypt-proxy 1.9.5
Mon Feb 11 11:24:13 2019 daemon.info dnscrypt-proxy[24269]: dnscrypt-proxy Generating a new session key pair
Mon Feb 11 11:24:13 2019 daemon.info dnscrypt-proxy[24269]: dnscrypt-proxy Done
Mon Feb 11 11:24:14 2019 daemon.info avahi-daemon[4155]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::9610:3eff:fe01:6143.
Mon Feb 11 11:24:14 2019 daemon.info avahi-daemon[4155]: New relevant interface wlan0.IPv6 for mDNS.
Mon Feb 11 11:24:14 2019 daemon.info avahi-daemon[4155]: Registering new address record for fe80::9610:3eff:fe01:6143 on wlan0.*.
Mon Feb 11 11:24:14 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:14 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:14 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:14 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 2)
Mon Feb 11 11:24:14 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:14 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 3)
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 4)
Mon Feb 11 11:24:15 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:15 2019 daemon.warn odhcpd[2525]: DHCPV6 CONFIRM IA_NA from 000100011fefc5681c1b0d68b7f4 on br-lan: not on-link fd2b:450c:96dc::d18/128
Mon Feb 11 11:24:15 2019 daemon.warn odhcpd[2525]: DHCPV6 SOLICIT IA_NA from 000100011fefc5681c1b0d68b7f4 on br-lan: ok fd2b:450c:96dc::d18/128
Mon Feb 11 11:24:15 2019 daemon.info dnsmasq[24248]: read /etc/hosts - 4 addresses
Mon Feb 11 11:24:15 2019 daemon.info dnsmasq[24248]: read /tmp/hosts/odhcpd - 2 addresses
Mon Feb 11 11:24:15 2019 daemon.info dnsmasq[24248]: read /tmp/hosts/dhcp.cfg01411c - 8 addresses
Mon Feb 11 11:24:15 2019 daemon.info dnsmasq-dhcp[24248]: read /etc/ethers - 0 addresses
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 5)
Mon Feb 11 11:24:15 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:15 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.226 [MAC ADDRESS]
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.226 [MAC ADDRESS]
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.226 [MAC ADDRESS] ESP_AB1500
Mon Feb 11 11:24:16 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 6)
Mon Feb 11 11:24:16 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 7)
Mon Feb 11 11:24:16 2019 daemon.warn odhcpd[2525]: DHCPV6 REQUEST IA_NA from 000100011fefc5681c1b0d68b7f4 on br-lan: ok fd2b:450c:96dc::d18/128
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq[24248]: read /etc/hosts - 4 addresses
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq[24248]: read /tmp/hosts/odhcpd - 3 addresses
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq[24248]: read /tmp/hosts/dhcp.cfg01411c - 8 addresses
Mon Feb 11 11:24:16 2019 daemon.info dnsmasq-dhcp[24248]: read /etc/ethers - 0 addresses
Mon Feb 11 11:24:16 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:16 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.208 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.208 [MAC ADDRESS] amazon-2ea13ca47
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.199 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.199 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.199 [MAC ADDRESS] sonoff-rfbridge-0417
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 8)
Mon Feb 11 11:24:17 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.179 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.179 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.179 [MAC ADDRESS] kidsroom
Mon Feb 11 11:24:17 2019 kern.debug kernel: [27708.703185] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.160 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.160 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.160 [MAC ADDRESS] ESP_Easy_0
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 9)
Mon Feb 11 11:24:17 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 10)
Mon Feb 11 11:24:17 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.200 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.200 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.200 [MAC ADDRESS] amcrest
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.172 [MAC ADDRESS]
Mon Feb 11 11:24:17 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.172 [MAC ADDRESS] roku
Mon Feb 11 11:24:18 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.240 [MAC ADDRESS]
Mon Feb 11 11:24:18 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.240 [MAC ADDRESS] skylake
Mon Feb 11 11:24:19 2019 kern.debug kernel: [27710.344958] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:19 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:19 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.218 [MAC ADDRESS]
Mon Feb 11 11:24:19 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.218 [MAC ADDRESS]
Mon Feb 11 11:24:19 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.218 [MAC ADDRESS] sonoff-switch-6249
Mon Feb 11 11:24:19 2019 kern.debug kernel: [27710.914621] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:21 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.200 [MAC ADDRESS]
Mon Feb 11 11:24:21 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.200 [MAC ADDRESS] amcrest
Mon Feb 11 11:24:22 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.240 [MAC ADDRESS]
Mon Feb 11 11:24:22 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.240 [MAC ADDRESS] skylake
Mon Feb 11 11:24:24 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:24 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 11)
Mon Feb 11 11:24:24 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:24 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:24 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:24 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.201 [MAC ADDRESS]
Mon Feb 11 11:24:24 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.201 [MAC ADDRESS]
Mon Feb 11 11:24:24 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.201 [MAC ADDRESS] Google-Home-Mini
Mon Feb 11 11:24:25 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:25 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 12)
Mon Feb 11 11:24:26 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:26 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:26 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.118 [MAC ADDRESS]
Mon Feb 11 11:24:26 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.118 [MAC ADDRESS] kindle-cfea66977
Mon Feb 11 11:24:30 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:30 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 13)
Mon Feb 11 11:24:31 2019 kern.debug kernel: [27722.425121] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:31 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:31 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:24:31 2019 kern.debug kernel: [27722.676720] ieee80211 phy0: Stop BA [MAC ADDRESS]
Mon Feb 11 11:24:33 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:33 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.131 [MAC ADDRESS]
Mon Feb 11 11:24:33 2019 kern.debug kernel: [27724.707686] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:24:33 2019 kern.debug kernel: [27725.206745] ieee80211 phy0: Stop BA [MAC ADDRESS]
Mon Feb 11 11:24:35 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:35 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.131 [MAC ADDRESS]
Mon Feb 11 11:24:35 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:35 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.171 [MAC ADDRESS]
Mon Feb 11 11:24:35 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.171 [MAC ADDRESS]
Mon Feb 11 11:24:35 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.171 [MAC ADDRESS] XiaoMiRepeater_V2
Mon Feb 11 11:24:38 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:24:38 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.131 [MAC ADDRESS]
Mon Feb 11 11:24:39 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.131 [MAC ADDRESS]
Mon Feb 11 11:24:39 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.131 [MAC ADDRESS] esp8266_AC7B34
Mon Feb 11 11:24:41 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:24:41 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 14)
Mon Feb 11 11:24:41 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:24:41 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:25:00 2019 cron.info crond[2551]: USER root pid 29226 cmd /sbin/fan_ctrl.sh
Mon Feb 11 11:28:15 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.108 [MAC ADDRESS]
Mon Feb 11 11:28:15 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.108 [MAC ADDRESS] foscam
Mon Feb 11 11:30:00 2019 cron.info crond[2551]: USER root pid 28845 cmd /sbin/fan_ctrl.sh
Mon Feb 11 11:32:01 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:32:01 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 15)
Mon Feb 11 11:32:01 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:32:01 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:32:02 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.241 [MAC ADDRESS]
Mon Feb 11 11:32:02 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.241 [MAC ADDRESS] amazon-ac332cf73
Mon Feb 11 11:35:00 2019 cron.info crond[2551]: USER root pid 28458 cmd /sbin/fan_ctrl.sh
Mon Feb 11 11:36:26 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:36:26 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:36:26 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 3)
Mon Feb 11 11:36:27 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:36:27 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:36:28 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:36:28 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.200 [MAC ADDRESS]
Mon Feb 11 11:36:29 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.200 [MAC ADDRESS]
Mon Feb 11 11:36:29 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.200 [MAC ADDRESS] amcrest
Mon Feb 11 11:38:22 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.108 [MAC ADDRESS]
Mon Feb 11 11:38:22 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.108 [MAC ADDRESS] foscam
Mon Feb 11 11:40:00 2019 cron.info crond[2551]: USER root pid 28141 cmd /sbin/fan_ctrl.sh
Mon Feb 11 11:40:05 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: authenticated
Mon Feb 11 11:40:05 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: associated (aid 16)
Mon Feb 11 11:40:06 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED [MAC ADDRESS]
Mon Feb 11 11:40:06 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] WPA: pairwise key handshake completed (RSN)
Mon Feb 11 11:40:06 2019 daemon.info dnsmasq-dhcp[24248]: DHCPDISCOVER(br-lan) [MAC ADDRESS]
Mon Feb 11 11:40:06 2019 daemon.info dnsmasq-dhcp[24248]: DHCPOFFER(br-lan) 192.168.31.153 [MAC ADDRESS]
Mon Feb 11 11:40:06 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.153 [MAC ADDRESS]
Mon Feb 11 11:40:06 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.153 [MAC ADDRESS]
Mon Feb 11 11:40:07 2019 kern.debug kernel: [28659.065707] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:08 2019 kern.debug kernel: [28659.840729] ieee80211 phy0: Stop BA [MAC ADDRESS]
Mon Feb 11 11:40:08 2019 kern.debug kernel: [28660.233280] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.290245] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.330070] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.369962] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.410274] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.450349] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.470775] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.529870] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.560085] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.609906] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.650243] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.680235] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.719948] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.769947] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.809834] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28660.849806] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:09 2019 kern.debug kernel: [28661.242144] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:12 2019 kern.debug kernel: [28663.550776] ieee80211 phy0: Stop BA [MAC ADDRESS]
Mon Feb 11 11:40:20 2019 kern.debug kernel: [28671.665440] ieee80211 phy0: Mac80211 start BA [MAC ADDRESS]
Mon Feb 11 11:40:21 2019 kern.debug kernel: [28672.730903] ieee80211 phy0: Stop BA [MAC ADDRESS]
Mon Feb 11 11:42:22 2019 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED [MAC ADDRESS]
Mon Feb 11 11:42:22 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: disassociated due to inactivity
Mon Feb 11 11:42:23 2019 daemon.info hostapd: wlan0: STA [MAC ADDRESS] IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Mon Feb 11 11:45:00 2019 cron.info crond[2551]: USER root pid 25527 cmd /sbin/fan_ctrl.sh
Mon Feb 11 11:48:29 2019 daemon.info dnsmasq-dhcp[24248]: DHCPREQUEST(br-lan) 192.168.31.108 [MAC ADDRESS]
Mon Feb 11 11:48:29 2019 daemon.info dnsmasq-dhcp[24248]: DHCPACK(br-lan) 192.168.31.108 [MAC ADDRESS] foscam
Mon Feb 11 11:50:00 2019 cron.info crond[2551]: USER root pid 25196 cmd /sbin/fan_ctrl.sh



#2

Post you config files here, perhaps there is a routing issue or a conflict of addresses.

Also, I have seen some IoT devices DoS-ing the network when they could not reach an external server.


#3

Thanks for the reply. I have noticed the following line in my system log about a "possible DNS-rebind attack detected". Don't know if this harmful:

Mon Feb 11 11:16:56 2019 kern.debug kernel: [27268.188952] ieee80211 phy0: Mac80211 start BA 4c:4e:03:82:20:0e
Mon Feb 11 11:16:56 2019 kern.debug kernel: [27268.218932] ieee80211 phy0: Mac80211 start BA 4c:4e:03:82:20:0e
Mon Feb 11 11:17:08 2019 daemon.warn dnsmasq[11073]: possible DNS-rebind attack detected: gwrtdp-tn690bfadt-drop.aotclouds.net
Mon Feb 11 11:17:16 2019 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED a8:a1:98:9a:f9:0a
Mon Feb 11 11:17:16 2019 daemon.info hostapd: wlan0-1: STA a8:a1:98:9a:f9:0a IEEE 802.11: authenticated
Mon Feb 11 11:17:18 2019 daemon.warn dnsmasq[11073]: possible DNS-rebind attack detected: gwrtdp-tn690bfadt-drop.aotclouds.net
Mon Feb 11 11:17:18 2019 kern.debug kernel: [27289.746162] ieee80211 phy0: Mac80211 start BA 4c:4e:03:82:20:0e
Mon Feb 11 11:17:18 2019 kern.debug kernel: [27289.789270] ieee80211 phy0: Mac80211 start BA 4c:4e:03:82:20:0e

Which config files would you like me to upload? I don't see the option to attach files to a post here. Anyway, I have included below, my DHCP and WIRELESS config. Please let me know if you need anymore.

DHCP(Mac Address Masked):

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name 'odroidxu4'
	option dns '1'
	option mac 'REMOVED:eb'
	option ip '192.168.31.192'

config host
	option name 'sv3c'
	option dns '1'
	option mac 'REMOVED:40'
	option ip '192.168.31.124'

config host
	option name 'amcrest'
	option dns '1'
	option mac 'REMOVED:d2'
	option ip '192.168.31.200'

config host
	option name 'roku'
	option dns '1'
	option mac 'REMOVED:b9'
	option ip '192.168.31.172'

config host
	option name 'foscam'
	option dns '1'
	option mac 'REMOVED:38'
	option ip '192.168.31.108'

config host
	option name 'skylake'
	option dns '1'
	option mac 'REMOVED:ca'
	option ip '192.168.31.240'

config dhcp 'GUEST'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'GUEST'

WIRELESS CONFIG


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/soc:pcie@82000000/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr 'REMOVED'
	option encryption 'psk2+ccmp'
	option ssid 'test'
	option key 'test1234'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/soc:pcie@82000000/pci0000:00/0000:00:03.0/0000:03:00.0'
	option htmode 'VHT80'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option macaddr 'REMOVED'
	option encryption 'psk2+ccmp'
	option key 'password'
	option disabled '1'

config wifi-iface
	option encryption 'none'
	option device 'radio0'
	option mode 'ap'
	option ssid 'COCOLOVE GUEST'
	option network 'GUEST'
	option disabled '1'



#4

Not sure why 18.06.1, but iirc this issue was partially addressed in a later version of mwlwifi, which should be there OOTB in 18.06.2.


#5

Ummm, @anomeome, you said "partially addressed"? I'm not sure I really understand you. Btw, isn't @eduperez, who commented above, the official maintainer of the mwlwifi driver? Hopefully, he can shed some more light on this issue?


#6

No, here is the repository, and if you look at the closed issues on that site I think you will find some like you are experiencing. At any rate, I would start by getting onto the latest mwlwifi.


#7

Ok. Will do that and report back. I went though the Git repo you posted and I did see some issues with multiple SSID's on one interface on older mwlwifi drivers. Let's see how it goes on v18.06.2.


#8

Could you also post the contents of your /etc/config/network file, where you set up the interface that you are calling GUEST?


#9

Here it is. The guest network was created using instructions from the OpenWrt user guide here

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2b:450c:96dc::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.31.1'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config interface 'GUEST'
	option proto 'static'
	option ipaddr '192.168.5.1'
	option netmask '255.255.255.0'

#10

Hmm, those instructions seem correct but a bit outdated, and might need a small amount of updating. For example, it's generally recommended that you isolate all of the clients from each other on a guest network. You can do this by either adding option isolate '1' to your wifi-face config in /etc/config/wireless, or if you are using LuCI, there is a checkbox that you can enable if you configure the wireless settings for GUEST and in the Interface Configuration section go to the Advanced tab, and enable the "Isolate Clients" checkbox.

This is discussed in these instructions, which is the page that the LuCI instructions you referenced are based on. You might want to go through this page to see whether the actions you performed in LuCI have resulted in config files that match up with what is shown there.


#11

Sorry, but I am not the maintainer of the mwlwifi drivers: those drivers are being maintained by Marvel themselves (at the repository linked by @anomeome), and I just compile whatever they publish into packages that can be installed on top of stable versions of OpenWrt.

Reading your config files, I see you are letting your GUEST wifi wide open... are you sure there isn't somebody around you abusing that connection?


#12

Ok guys. This is the status at the moment.

I did a clean installation of OpenWrt v18.06.2. Enabled the main 2.4Ghz wireless network and also the Guest network following the instructions here, as recommended by @dit_dah_dit. I have 15 devices connected to the main wireless and 1 device(android phone) connected to the guest. A few minutes(about 10 to 15min) later the wireless network begins to deteriorate, with large pings and network timeouts(to the router) on both the main wireless and the guest network. I disabled the guest network and everything is back to normal. What do I do now?


#13

Are you able to witness the deterioration the moment it starts happening? Try monitoring the logs by running tail -f /tmp/log/messages, and then turn on the guest network. As soon as the deterioration begins, do you start to see new/different log messages, or repeating log messages? And do those messages stop when you turn off the guest network?

The behavior that you are describing sounds suspiciously like what @eduperez was asking, and it sounds like some nearby device is abusing the guest connection. If that is the case, you may want to test that possibility by putting a password on the guest network and see whether the deterioration still occurs.


#14

I leave my guest wifi wide open too but I run SQM and limit my up and down speeds to a small fraction of my full bandwidth. You should try that


#15

So things go south when the android device is on, but are fine when it is not?


#16

@anomeome , yes, it seems to happen only when one or two android phones begin to connect. I noticed they are on the edge of the wireless, meaning signal to noise is is very low, like, 84/95. Could this be problematic - maybe causing the router to work too much to keep them connected?

@eduperez, I doubt it is too much pressure by the guest devices on my connection. I run the same setup with an EA3500 or a GL.iNet 300M and don't have these same problems.

@dit_dah_dit, I will attempt to do a live monitoring of the log as you suggested.


#17

At the same location? If someone connects to your guest wifi and starts to download a torrent, you will get this kind of behavior. If at a second location there is no pressure it will be fine there...

Check the realtime traffic graphs


#18

I check the realtime graphs all the time. No issues there. Also the problem isn't WAN based. When the issue pops up, it is device-router connectivity which breaks down on the wireless side.


#19

If the devices are on the edge of the signal region they are probably negotiating a very low bit-rate and may be dominating the air time at one megabits or something like that make sure you are disabling legacy rates


#20

Do you recognise/own all the Wireless Associated Stations