WRT1900AC - AR5BXB112 Not Recognized


I downloaded and flashed the latest stable version of OpenWRT (v22.03.2 r19803-9a599fee93) on my WRT1900AC v1 and am having trouble getting the ath9k wireless card I installed working (AR5BXB112). I used the 'customize packages' option from the website's firmware selector to build an image with the following packages:

base-files busybox ca-bundle curl ddns-scripts dnsmasq drill dropbear firewall4 fstools iwinfo kmod-gpio-button-hotplug kmod-ath9k kmod-nft-offload kmod-wireguard libc libgcc libustream-wolfssl logd lua luci luci-base luci-ssl luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-theme-bootstrap luci-app-firewall luci-app-ddns luci-app-opkg luci-app-wireguard luci-proto-ipv6 luci-proto-ppp liblua libubus libubus-lua libuci-lua mtd nano netifd nftables odhcp6c odhcpd-ipv6only opkg ppp ppp-mod-pppoe procd procd-seccomp procd-ujail rpcd uboot-envtools uci uclient-fetch uhttpd urandom-seed wireguard-tools urngd wpad-basic-wolfssl

When I first flashed the image, my wireless card was recognized but after rebooting once everything was configured I no longer have wireless. It was working before as I was able to connect wireless devices to my network before the reboot.

Nothing in dmesg output or the kernel log provides any info, grep'ing for 'ath' in the respective logs. Even reflashing/performing a factory reset does nothing to get the wireless card working.

Also, 'lspci' from the pciutils package does not list the device either.

Any suggestions on how to go about fixing this?

Did it work on earlier OpenWrt versions or are you trying to get this working for the first time (major difference in terms of debugging)?

Apart from this, I would start by flashing an OpenWrt release image and using opkg to install kmod-ath9k on the running system, rather using the imagebuilder (which might catch you out with unexpected dependency issues).

This is a new router for me so I haven't tried earlier OpenWRT versions per-se, though I did attempt using LibreCMC v1.5.7 first but had issues there as well (e.g. no IP address for the WAN interface, no wifi even with ath9k drivers installed).

I'll give this a go and report back. There won't be any security issues with having the router connected to the Internet before configuring the router password and ssh will there?

Does that tool allow you to exclude as well as include packages; i.e. any hint of the default radio bits. I suspect you may have to build things.

You should be fine leaving it connected as ports should not be open.

Not sure what you mean by hint on the default radio bits?

I tried both a sysupgrade and factory install image and neither made the wifi functional after installing kmod-ath9k and rebooting.

I'll take it back apart here in a bit and try swapping the wifi chip, though that's not ideal since I don't have another full-size chip (I made my own custom bracket for this device). At the very least that may provide a hint as to whether it's that specific chip.

Looks like it might be a short of some sort between the wifi chip and the heatsink beneath it. Maybe just not fastening it down as tight will fix it? I moved the chip to the adjacent pcie slot for testing.

EDIT: After testing with the chip moved to the other slot and experimenting with the tension placed on the bracket I've found that it is indeed a short. I'll have to place something between the chip and the heatsink!

Thank you for the help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.