Wrong firmware from firmware selector or wrong firmware worked

Hi guys, I had a weird issue and I would like to know what is going on before I risk bricking my router.

I have a Linksys EA4500v1. I am trying to upgrade from OpenWrt 21.02.1 to OpenWrt 22.03.3.
I used the firmware selector (link goes to the exact screen that I downloaded the file from) to select the correct firmware for my device. It said that the correct upgrade firmware file is "openwrt-22.03.3-kirkwood-linksys_ea4500-squashfs-sysupgrade.bin".

When I tried to upload it to my router, I got the following error message:

Image check failed:

Sun Mar 12 14:44:42 CDT 2023 upgrade: Device linksys,wrt1900ac-v1 not supported by this image Sun Mar 12 14:44:42 CDT 2023 upgrade: Supported devices: linksys,ea4500 linksys,viper linksys-viper Image check failed.

Here is a screenshot of the message I get:

In case it matters, according to my router's admin page the build info for my current OpenWRT version is:

Attribute Value
Model Linksys WRT1900AC v1
Architecture ARMv7 Processor rev 2 (v7l)
Target Platform mvebu/cortexa9
Firmware Version OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-22.335.71649-0ecaf74
Kernel Version 5.4.154

I noticed that the target platform is "mvebu/cortexa9", which is different from the target platform of the upgrade firmware ("kirkwood/generic"). But this firmware has worked just fine for me for a year. Should I ignore the upgrade warning and flash anyway, or do I need a different firmware?

These two devices seems to look very different, which one have you got?

Linksys WRT1900AC v1 : https://openwrt.org/toh/linksys/wrt1900ac
Linksys EA4500 v1 : https://openwrt.org/toh/linksys/ea4500

They are very different architectures, don't flash a not fitting one

1 Like

Thank you, @patient0 , I looked at the front panel of my router and it was indeed a WRT1900AC. Thank you for your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.