WR941ND v6 International - behaving in a weird way, maybe bricked?

I got my hands on a TL WR941ND v6 international, the owner doesn´t remember if at some point he installed a openwrt (maybe ddwrt) firmware. In other words, I donno what is running on the router.

The router is in a very weird state:

  • wifi doesn´t work
  • factory reset via button on the back of the router doesn't work
  • power led is steadily on
  • every 60 seconds (or something like that) all the lights turn on for 1s
  • tried to connect via ethernet to all the 4 lan ports and the wan port, the link goes up for a second and then goes down, the same happens every 10 seconds
  • tried to host a tftp with firmware, and boot the router with the reset button on, nothing happens
  • telnet doesn't work, nor http connection

What are my options here?

Connect to serial and see what is going on.


Thank you @tmomas

Just to be 100% sure,
looking at the image of the V6 of the board,
I see the TX,RX and GND. I guess I don't need to connect the +V as well. As long as the ground is shared among the router and the laptop I should be able to read the signal. This also mean that It doesn't matter if I use a 5v or a 3.3v converter.

Is that correct?

You must use 3.3 V, this refers to the signaling on the serial line.

You are right, the serial protocol use the TX,RX for the high voltage reference (in this case I guess the v6 is the same of the v3, hence the +3.3v)

Pretty much universally

  • Never connect V+
  • Always use a 3.3 V converter with a 3.3 V device

Using a 5 V converter will put 5 V on the logic inputs, which can be enough to fry them quicky.

Perfect, thanks everyone for confirming.

I wanted to use an arduino mega to read the serial of the router, but the TX pin is at 5.5v so that's a no no. I could use a resistor + diode to step down the voltage, but I guess, given the price, it's safer to go with one of those.