WPJ563 LAN port doesn't give out ip address

I installed OpenWrt to COMPEX WPJ563, but find that the LAN port doesn't work well.

When connect my computer to the LAN port of the router, my computer cannot obtain an IPv4 address for local area network in the format of "192.168.1.x".

Can anyone help offer some hint on this...Thanks

Let me add some of my debugging:

  • The LAN port works well on top of the original CompexWRT system, my computer can get an local area network IP address of "". So it cannot by some hardware problem of my router, and my computer works okay.

  • With OpenWRT system, if I use WLAN, the connected device can also get a local area network IP address. So I think the DHCP configuration of my router is correct.

In this case, what may be the problem? It's wierd.

Are you sure you are not using the WAN port instead?
Post your network config file here, please.

Just find out I am using WAN, so stupid........

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


If you kept your CompexWRT based config while installing OpenWrt, it's quite possible that the default configs differ - resulting in your observed behaviour. If you start with a clean OpenWrt default config instead, WAN and LAN are supposed to function according to their labels - however, for rarer devices like yours, subtle bugs can always arise (but those can be fixed as well).