Wpad 802.11w no longer working in trunk?

Not sure if it will mean anything, but removing ieee80211w from the config the radios will start normally with the following log messages:


Mon Oct  9 15:39:03 2017 daemon.info procd: - init complete -
Mon Oct  9 15:39:03 2017 kern.info kernel: [   19.304780] br-lan: port 1(eth0.1) entered forwarding state
Mon Oct  9 15:39:04 2017 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Mon Oct  9 15:39:04 2017 kern.info kernel: [   19.952065] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mon Oct  9 15:39:04 2017 kern.info kernel: [   19.989856] device wlan0 entered promiscuous mode
Mon Oct  9 15:39:04 2017 kern.info kernel: [   19.994649] br-lan: port 2(wlan0) entered forwarding state
Mon Oct  9 15:39:04 2017 kern.info kernel: [   20.000191] br-lan: port 2(wlan0) entered forwarding state
Mon Oct  9 15:39:04 2017 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Oct  9 15:39:04 2017 daemon.err hostapd: Using interface wlan0 with hwaddr 20:4e:7f:74:4f:00 and ssid "LEDE2"
Mon Oct  9 15:39:04 2017 kern.info kernel: [   20.035571] br-lan: port 2(wlan0) entered disabled state
Mon Oct  9 15:39:04 2017 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Mon Oct  9 15:39:04 2017 kern.info kernel: [   20.182114] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Mon Oct  9 15:39:04 2017 kern.info kernel: [   20.222709] device wlan1 entered promiscuous mode
Mon Oct  9 15:39:04 2017 kern.info kernel: [   20.227564] br-lan: port 3(wlan1) entered forwarding state
Mon Oct  9 15:39:04 2017 kern.info kernel: [   20.233059] br-lan: port 3(wlan1) entered forwarding state
Mon Oct  9 15:39:04 2017 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Oct  9 15:39:04 2017 daemon.err hostapd: Using interface wlan1 with hwaddr 20:4e:7f:74:4f:02 and ssid "LEDE5"
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.034797] br-lan: port 3(wlan1) entered disabled state
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.145366] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.151869] br-lan: port 2(wlan0) entered forwarding state
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.157448] br-lan: port 2(wlan0) entered forwarding state
Mon Oct  9 15:39:05 2017 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
Mon Oct  9 15:39:05 2017 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.345464] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.351982] br-lan: port 3(wlan1) entered forwarding state
Mon Oct  9 15:39:05 2017 kern.info kernel: [   21.357538] br-lan: port 3(wlan1) entered forwarding state
Mon Oct  9 15:39:05 2017 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ENABLED
Mon Oct  9 15:39:05 2017 daemon.notice hostapd: wlan1: AP-ENABLED
Mon Oct  9 15:39:05 2017 daemon.notice netifd: Network device 'wlan0' link is up
Mon Oct  9 15:39:05 2017 daemon.notice netifd: Network device 'wlan1' link is up
Mon Oct  9 15:39:07 2017 kern.info kernel: [   23.154764] br-lan: port 2(wlan0) entered forwarding state
Mon Oct  9 15:39:07 2017 kern.info kernel: [   23.354788] br-lan: port 3(wlan1) entered forwarding state

Compiled using Ubuntu 17.04 x64 and fresh pull of source.git. ieee80211w option continues to cause the radios to not start on WNDR3800. Same error message as in previous logs.

Compiled using the same Ubuntu 17.04 box and this time with a fresh pull from the libreCMC git (they re-based off LEDE 17.01) and ieee80211w works fine again on my WNDR3800.

https://bugs.lede-project.org/index.php?do=details&task_id=898

have you tried using hostapd instead?

I have same problem on wzr-hp-ag300h, builded on Ubuntu 17.04 x64, snapshot r5025.
When 80211w option removed, everything work well.
(logread |grep hostapd)
Tue Oct 10 18:07:56 2017 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Tue Oct 10 18:07:57 2017 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Oct 10 18:07:57 2017 daemon.err hostapd: Using interface wlan0 with hwaddr 4c:e6:76:xx:xx:xx and ssid "XXX"
Tue Oct 10 18:07:58 2017 daemon.err hostapd: Interface initialization failed
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->DISABLED
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Oct 10 18:07:58 2017 daemon.err hostapd: wlan0: Unable to setup interface.
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Tue Oct 10 18:07:58 2017 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Tue Oct 10 18:07:58 2017 daemon.notice hostapd: ELOOP: remaining socket: sock=20 eloop_data=0x777afec0 user_data=0 handler=0x4395dc
Tue Oct 10 18:08:09 2017 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Oct 10 18:08:09 2017 daemon.err hostapd: Using interface wlan0 with hwaddr 4c:e6:76:xx:xx:xx and ssid "XXX"
Tue Oct 10 18:08:09 2017 daemon.err hostapd: Interface initialization failed
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->DISABLED
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Oct 10 18:08:09 2017 daemon.err hostapd: wlan0: Unable to setup interface.
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Tue Oct 10 18:08:09 2017 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Tue Oct 10 18:08:09 2017 daemon.notice hostapd: ELOOP: remaining socket: sock=20 eloop_data=0x774c1ec0 user_data=0 handler=0x4395dc

Ok, the 11W setting is supposed to be enabled by passing a -DCONFIG_IEEE80211W cflag:

This should be working fine, if it wasn't for some checks in hostapd's makefiles:
http://w1.fi/cgit/hostap/tree/hostapd/Makefile#n286
Because the makefile doesn't know about cflags and will only care about the contents of the ".config"
which as you can see here:

disables the symbol - (it's commented out so the =y does nothing. + check out the git blame history of the 11W line there.)

Can you edit the hostapd-full.config file (remove the leading #) in your repository, recompile wpad and install the new package?

Yep.
root@AG300H:~# opkg list-installed |grep hostapd
hostapd-common - 2017-08-24-c2d4f2eb-1
root@AG300H:~# opkg list-installed |grep wpad
wpad - 2017-08-24-c2d4f2eb-1

Oops, I think I accidentally edited the previous reply, instead of making a new one.
Please see: Wpad 802.11w no longer working in trunk?

Hmm. That option in hostapd-full.config did not actually change recently, but instead wpa_supplicant-full.config did recently change due to this commit ( cc @stintel ):
https://git.lede-project.org/?p=source.git;a=commitdiff;h=65113799d734d4f6a2cf10f9d704a94b71340fbe

Commented CONFIG_IEEE80211W=y flag because it is
set in the Makefile, only if the driver supports it.

Removed NEED_80211_COMMON flag because it is not part
of config file, it is set by the hostapd upstream Makefile.

The curious part here is why this would affect only some users.

If I had to guess, it's probably because of
https://github.com/lede-project/source/commit/7865e86b0ebc226d9b3b8866acef68d69b60de9f

disabling CONFIG_WPS. But we won't know, unless someone reverts it and tests whenever ieee80211w=1 does work or not.

I'm edit hostapd-full.config and/or wpa_supplicant-full.config, recompiled&install but still not work.

(logread |grep wpad)
 daemon.notice netifd: radio0 (977): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path ()
(logread |grep hostapd)
daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
 daemon.notice hostapd: 20/40 MHz operation not permitted on channel pri=11 sec=7 based on overlapping BSSes
 daemon.err hostapd: Using interface wlan0 with hwaddr 4c:e6:76::xx:xx:xx and ssid "XXX"
 daemon.err hostapd: Interface initialization failed
 daemon.notice hostapd: wlan0: interface state HT_SCAN->DISABLED
 daemon.notice hostapd: wlan0: AP-DISABLED 
 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
 daemon.notice hostapd: wlan0: AP-DISABLED 
 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING 
 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
 daemon.notice hostapd: ELOOP: remaining socket: sock=20 eloop_data=0x77489e90 user_data=0 handler=0x4394d0

The problem has been reported to the Mailing-List.
http://lists.infradead.org/pipermail/lede-dev/2017-October/009262.html

Apparently, the issue started with:
"
author Hauke Mehrtens
Tue, 22 Aug 2017 21:59:48 +0000 (23:59 +0200)
committer Hauke Mehrtens
Sun, 1 Oct 2017 10:49:11 +0000 (12:49 +0200)
commit a8f63a0717f553e0a1b37ee9212fc4cb2a801426
mac80211: update to backports-4.14-rc2"

Let's see how this will play out.

What does WPS has to do with ieee80211w?
I think the problem is the newer version of hostapd

Nothing directly. But the CONFIG_WPS did set the NEED_SHA256 dependency in src/hostapd/Makefile (which CONFIG_IEEE80211W needs). Without CONFIG_WPS, this is no longer the case. But other options set it as well,
with any luck something else in the hostapd-full.config needs it too and sets it.

But If this error can really be traced to the the backports-4.14-rc2 patch, you could also try if installing the kmod-cmac module helps. (Note: the module will need to be loaded / (or you reboot the router). I know that mac80211 can request missing cipher modules at runtime and that this is working on a debian system with udev / systemd. But I haven't
verified that procd does it too ).

But in my commit i removed CONFIG_WPS2, not CONFIG_WPS...

I'm going to test the older hostapd version

Ok, just tested with older version of hostapd (2016-12-19) and it's NOT working.
So the problem may be really related to backports-4.14-rc2.

Felix has posted RFT on the mailing-list.

For me it's working again after this commit
https://github.com/lede-project/source/commit/609208597b6d18b0c1730f34685db73c859aa492

But now I have another problem LOL
The txpower now is alway at minimum...
With iwinfo phy0 txpower
i receive:

   0 dBm (   1 mW)
   1 dBm (   1 mW)
   2 dBm (   1 mW)
*  3 dBm (   1 mW)
   4 dBm (   2 mW)
   5 dBm (   3 mW)
   6 dBm (   3 mW)
   7 dBm (   5 mW)
   8 dBm (   6 mW)
   9 dBm (   7 mW)
  10 dBm (  10 mW)
  11 dBm (  12 mW)
  12 dBm (  15 mW)
  13 dBm (  19 mW)
  14 dBm (  25 mW)
  15 dBm (  31 mW)
  16 dBm (  39 mW)
  17 dBm (  50 mW)
  18 dBm (  63 mW)
  19 dBm (  79 mW)
  20 dBm ( 100 mW)
  21 dBm ( 125 mW)

Also if I try with iw phy phy0 set txpower fixed 1500 nothing changes

Well, you know what to do: Report your findings to the Mailing-List :wink: .